mythwelcome/mythfrontend crashed with SIGILL

Bug #201304 reported by sishgupta on 2008-03-12
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MythTV
Invalid
Unknown
mythtv (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: mythtv

Mythwelcome/frontend crashes with the 0.21 release of mythtv. It happened in both 7.10 and now it is happening in the latest 8.04.

Heres the console dump:
2008-03-12 02:35:54.008 New DB connection, total: 2
2008-03-12 02:35:54.009 Connected to database 'mythconverg' at host: localhost
2008-03-12 02:35:54.012 mythfrontend version: 0.21.20080304-1 www.mythtv.org
2008-03-12 02:35:54.012 Enabled verbose msgs: important general
2008-03-12 02:35:55.944 Total desktop dim: 1024x768, with 1 screen[s].
2008-03-12 02:35:55.958 Using screen 0, 1024x768 at 0,0
2008-03-12 02:35:55.962 Switching to square mode (G.A.N.T)
2008-03-12 02:35:56.040 Using the Qt painter
2008-03-12 02:35:56.054 lirc init success using configuration file: /home/sishgupta/.mythtv/lircrc
2008-03-12 02:35:56.054 JoystickMenuClient Error: Joystick disabled - Failed to open device
Illegal Instruction (core dumped)

I realize that this would be best submitted at the mythtv trac but I dont have the time to get all the information they ask for. Apport seems to save me a lot of time though, so i am submitting through this.

ProblemType: Crash
Architecture: i386
Date: Wed Mar 12 02:37:22 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/mythwelcome
NonfreeKernelModules: nvidia
Package: mythtv-frontend 0.21.0-0ubuntu2
PackageArchitecture: i386
ProcCmdline: mythwelcome
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
Signal: 4
SourcePackage: mythtv
Stacktrace:
 #0 0xb52f5300 in ?? () from /usr/lib/libGLcore.so.1
 #1 0xb2c37000 in ?? ()
 #2 0x00000000 in ?? ()
StacktraceTop:
 ?? () from /usr/lib/libGLcore.so.1
 ?? ()
 ?? ()
Title: mythwelcome crashed with SIGILL
Uname: Linux 2.6.24-12-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin mythtv plugdev sambashare video

sishgupta (sishgupta) wrote :
sishgupta (sishgupta) wrote :

I forgot to say that this happens upon launching mythfrontend or mythwelcome.

sishgupta (sishgupta) wrote :

After playing around, it seems to be related to X or my TV.
I can launch mythfrontend through SSH with xforwarding on my windows laptop.

StacktraceTop:?? () from /usr/lib/libGLcore.so.1
?? ()
?? ()

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in mythtv:
importance: Undecided → Medium
status: New → Incomplete
sishgupta (sishgupta) wrote :

Thanks Pedro.

I found the solution to my problem and it has little or nothing to do with mythtv.
The nvidia 169.xx drivers do not support CPU's with out SSE.

I have posted details here on the mythbuntu section of the ubuntu forums.
http://ubuntuforums.org/showpost.php?p=4504373&postcount=43

-sish

Changed in mythtv:
status: Incomplete → Invalid
Changed in mythtv:
status: Unknown → Invalid
Pavel Mlčoch (pavkamlc) wrote :

Ive this problem on actualy Intrepid nvidia drivers. I've GeForce 6150 LE card, CPU Athlon 64. It hapens on play DVD faster then 5x

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.