mythtv should not depend on gksu

Bug #1740620 reported by Jeremy Bicha on 2017-12-30
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
High
Unassigned

Bug Description

gksu has been deprecated and unmaintained for several years. It is recommended for app developers to use PolicyKit to run the specific actions that need elevated privileges instead of running the entire app as root.

Ubuntu 17.10's default desktop (a themed GNOME on Wayland) does not support gksu.

Therefore, Debian and Ubuntu intend to remove gksu soon. Please modify mythtv-frontend and mythtv-backend to not depend on gksu.

See also LP: #1740618

Jeremy Bicha (jbicha) on 2018-03-13
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mythtv (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :
Changed in mythtv (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers