Unable to install mythtv-frontend on 16.10

Bug #1641427 reported by Chris Shelton on 2016-11-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

The transcode package seems to have been removed with the 16.10 release, which causes mythtv-frontend to not be installable:

# aptitude install mythtv-frontend
The following NEW packages will be installed:
  mythtv-frontend{b} python-imaging{a} python-imdbpy{a} python-pil{a} wmctrl{a}
0 packages upgraded, 5 newly installed, 0 to remove and 38 not upgraded.
Need to get 1,686 kB of archives. After unpacking 7,345 kB will be used.
The following packages have unmet dependencies:
 mythtv-frontend : Depends: transcode which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) mythtv-frontend [Not Installed]

On http://packages.ubuntu.com/yakkety/mythtv-frontend, the transcode package is listed as a dependency for mythtv-frontend, and also listed as "Package not available".

summary: - Unable to install mythtv-frontend on yakkety
+ Unable to install mythtv-frontend on 16.10
Thomas Mashos (tgm4883) wrote :

Are you using the MythTV updates PPA by the Mythbuntu team?

Chris Shelton (cshelton1409) wrote :

No, I was just trying to install from the ubuntu yakkety/multiverse package. I was able to install mythtv-backend, but when trying to install mythtv-frontend, I encountered the broken dependency issue.

In case it helps, here are some details from the system that I am using:

root@zeus:/etc/apt# apt-cache policy mythtv-frontend
mythtv-frontend:
  Installed: (none)
  Candidate: 2:0.28.0+fixes.20160413.15cf421-0ubuntu2
  Version table:
     2:0.28.0+fixes.20160413.15cf421-0ubuntu2 500
        500 http://us.archive.ubuntu.com/ubuntu yakkety/multiverse amd64 Packages
root@zeus:/etc/apt# apt-cache policy mythtv-backend
mythtv-backend:
  Installed: 2:0.28.0+fixes.20160413.15cf421-0ubuntu2
  Candidate: 2:0.28.0+fixes.20160413.15cf421-0ubuntu2
  Version table:
 *** 2:0.28.0+fixes.20160413.15cf421-0ubuntu2 500
        500 http://us.archive.ubuntu.com/ubuntu yakkety/multiverse amd64 Packages
        100 /var/lib/dpkg/status

I am just starting on the setup for this system, and am certainly willing to switch to using the MythTV updates PPA by Mythbuntu, if their packages are not broken on 16.10.

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

I don't know whether this should be marked as a duplicate or not, but the underlying reason why this package is currently not installable is that transcode was removed from 15.10 (without checking reverse dependencies). It is now in the process of being re-introduced and is currently in yakkety-proposed. Please see bug 1631796 for more details.

Changed in mythtv (Ubuntu):
status: New → Confirmed
tags: added: yakkety
Hans Joachim Desserud (hjd) wrote :

Now that bug 1631796 has been resolved, transcode is available in Ubuntu 16.10, and mythtv-frontend is installable again.

Changed in mythtv (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers