MythTV Frontend requires killall pulseaudio

Bug #162539 reported by Anthony Wood on 2007-11-14
2
Affects Status Importance Assigned to Milestone
MythTV
Fix Released
Unknown
mythtv (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: mythtv-frontend

Gutsy has pulseaudio by default.

MythTV before changeset 14785 (http://svn.mythtv.org/trac/changeset/14785) required memory mapped access to the sound device.

The pulseaudio compatibility layer is not compatible with memory mapped access.

The changeset fixes the upstream bug http://svn.mythtv.org/trac/ticket/3598

More info is available in the mythtv changeset and bug.

To reproduce:

start mythtvfrontend
choose something which requires sound, e.g. live tv
no sound will come

killall pulseaudio

then try again and sound works

Changed in mythtv:
status: Unknown → Fix Released
Mario Limonciello (superm1) wrote :

This patch is already applied to the gutsy packages. See https://bugs.edge.launchpad.net/ubuntu/+source/mythtv/+bug/138810
I'm marking this bug incomplete though still in case it isn't working for you.

Changed in mythtv:
importance: Undecided → Wishlist
status: New → Incomplete

Thanks Mario.

Is there any chance that this is small/big enough so it can/will be applied to the Feisty Package since both G & F are Myth 0.20.2?

cheers,
Woody

Mario Limonciello (superm1) wrote :

Anthony,

Applying it to the feisty packages is unlikely unfortunately. The SRU process only allows for regressions to be fixed, not "new features". It can however, be backported from gutsy or hardy (preferably hardy after the package levels out - there are some issues with that). I'd recommend for now just upgrading to gutsy though.

Mario,

My brain was on holiday, I have gutsy already. mythtv 0.20.2-0ubuntu10 seems to have the problem for me.

Running mythfrontend I get (in part):

2007-11-27 12:47:32.440 Connected to database 'mythconverg' at host: 192.168.76.9
2007-11-27 12:47:33.163 TV: Attempting to change from None to WatchingPreRecorded
2007-11-27 12:47:34.768 RingBuf(myth://192.168.76.9:6543/2007_20071105165000.nuv): Waited 1.0 seconds for data to become available...
2007-11-27 12:47:37.163 Opening OSS audio device '/dev/dsp'.
2007-11-27 12:47:37.163 AudioOutput Error: WARNING: something is currently using: /dev/dsp, retrying.
2007-11-27 12:47:37.163 NVP: Disabling Audio, reason is: WARNING: something is currently using: /dev/dsp, retrying.

lsof /dev/dsp gives nothing

Tried changing the audio device to "ALSA:Default"...

2007-11-27 12:57:22.958 TV: Attempting to change from None to WatchingPreRecorded
2007-11-27 12:57:23.631 NVP: Prebuffer wait timed out 10 times.
2007-11-27 12:57:30.060 Opening ALSA audio device 'default'.
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
2007-11-27 12:57:30.102 AudioOutput Error: snd_pcm_open(default): Device or resource busy
2007-11-27 12:57:30.103 NVP: Disabling Audio, reason is: snd_pcm_open(default): Device or resource busy

So I guess I have a different problem?

Anthony Wood wrote:
> Mario,
>
> My brain was on holiday, I have gutsy already. mythtv 0.20.2-0ubuntu10
> seems to have the problem for me.
>
> Running mythfrontend I get (in part):
>
> 2007-11-27 12:47:32.440 Connected to database 'mythconverg' at host: 192.168.76.9
> 2007-11-27 12:47:33.163 TV: Attempting to change from None to WatchingPreRecorded
> 2007-11-27 12:47:34.768 RingBuf(myth://192.168.76.9:6543/2007_20071105165000.nuv): Waited 1.0 seconds for data to become available...
> 2007-11-27 12:47:37.163 Opening OSS audio device '/dev/dsp'.
> 2007-11-27 12:47:37.163 AudioOutput Error: WARNING: something is currently using: /dev/dsp, retrying.
> 2007-11-27 12:47:37.163 NVP: Disabling Audio, reason is: WARNING: something is currently using: /dev/dsp, retrying.
>
> lsof /dev/dsp gives nothing
>
> Tried changing the audio device to "ALSA:Default"...
>
> 2007-11-27 12:57:22.958 TV: Attempting to change from None to WatchingPreRecorded
> 2007-11-27 12:57:23.631 NVP: Prebuffer wait timed out 10 times.
> 2007-11-27 12:57:30.060 Opening ALSA audio device 'default'.
> ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
> 2007-11-27 12:57:30.102 AudioOutput Error: snd_pcm_open(default): Device or resource busy
> 2007-11-27 12:57:30.103 NVP: Disabling Audio, reason is: snd_pcm_open(default): Device or resource busy
>
> So I guess I have a different problem?
>
Looking over the patch, I suspect pulse audio only works with ALSA. I don't
know what more to say however.

--
Mario Limonciello
<email address hidden>

Mario Limonciello (superm1) wrote :

Anythony,

Since the bug isn't related to the changeset you are talking about i'm going to close up this bug. Hopefully it doesn't crop back up when we do switch over to pulseaudio by default though :)

Changed in mythtv:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.