Cannot install mythtv-backend on Xenial

Bug #1529710 reported by Jesse Hughes on 2015-12-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

New upgrade of xenial, installing mythtv-backend fails with the following:

jesse@nietzsche:/var/lib/dpkg$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libslang2:i386
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  mythtv-backend
The following packages will be upgraded:
  mythtv-backend
1 upgraded, 0 newly installed, 0 to remove and 2337 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,243 kB of archives.
After this operation, 179 kB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 797839 files and directories currently installed.)
Preparing to unpack .../mythtv-backend_2%3a0.27.1+fixes.20140624.aa822f5-0ubuntu7_amd64.deb ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
invoke-rc.d: unknown initscript, /etc/init.d/mythtv-backend not found.
dpkg: warning: subprocess old pre-removal script returned error exit status 100
dpkg: trying script from the new package instead ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
invoke-rc.d: unknown initscript, /etc/init.d/mythtv-backend not found.
dpkg: error processing archive /var/cache/apt/archives/mythtv-backend_2%3a0.27.1+fixes.20140624.aa822f5-0ubuntu7_amd64.deb (--unpack):
 subprocess new pre-removal script returned error exit status 100
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
invoke-rc.d: unknown initscript, /etc/init.d/mythtv-backend not found.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 100
Errors were encountered while processing:
 /var/cache/apt/archives/mythtv-backend_2%3a0.27.1+fixes.20140624.aa822f5-0ubuntu7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any help greatly appreciated.

Jesse Hughes (jesse-v) wrote :

Created an empty file /etc/init.d/mythtv-backend and made it executable, re-ran apt-get install -f and everything worked.

Mario Limonciello (superm1) wrote :

We've moved to a 0.28 build and fixed systemd support. This should be fixed with the current version. If you have problems please re-open.

Changed in mythtv (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers