mythtv cannot be used with mariadb-server

Bug #1518924 reported by Markus on 2015-11-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Thomas Mashos

Bug Description

MythTV (especially mythtv-database) seem to require MySQL as database backend. While being fully compatible, MariaDB seems not to be an option for the current package.
On my system, installing mythtv would uninstall the MariaDB packages and instead install the MySQL suite. Which for sure is not what I want.

I'm running Ubuntu 15.10, apt-cache policy for mythtv-backend is

mythtv-backend:
  Installiert: (keine)
  Installationskandidat: 2:0.27.1+fixes.20140624.aa822f5-0ubuntu6
  Versionstabelle:
     2:0.27.1+fixes.20140624.aa822f5-0ubuntu6 0
        500 http://de.archive.ubuntu.com/ubuntu/ wily/multiverse amd64 Packages

Could someone of the package maintainers update the dependencies so that mythtv-database accepts also MariaDB as backend? Or am I missing something here?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mythtv (Ubuntu):
status: New → Confirmed
Thomas Mashos (tgm4883) wrote :

This should be in the next build which you can get from by enabling (recommended) the mythbuntu repos http://www.mythbuntu.org/repos

Changed in mythtv (Ubuntu):
assignee: nobody → Thomas Mashos (tgm4883)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers