mythtv-frontend not detecting previous runs of mythsetup

Bug #145714 reported by Ed Hargin on 2007-09-27
2
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Mario Limonciello

Bug Description

Using the automatic mythtv desktop login option, that automatically loads mythtv-frontend I am always prompted that it believes I have no run mythtv-setup previously. I can click "cancel" on this warning and use mythtv-frontend just fine, with no issues. If I do the setup as prompted it makes no difference on subsequent logins - and I am again prompted.

This is annoying as it requires having a keyboard plugged in to click "cancel" as a remote control will not work for me outside of the frontend.

I am not really sure what information is needed to debug/troubleshoot this bug, so please feel free to request whatever information you need to debug this. It sounds like it might be a database value that is not getting updated, or being read incorrectly - but I haven't read the code so have no real idea of what could be causing it.

Related branches

Mario Limonciello (superm1) wrote :

Can you do this as a temporary attempt to work around this:

Edit /usr/share/mythtv/startmythtv.sh

Replace any instances of '~' with '$HOME' (without the quotes).

See if that resolves it ( You should get asked once more, and then that should be it)

Changed in mythtv:
status: New → Incomplete
Ed Hargin (ed-hargin) wrote :

I made the change as suggested. It did not resolve the situation, either by going through the setup again, or by clicking "cancel".

Ed Hargin schrieb:
> I made the change as suggested. It did not resolve the situation,
> either by going through the setup again, or by clicking "cancel".
>

Can you post the output

ls -al /home/<youruser>/.mythtv/

?

okay next idea. what are the permissions on ~/.mythtv and its contents?

On 9/27/07, Ed Hargin <email address hidden> wrote:
> I made the change as suggested. It did not resolve the situation,
> either by going through the setup again, or by clicking "cancel".
>
> --
> mythtv-frontend not detecting previous runs of mythsetup
> https://bugs.launchpad.net/bugs/145714
> You received this bug notification because you are a member of MythTV
> Ubuntu Maintainers, which is a bug contact for mythtv in ubuntu.
>

--
Mario Limonciello
<email address hidden>

Ed Hargin (ed-hargin) wrote :

drwxr-xr-x 4 root root 90 2007-09-27 16:11 .mythtv

AND

$ ls -al /home/mythtv/.mythtv/
total 20
drwxr-xr-x 4 root root 90 2007-09-27 16:11 .
drwxr-xr-x 51 mythtv mythtv 4096 2007-09-27 19:45 ..
drwxr-xr-x 2 root root 117 2007-09-27 16:26 channels
-rw-r--r-- 1 root root 3720 2007-09-27 00:46 lircrc
-rwxrwxrwx 1 root root 3911 2007-09-23 16:16 lircrc.old
drwxrwxrwx 3 root root 37 2007-09-27 16:52 themecache
-rw-r--r-- 1 root root 298 2007-09-27 16:15 vidsource.xmltv

Ed Hargin (ed-hargin) wrote :

I changed the ownership of the dir (recursively) to mythtv:mythtv - now after having run the setup as prompted the error has gone away.

Okay so the issue at hand is that /home/mythtv is owned by root, so you're
not allowed to touch or create files within there.

How did you set things up?

Mythbuntu Control Centre? or with just apt-get install
ubuntu-mythtv-frontend?

If you did it via control centre, what user name did you choose for your
automatic login? It appears that the 'mythtv' user is being used, which
isn't at all the intended behavior, and consequently a different bug.
Also if you did it via the control centre, what items did you install prior
to the control centre?

On 9/27/07, Ed Hargin <email address hidden> wrote:
>
> drwxr-xr-x 4 root root 90 2007-09-27 16:11 .mythtv
>
> AND
>
> $ ls -al /home/mythtv/.mythtv/
> total 20
> drwxr-xr-x 4 root root 90 2007-09-27 16:11 .
> drwxr-xr-x 51 mythtv mythtv 4096 2007-09-27 19:45 ..
> drwxr-xr-x 2 root root 117 2007-09-27 16:26 channels
> -rw-r--r-- 1 root root 3720 2007-09-27 00:46 lircrc
> -rwxrwxrwx 1 root root 3911 2007-09-23 16:16 lircrc.old
> drwxrwxrwx 3 root root 37 2007-09-27 16:52 themecache
> -rw-r--r-- 1 root root 298 2007-09-27 16:15 vidsource.xmltv
>
> --
> mythtv-frontend not detecting previous runs of mythsetup
> https://bugs.launchpad.net/bugs/145714
> You received this bug notification because you are a member of MythTV
> Ubuntu Maintainers, which is a bug contact for mythtv in ubuntu.
>

--
Mario Limonciello
<email address hidden>

Mario Limonciello (superm1) wrote :

Ed,
Glad you fixed it locally, but can you answer the questions I listed so we
can avoid this in the future for other people :)?

On 9/27/07, Ed Hargin <email address hidden> wrote:
>
> I changed the ownership of the dir (recursively) to mythtv:mythtv - now
> after having run the setup as prompted the error has gone away.
>
> --
> mythtv-frontend not detecting previous runs of mythsetup
> https://bugs.launchpad.net/bugs/145714
> You received this bug notification because you are a member of MythTV
> Ubuntu Maintainers, which is a bug contact for mythtv in ubuntu.
>

--
Mario Limonciello
<email address hidden>

Ed Hargin (ed-hargin) wrote :

I didn't use the control center at all I'm afraid - so no bug there. I created the mythtv user myself a long time ago for use here.

Mario Limonciello (superm1) wrote :

Okay so since you made the username yourself, that is where the issues are. At very minimum we can setup the packages to chown /home/mythtv to mythtv:mythtv. I'll add that to the packages.

Changed in mythtv:
assignee: nobody → superm1
status: Incomplete → Triaged
Changed in mythtv:
status: Triaged → In Progress
Changed in mythtv:
status: In Progress → Fix Committed
Mario Limonciello (superm1) wrote :

mythtv (0.20.2-0ubuntu8) gutsy; urgency=low

  [ Mario Limonciello ]
  * debian/startmythtv.sh:
    - Switch ~ to $HOME
    - Only run mtd if not running.
  * debian/control:
    - Refresh dependencies for ubuntu-mythtv-frontend
      to gutsy appropriate package names.
  * debian/ubuntu-mythtv-frontend.postinst:
    - Take ownership of ~/.mythtv if necessary. (LP: #145714)

  [ Michael Haas ]
  * debian/startmythtv.sh:
    - Correct minor typo in ${MYTHWELCOME}. (LP: #144541)

  [ Jo Shields ]
  * Start mythtv-setup in a terminal. (LP: #147701)

  [ Brian J. Murrell ]
  * Clarify text in mythtv-database.postinst (LP: #146328)

 -- Mario Limonciello <email address hidden> Thu, 27 Sep 2007 02:00:01 -0500

Changed in mythtv:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers