mythfrontend.real crashed with SIGSEGV in glXMakeCurrentReadSGI()

Bug #145706 reported by danda on 2007-09-27
8
Affects Status Importance Assigned to Milestone
MythTV
Confirmed
Unknown
mythtv (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: mythtv

machine (laptop) was idle overnight. Crash report dialog was open when I returned in the morning. mythbackend is on a separate machine. Laptop is a Thinkpad T61 with Intel 985 graphics.

ProblemType: Crash
Architecture: amd64
Date: Wed Sep 26 20:55:35 2007
Disassembly: 0x2aaaab0b6090:
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/mythfrontend.real
NonfreeKernelModules: ath_hal
Package: mythtv-frontend 0.20.2-0ubuntu7
PackageArchitecture: amd64
ProcCmdline: /usr/bin/mythfrontend.real
ProcCwd: /home/mythtv
ProcEnviron:
 PATH=/usr/local/bin:/usr/bin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/sh
Signal: 11
SourcePackage: mythtv
StacktraceTop:
 ?? ()
 glXMakeCurrentReadSGI () from /usr/lib/libGL.so.1
 QGLContext::doneCurrent ()
 QGLWidget::reparent () from /usr/lib/libqt-mt.so.3
 MythMainWindow::Init ()
Title: mythfrontend.real crashed with SIGSEGV in glXMakeCurrentReadSGI()
Uname: Linux box 2.6.22-12-generic #1 SMP Sun Sep 23 20:03:18 GMT 2007 x86_64 GNU/Linux
UserGroups: audio cdrom dialout video

danda (dan-osc) wrote :
Mario Limonciello (superm1) wrote :

Hi, thanks for the bug report.
Just for sanities sake, did you have anything else using Glx active at this time? Compiz or anything like that?

Not that I'm aware of. I'm running kde at the moment, and compiz doesn't seem
to start under kde unless I start it manually. I did have Kaffeine open with
a movie (paused), but I think that just uses XV. Other open apps:
Konqueror, kmail, konsole, firefox.

On Thursday 27 September 2007 11:33:56 Mario Limonciello wrote:
> Hi, thanks for the bug report.
> Just for sanities sake, did you have anything else using Glx active at this
> time? Compiz or anything like that?

Changed in mythtv:
importance: Undecided → Medium
danda (dan-osc) wrote :

I had this happen again this morning.

I haven't tested it yet, but I have a theory that it could be related to the screensaver. As both mornings when it occurred, I had left mythtv running overnight and the screensaver had activated.

Changed in mythtv:
status: Unknown → New
Changed in mythtv:
status: New → Confirmed
Changed in mythtv:
status: New → Confirmed
Peter L Jones (peter-drealm) wrote :

I had this on exiting after watching a recording. Nothing else using GLX, only other user apps open were firefox and a terminal window (from where I'd launched MythTV -- it had hung on first run, so I'd "kill -HUP"'d it). I'm using fglrx.

Mario Limonciello (superm1) wrote :

Marking this as a duplicate of the newer bug because the newer bug has a stacktrace against trunk and is more likely to be fixed upstream

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.