MythTV 0.20.2 SRU

Bug #134726 reported by Mario Limonciello on 2007-08-25
36
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
High
Mario Limonciello
Edgy
High
Mario Limonciello
Feisty
High
Mario Limonciello

Bug Description

Binary package hint: mythtv

Recently, a new minor release of MythTV was announced, version 0.20.2. Feisty contains an svn checkout after 0.20.1.

For North American users, guide data was previously provided by Tribune Media Services through a service called Zap2It. Starting September first, this service will be discontinued. A non profit organization, Schedules Direct (www.schedulesdirect.org) has been formed to replace Zap2it for guide data to all North American users. Schedules Direct unfortunately requires an update to the new MythTV release due to new servers being used, and guide data being stored in the MySQL table differently. With this release there is an ABI change, meaning that all machines using MythTV will need to be upgraded to have a version with the same ABI. This goes for plugins as well, all of mythplugins will need to be using the newer 0.20.2 release too. Archive wise, since this isn't a major version bump, no NEW binary packages will be necessary, libmyth-0.20 will still be used.

The format for guide data through schedules direct is different than Zap2it's previous format. All shows are stored internally with a longer series-id (presumingly) for future support of more possible shows. After installing this version, the MySQL tables will be updated, and guide data will be translated over to the new format. Unfortunately, due to the ABI change, just applying the patches that do this is not feasible. This would provide a false assumption that these packages worked with packages using the old ABI, which isn't the case.

I would have to rank this as being a very severe problem, as without guide data, a MythTV box is useless for North American users. At this point, the only options for Feisty users would be to upgrade to Gutsy (which had 0.20.2 uploaded recently) and use the testing release, or to compile the packages from source themselves. It's hard to estimate how many users will really be affected, since popularity contest doesn't provide statistics on people's locale. The install number for mythtv-common is around 7.5k, but again there isn't much information about how far back that goes.

As for changes other changes involved, you can view a changelog between the 0.20.1 minor release 0.20.2 at the MythTV wiki: http://www.mythtv.org/wiki/index.php/Release_Notes_-_0.20.2

The 0.20.2 release is developed in a branch separate from trunk. All of the changes that have been put into it have been backported out of trunk, and should be considered stable. Since no major 'features' have been introduced, I would expect the risk for regression to unaffected (non North American) users to be very low.

Mario Limonciello (superm1) wrote :

Attaching a diffstat of the upstream tarballs.

Mario Limonciello (superm1) wrote :

Attaching a build log using the new diff

Mario Limonciello (superm1) wrote :

Attaching feisty debdiff

Changed in mythtv:
importance: Undecided → High
assignee: nobody → superm1
status: New → In Progress
Mario Limonciello (superm1) wrote :

Attaching edgy debdiff

Changed in mythtv:
assignee: nobody → superm1
importance: Undecided → High
status: New → In Progress
assignee: nobody → superm1
importance: Undecided → High
status: New → In Progress
Mario Limonciello (superm1) wrote :

Edgy Build log using the new diff

Kees Cook (kees) wrote :

Hi, Can you post links to the new orig/dsc/diff files? I'd like to start getting this tested. Also, since this will cause the need for 3rd party rebuilds, what do you think of a Debian.NEWS informing people of the ABI bump and the need for them to recompile things? Thanks!

Kees Cook (kees) wrote :

I've verified that the edgy build installs (modulo a small fix that superm1 is already adding).

Mario Limonciello (superm1) wrote :

The feisty build has been pushed to feisty-proposed.

Mario Limonciello (superm1) wrote :

The edgy build has been uploaded.

Changed in mythtv:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Changed in mythtv:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Justin Bowes (daft-angus) wrote :

The Feisty build installs, but mythfilldatabase fails with an error message about oldprograms being a crashed table until the contrib/optimize_mythdb.pl script is run.

After running this script, all seems okay. I'll give the system more of a workout tonight after work.

James Rankin (rankin-james) wrote :

Works for me! Edgy eft.
mythfilldatabase appears to be working properly with Schedules Direct.

Thanks!

Justin Bowes (daft-angus) wrote :

All working on Feisty; not sure if the need to run optimize_mythdb was due to the upgrade or not, since DataDirect had not been working since August 18.

Mario Limonciello (superm1) wrote :

There were some minor issues encountered with the schedules direct switch over for a few users depending upon the username they chose for schedules direct. A new upload with 3 cherry picked patches from svn has been added, 0.20.2-0ubuntu0.6.10, and just needs to be acked by an archive admin.

Changed in mythtv:
status: Fix Released → In Progress
Mario Limonciello (superm1) wrote :

There were some minor issues encountered with the schedules direct switch over for a few users depending upon the username they chose for schedules direct. A new upload with 3 cherry picked patches from svn has been added, 0.20.2-0ubuntu0.7.04, and just needs to be acked by an archive admin.

Changed in mythtv:
status: Fix Released → Confirmed
status: Confirmed → In Progress
Karl Hegbloom (karl.hegbloom) wrote :

I've very recently moved my workstation up to Gutsy Gibbon, in pursuit of a precompiled package for this new version of MythTV. It seems to be working fine, except that the bug where it doesn't put the edit bars in the right place after you edit and load the commercial cuts. That only happens if you have overscan set in the settings, under TV Settings, Playback.

There is a changeset in SVN that fixes the bug. I've attached it for your convenience. It was downloaded from the MythTV SVN web, and is changeset r12492.

  http://svn.mythtv.org/trac/

  http://svn.mythtv.org/trac/changeset/12492/trunk

I have not tried to apply this patch to the MythTV 0.20.2 sources, but did try it with the last version, and it worked great. The edit bars now line up right above the edges of the red regions showing where sections are cut out. Without the patch, if you have TV playback overscan set to non-zero, the edit bars are positioned as if the video has not been scaled for the overscan. They don't line up right.

Perhaps there are options to 'unzip' that ask it for only the .png files?

I think that the first action you should take re changeset_r12492 is to begin lobbying the MythTV maintainers to apply the patch to the 0.20.2 branch.

How will you include .png files in the package? They can't be handled by 'diff'. Have you thought of porting to 'cdbs' and reorganizing the source package so that it's a Debian native package and contains .tar.gz of the upstream source distribution as well as the .zip containing the updated .png images. 'cdbs' has good support for dpatch.

Would you like any help with that? It might be a fun diversion.

Karl Hegbloom (karl.hegbloom) wrote :
rhex (launchpad-infosec) wrote :

I made the upgrade outlined in http://ubuntuforums.org/showthread.php?t=536555.

I did not have any guide data previously because this was a new installation for me. The first time I ran mythfilldatabase after the update, it segfaulted. Mythfilldatabase does appear to be successful intermittently though. When it is, the last log message reads: DataDirect: Deleting temporary files.

In the input connections, when selecting the correct video source, "Fetch Channels from Listings Source" does nothing. The guide displays the channels as "Adding Channel 13", etc, instead of with a label.

Thanks,

rhex

Kees Cook (kees) wrote :

Feisty works for me; no regressions in any of the plugins either. I have confirmed that the SD switch-over worked, and I'm fetching new guide data.

Brian Murray (brian-murray) wrote :

Feisty works for me also. I have not tested the plugins yet however. I have confirmed that the SD switch-over worked, and I'm fetching new guide data.

Sebastien Bacher (seb128) wrote :

what did you subscribe ubuntu-archive to this bug?

Sebastien Bacher (seb128) wrote :

The uploads to proposed have been accepted now

Changed in mythtv:
status: In Progress → Fix Committed
status: In Progress → Fix Committed
status: In Progress → Fix Committed
Kees Cook (kees) wrote :

Most recent upload also works for me (Feisty); as before, great work Mario!

Eric Wittle (ericw-wittle) wrote :

I'm working on a new install using 7.0.4, and I came across this bug. It was very helpful in getting me to the current version of MythTV, and therefore allowing me to download channel lineups. Unfortunately, my setup is not working completely correctly, and I don' t know if this is a problem in MythTV 0.20.2 or in the preparation of the Ubuntu distribution. The issue is that the tuner frequency is not set correctly when an external channel change script is defined for the card input. I have fairly detailed notes on my configuration/setup and this specific problem. I can work around this by starting to watch tv, then invoking ivtv-tune -c3, where 3 is the channel preset I need the tuner set to for my set top box.

My configuration/setup:

http://www.wittle.net/wiki/MythTV

More details on this specific problem:

http://www.wittle.net/wiki/MythTV#Figuring_out_how_to_set_the_tuner_to_the_right_channel_after_boot

Thanks,

-Eric

Eric Wittle (ericw-wittle) wrote :

Additional note; the myth front end core dumps at the end of Utilities/Setup->Setup->Appearence

-Eric

heckheck (jinfo) wrote :

An update to this bug states that the uploads to proposed have been accepted, yet I have not yet found that the new version is available when I update my apt cache. There are only three days of guide data left from Zap2It, is there any hope that it will be possible to update from the normal Ubuntu repository before guide data runs out, or will people be forced to us the proposed repository to avoid service interruption?

Thanks,

-Jim

Like Eric mentioned above (https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/134726/comments/25), I experienced front-end crashes when using setup. Unfortunately, I didn't keep notes and don't remember the details.

heckheck: I recommend that you install the myth packages directly from -proposed. I found that by using synaptic I could be selective about updates from -proposed. I only accepted myth-related ones.

Marlon (marlonbuchanan) wrote :

Has been working well for a week for me. Good work Mario. Thanks! Master backend Edgy. Other backends Edgy and Feisty.

Mario Limonciello (superm1) wrote :

per the SRU process described at http://wiki.ubuntu.com/MOTU/SRU, these are ready to be copied over to -updates by an archive administrator. Subscribing ubuntu-archive.

Changed in mythtv:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to edgy-updates.

Changed in mythtv:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to feisty-updates.

Changed in mythtv:
status: Fix Committed → Fix Released
Matthew Carpenter (matt-eisgr) wrote :

Could we get this backported to Dapper?
I know this sounds like an odd request, but after being forced to upgrade distro versions for my mythbox before (and having Multiverse/Universe stuff uninstalled, etc) I chose Dapper because 5-year support sounded good. Perhaps it's odd, since most boxen used for multimedia are always running the latest-greated stuff. But I'm still running Dapper on my myth box because of it.

I'd really really really really really incredibly appreciate it :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.