mythweb folders are linked to wrong location

Bug #1300404 reported by Borim on 2014-03-31
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

I am using ubuntu 14.04.

After I managed to get mythtv working, I installed mythweb, but when I browse to "localhost/mythweb" I get only: Not found

The problem is that the mythweb folder /usr/share/mythtv/mythweb is linked to the wrong place in the apache html tree:
/var/www/mythweb

But the html root folder of apache is: /var/www/html
The correct path for the mythweb files is /var/www/html/mythweb
After the link is created you have to adapt the directory location in /etc/apache2/sites-enabled/mythweb.conf

Finally you have to restart apache and mythweb works ;)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: mythweb 2:0.27.0+fixes.20140324.8ee257c-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-20.42-generic 3.13.7
Uname: Linux 3.13.0-20-generic x86_64
NonfreeKernelModules: wl tbs6982fe tbs6680fe tbs6923fe tbs6985se tbs6928se tbs6982se tbs6991fe tbs6618fe tbs6922fe tbs6928fe tbs6991se
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Mar 31 21:20:07 2014
InstallationDate: Installed on 2014-03-30 (1 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140329)
Installed_mythtv_dbg: 2:0.27.0+fixes.20140324.8ee257c-0ubuntu1
MythTVDirectoryPermissions: lrwxrwxrwx 1 root root 13 Mär 31 20:15 /var/lib/mythtv -> /Daten/mythtv
PackageArchitecture: all
SourcePackage: mythtv
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.default.mythweb:
 [cfg]
 enable = true
 only =
 username =
 password =
mtime.conffile..etc.default.mythweb: 2014-03-31T20:48:47.828933

Related branches

Borim (borim) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mythtv (Ubuntu):
status: New → Confirmed
thefuzz4 (jason-hamilton) wrote :

I can confirm that the upgrade to 14.04 for me today also broke this. I did just as the poster suggested.

cd /var/www/html
sudo ln -s ../mythweb
cd /etc/apache2/sites-enabled
sudo vi mythweb.conf (I like vi but use whatever floats your boat :) )
update these two entries to this
    <Directory "/var/www/html/mythweb/data">
        #Options -All +FollowSymLinks +IncludesNoExec
    </Directory>
    <Directory "/var/www/html/mythweb" >
sudo service apache2 reload

and done :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 2:0.27.0+fixes.20140324.8ee257c-0ubuntu2

---------------
mythtv (2:0.27.0+fixes.20140324.8ee257c-0ubuntu2) trusty; urgency=medium

  * Fix default mythweb configuration to match changes to Ubuntu document
    root. (LP: #1300404)
  * Add back ppc64el_altivec.patch to fix FTBFS on ppc64el.
 -- Mario Limonciello <email address hidden> Fri, 11 Apr 2014 00:57:11 -0500

Changed in mythtv (Ubuntu):
status: Confirmed → Fix Released
brianary (brian-webcoder) wrote :

After upgrading to Trusty Tahr, I also had this issue, though examining the version of my mythtv package showed I had 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3 .

The link appeared to be fixed, but I still had to manually update the mythweb.conf file with the correct paths as in comment #1.

James Brusey (james-brusey) wrote :

I've also had this problem on upgrading to Trusty Tahr. For me the fix was to add in the symlink only: "cd /var/www && sudo ln -s /usr/share/mythtv/mythweb ."
dpkg-query -W mythweb
mythweb 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3

John Gelm (jgelm) wrote :

I followed #3 above with the difference of the cd and ln did not work for me so I:

sudo su
#cd /var/www/html
#ln -s /user/share/mythtv/mythweb

Now in browser: localhost/mythweb

Works!

Thanks all.

dailyglen (dailyglen) wrote :

I ran into this too on a fresh Linux Mint 17.2 (based on 14.04). Thanks for the solution posted in #3.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers