Using hostname test-VirtualBox causes Mythbuntu install to fail

Bug #1215440 reported by Mario Limonciello on 2013-08-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Wishlist
Mario Limonciello
Precise
Wishlist
Mario Limonciello

Bug Description

The install actually completed, but mysql wasn't properly configured.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.8.0-29.42~precise1-generic 3.8.13.5
Uname: Linux 3.8.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
Date: Thu Aug 22 08:19:32 2013
InstallCmdLine: file=/cdrom/preseed/mythbuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InstallationMedia: Mythbuntu 12.04.3 "Precise Pangolin" - Release amd64 (20130820)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Mario Limonciello (superm1) wrote :
Mario Limonciello (superm1) wrote :

Aug 22 13:04:33 mythbuntu ubiquity: error: "kernel.yama.protected_nonaccess_hardlinks" is an unknown key
Aug 22 13:04:43 mythbuntu ubiquity: start: Job failed to start
Aug 22 13:04:43 mythbuntu ubiquity: invoke-rc.d: initscript mysql, action "start" failed.
Aug 22 13:04:43 mythbuntu ubiquity: stop: Unknown instance:
Aug 22 13:04:48 mythbuntu ubiquity: ERROR 1062 (23000) at line 1148: Duplicate entry 'TV Frontend-CYCLEAUDIOCHAN-test-VirtualBox' for key 'PRIMARY'
Aug 22 13:04:49 mythbuntu plugininstall.py: log-output -t ubiquity chroot /target mysqladmin --defaults-file=/etc/mysql/debian.cnf shutdown
Aug 22 13:04:49 mythbuntu ubiquity: error: "kernel.yama.protected_nonaccess_hardlinks" is an unknown key
Aug 22 13:04:54 mythbuntu plugininstall.py: log-output -t ubiquity chroot /target mount -t proc proc /proc
Aug 22 13:04:54 mythbuntu plugininstall.py: log-output -t ubiquity chroot /target mount -t sysfs sysfs /sys
Aug 22 13:04:54 mythbuntu plugininstall.py: log-output -t ubiquity mount --bind /dev /target/dev

Mario Limonciello (superm1) wrote :

The failure only happens if the hostname is "test-VirtualBox". It's because the introductory mysql table has an entry for that that gets duplicated. As this is not very likely for someone to be testing in VirtualBox due to the necessity of TV tuners I don't think this should be a big deal for 12.04.3. We can target it for 12.04.4 to fix.

affects: ubiquity (Ubuntu) → mythtv (Ubuntu)
Changed in mythtv (Ubuntu):
assignee: nobody → Mario Limonciello (superm1)
importance: Undecided → Wishlist
milestone: none → ubuntu-12.04.4
status: New → Confirmed
summary: - Mythbuntu 12.04.03 candidate install fails
+ Using hostname test-VirtualBox causes Mythbuntu install to fail
Changed in mythtv (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Wishlist
assignee: nobody → Mario Limonciello (superm1)
milestone: none → ubuntu-12.04.4
Changed in mythtv (Ubuntu):
milestone: ubuntu-12.04.4 → none
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1215440

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 2:0.27.0+fixes.20130907.ac841f0-0ubuntu3

---------------
mythtv (2:0.27.0+fixes.20130907.ac841f0-0ubuntu3) saucy; urgency=low

  * Add a patch to readjust the inclusion order to fix FTBFS on PPC.
    - Submitted upstream at http://code.mythtv.org/trac/ticket/11835
 -- Mario Limonciello <email address hidden> Tue, 10 Sep 2013 12:29:00 -0500

Changed in mythtv (Ubuntu):
status: Confirmed → Fix Released
pdecat (pdecat) wrote :

The commit that replaces 'test-VirtualBox' with 'OLDHOSTNAME' creates duplicated entries in keybindings and settings tables:

patrick@myhostname:~/workspace$ sudo aptitude install mythtv-database
The following NEW packages will be installed:
mythtv-database
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/116 kB of archives. After unpacking 366 kB will be used.
Preconfiguring packages ...

Selecting previously unselected package mythtv-database.
(Reading database ... 315279 files and directories currently installed.)
Unpacking mythtv-database (from .../mythtv-database_2%3a0.27.0+fixes.20130918.033883b-0ubuntu0mythbuntu3_all.deb) ...
Setting up mythtv-database (2:0.27.0+fixes.20130918.033883b-0ubuntu0mythbuntu3) ...
ERROR 1062 (23000) at line 1148: Duplicate entry 'TV Frontend-CYCLEAUDIOCHAN-myhostname' for key 'PRIMARY'
dpkg: error processing mythtv-database (--configure):
subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
mythtv-database
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up mythtv-database (2:0.27.0+fixes.20130918.033883b-0ubuntu0mythbuntu3) ...
ERROR 1062 (23000) at line 1148: Duplicate entry 'TV Frontend-CYCLEAUDIOCHAN-myhostname' for key 'PRIMARY'
dpkg: error processing mythtv-database (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
mythtv-database

This affected me and another user: http://ubuntuforums.org/showthread.php?t=2174537&p=12789159

Here is a pull request that fixes them back: https://github.com/MythTV/packaging/pull/34

Regards,
Patrick.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.