Ubuntu

mythlogserver crashed with SIGSEGV in QObject::disconnect()

Reported by Mario Limonciello on 2013-01-18
722
This bug affects 204 people
Affects Status Importance Assigned to Milestone
MythTV
Unknown
Unknown
Mythbuntu
Medium
Unassigned
mythtv (Ubuntu)
Medium
Unassigned

Bug Description

crashed on remote frontend

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: mythtv-common 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin: LP-PPA-mythbuntu-0.26]
ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
Uname: Linux 3.2.0-35-generic x86_64
NonfreeKernelModules: nvidia
.var.log.mythtv.mythavtest.log:

.var.log.mythtv.mythbackend.log:

.var.log.mythtv.mythccextractor.log:

.var.log.mythtv.mythcommflag.log:

.var.log.mythtv.mythfilldatabase.log:

.var.log.mythtv.mythjobqueue.log:

.var.log.mythtv.mythlcdserver.log:

.var.log.mythtv.mythmediaserver.log:

.var.log.mythtv.mythmetadatalookup.log:

.var.log.mythtv.mythpreviewgen.log:

.var.log.mythtv.mythshutdown.log:

.var.log.mythtv.mythtranscode.log:

.var.log.mythtv.mythtv.setup.log:

.var.log.mythtv.mythutil.log:

.var.log.mythtv.mythwelcome.log:

ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
CrashDB: mythbuntu
Date: Fri Jan 18 15:13:07 2013
Disassembly: => 0x0: Cannot access memory at address 0x0
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-precise-amd64-20120703-2
ExecutablePath: /usr/bin/mythlogserver
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
Installed_mythtv_dbg: 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
MarkForUpload: True
MythTVDirectoryPermissions:
 total 4
 drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
ProcCmdline: /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: mythtv
StacktraceTop:
 ?? ()
 QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
 disconnect (member=0x0, receiver=0x7ff2d800b560, this=0x7ff2e000b4c0) at /usr/include/qt4/QtCore/qobject.h:252
 unregisterSocket (socket_=0x7ff2e000b4c0, this=0x7ff2d800b560) at ../include/nzmqt/nzmqt.hpp:703
 nzmqt::PollingZMQContext::qt_static_metacall (_o=0x7ff2d800b560, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at moc_nzmqt.cpp:401
Title: mythlogserver crashed with SIGSEGV in QObject::disconnect()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Mario Limonciello (superm1) wrote :
information type: Private → Public
Changed in mythbuntu:
status: New → Triaged
Changed in mythtv (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in mythbuntu:
importance: Undecided → Medium
tags: removed: need-amd64-retrace
H Buus (mythtv-0) wrote :

I believe this is caused by a bug in nzmqt. It has been reported here:
https://github.com/jonnydee/nzmqt/issues/8
Several tickets have been filed against mythtv that appear to have this same root cause:
http://code.mythtv.org/trac/ticket/10924
http://code.mythtv.org/trac/ticket/11043
http://code.mythtv.org/trac/ticket/11360
as well as the mythtv ticket that links to this launchpad bug:
http://code.mythtv.org/trac/ticket/11378

H Buus (mythtv-0) wrote :

See http://code.mythtv.org/trac/ticket/10924 for a patch (mythlogserver-segv.patch​) that I believe will fix this problem.

Thanks for the patch. Once upstream applies it it will land in our auto
builds.
On Feb 5, 2013 1:01 AM, "H Buus" <email address hidden> wrote:

> See http://code.mythtv.org/trac/ticket/10924 for a patch (mythlogserver-
> segv.patch) that I believe will fix this problem.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1101395
>
> Title:
> mythlogserver crashed with SIGSEGV in QObject::disconnect()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mythbuntu/+bug/1101395/+subscriptions
>

Mark Preston (emarkpreston) wrote :

Without MythTV's frontend running, the Launchpad Bug reporter came up on screen today. I had to twice enter my Linux Admin password, and then and only then would this bug be reported. While this bug has been triaged as being of medium importance, I suggest it is worse (higher importance). Ever since MythTV has become part of my auto-downloads through the Ubuntu Update Manager, my hard drive spins furiously and the CPU had insane load averages of 15 : 12 : 8. I have a quad core cpu. This conflict even causes the mouse cursor to disappear from the screen and no amount of mouse movement "finds" it. What is even more confusing is that I am taken to a Launchpad page to select from several bugs and I have NO WAY of knowing which to select. So, even though I'm in ignorance, I have selected this one. By the bye: the Launchpad bug report took several minutes to populate it's report and send it along here. As my upload speed is 76K, that's a lot of upload. In the megabytes.

Mark Preston (emarkpreston) wrote :

After running sudo service mythtv-backend stop, the OS cannot get back control. My mouse is weak to dead at times. Typing into a form took 10 minutes because of this.

What part of mythtv can I stop besides backend? I tried to stop mythlogserver, mythlcdserver and another myth, but the terminal said "unrecognized service".

Download full text (4.1 KiB)

Are you sure that mythtv is the culprit? What does 'top' say?

Thanks,

Thomas Mashos

On Mon, Feb 25, 2013 at 10:39 AM, Mark Preston <email address hidden> wrote:

> After running sudo service mythtv-backend stop, the OS cannot get back
> control. My mouse is weak to dead at times. Typing into a form took 10
> minutes because of this.
>
> What part of mythtv can I stop besides backend? I tried to stop
> mythlogserver, mythlcdserver and another myth, but the terminal said
> "unrecognized service".
>
> --
> You received this bug notification because you are a member of Mythbuntu
> Bug Team, which is subscribed to MythTV.
> https://bugs.launchpad.net/bugs/1101395
>
> Title:
> mythlogserver crashed with SIGSEGV in QObject::disconnect()
>
> Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
> Triaged
> Status in MythTV:
> Unknown
> Status in “mythtv” package in Ubuntu:
> Triaged
>
> Bug description:
> crashed on remote frontend
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: mythtv-common
> 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin:
> LP-PPA-mythbuntu-0.26]
> ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
> Uname: Linux 3.2.0-35-generic x86_64
> NonfreeKernelModules: nvidia
> .var.log.mythtv.mythavtest.log:
>
> .var.log.mythtv.mythbackend.log:
>
> .var.log.mythtv.mythccextractor.log:
>
> .var.log.mythtv.mythcommflag.log:
>
> .var.log.mythtv.mythfilldatabase.log:
>
> .var.log.mythtv.mythjobqueue.log:
>
> .var.log.mythtv.mythlcdserver.log:
>
> .var.log.mythtv.mythmediaserver.log:
>
> .var.log.mythtv.mythmetadatalookup.log:
>
> .var.log.mythtv.mythpreviewgen.log:
>
> .var.log.mythtv.mythshutdown.log:
>
> .var.log.mythtv.mythtranscode.log:
>
> .var.log.mythtv.mythtv.setup.log:
>
> .var.log.mythtv.mythutil.log:
>
> .var.log.mythtv.mythwelcome.log:
>
> ApportVersion: 2.0.1-0ubuntu17.1
> Architecture: amd64
> CrashDB: mythbuntu
> Date: Fri Jan 18 15:13:07 2013
> Disassembly: => 0x0: Cannot access memory at address 0x0
> DistributionChannelDescriptor:
> # This is a distribution channel descriptor
> # For more information see
> http://wiki.ubuntu.com/DistributionChannelDescriptor
> canonical-oem-somerville-precise-amd64-20120703-2
> ExecutablePath: /usr/bin/mythlogserver
> InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary
> 20120703-15:08
> Installed_mythtv_dbg: 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
> MarkForUpload: True
> MythTVDirectoryPermissions:
> total 4
> drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
> ProcCmdline: /usr/bin/mythlogserver --daemon --verbose general
> --loglevel info --syslog local7
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x0: Cannot access memory at address 0x0
> PC (0x00000000) not located in a known VMA region (needed executable
> region)!
> Stack memory exhausted (SP below stack segment)
> SegvReason: executing NULL VMA
> Signal: 11
> SourcePackage: mythtv
> StacktraceTop:
> ?? ()
> QObject::disconnect(QObject const*, char const*, Q...

Read more...

Mark Preston (emarkpreston) wrote :

Today, I turned the 'puter on. A few moments after the desktop finished loading, I noticed both tuner lights on my SiliconDust tuner are active. No reason for that no scheduled work for Myth. I sudo the backend to stop and noticed a significant drop in CPU usage. And the tuner LEDs are out.

Per Mr. Mashos request re: top & cpu from a few days ago. With no other software app running, other than the terminal, so that I might observe the TOP results, stopping the backend restored some sanity to the OS. Part of Apache2 was mis-configged and aptitude figured that out and re-installed it, so that's at an 'end' for now.

This happens almost every start up.

Stefan Pappalardo (sjuk) wrote :

mythlogserver crashes on on frontend-mythbuntobox and on front-/backend-mythbuntubox, and it does unpredictable. Perhaps there is some hint in the mythfrontend.log (see attachment).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 2:0.27.0+fixes.20130907.ac841f0-0ubuntu3

---------------
mythtv (2:0.27.0+fixes.20130907.ac841f0-0ubuntu3) saucy; urgency=low

  * Add a patch to readjust the inclusion order to fix FTBFS on PPC.
    - Submitted upstream at http://code.mythtv.org/trac/ticket/11835
 -- Mario Limonciello <email address hidden> Tue, 10 Sep 2013 12:29:00 -0500

Changed in mythtv (Ubuntu):
status: Triaged → Fix Released
Peter D. (0123peter) wrote :

Bug still exists 16th September.

Thomas Mashos (tgm4883) wrote :
Download full text (4.0 KiB)

Are you running packages that are after September 7th? (currently,
those only exist in the Mythbuntu repo). You'll see from this commit
that it's literally impossible for mythlogserver to crash anymore

https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
Thanks,

Thomas Mashos

On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden> wrote:
> Bug still exists 16th September.
>
> --
> You received this bug notification because you are a member of Mythbuntu
> Bug Team, which is subscribed to MythTV.
> https://bugs.launchpad.net/bugs/1101395
>
> Title:
> mythlogserver crashed with SIGSEGV in QObject::disconnect()
>
> Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
> Triaged
> Status in MythTV:
> Unknown
> Status in “mythtv” package in Ubuntu:
> Fix Released
>
> Bug description:
> crashed on remote frontend
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: mythtv-common 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin: LP-PPA-mythbuntu-0.26]
> ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
> Uname: Linux 3.2.0-35-generic x86_64
> NonfreeKernelModules: nvidia
> .var.log.mythtv.mythavtest.log:
>
> .var.log.mythtv.mythbackend.log:
>
> .var.log.mythtv.mythccextractor.log:
>
> .var.log.mythtv.mythcommflag.log:
>
> .var.log.mythtv.mythfilldatabase.log:
>
> .var.log.mythtv.mythjobqueue.log:
>
> .var.log.mythtv.mythlcdserver.log:
>
> .var.log.mythtv.mythmediaserver.log:
>
> .var.log.mythtv.mythmetadatalookup.log:
>
> .var.log.mythtv.mythpreviewgen.log:
>
> .var.log.mythtv.mythshutdown.log:
>
> .var.log.mythtv.mythtranscode.log:
>
> .var.log.mythtv.mythtv.setup.log:
>
> .var.log.mythtv.mythutil.log:
>
> .var.log.mythtv.mythwelcome.log:
>
> ApportVersion: 2.0.1-0ubuntu17.1
> Architecture: amd64
> CrashDB: mythbuntu
> Date: Fri Jan 18 15:13:07 2013
> Disassembly: => 0x0: Cannot access memory at address 0x0
> DistributionChannelDescriptor:
> # This is a distribution channel descriptor
> # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
> canonical-oem-somerville-precise-amd64-20120703-2
> ExecutablePath: /usr/bin/mythlogserver
> InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
> Installed_mythtv_dbg: 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
> MarkForUpload: True
> MythTVDirectoryPermissions:
> total 4
> drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
> ProcCmdline: /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x0: Cannot access memory at address 0x0
> PC (0x00000000) not located in a known VMA region (needed executable region)!
> Stack memory exhausted (SP below stack segment)
> SegvReason: executing NULL VMA
> Signal: 11
> SourcePackage: mythtv
> StacktraceTop:
> ?? ()
> QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
> ...

Read more...

nik [tm] (tmcruisin) wrote :
Download full text (7.6 KiB)

Hi Thomas,

I'm pretty sure it completely up to date, but will check when home tonight an confirm.

Regards
Nick Sharp

On 16/09/2013, at 8:32, Thomas Mashos <email address hidden> wrote:

> Are you running packages that are after September 7th? (currently,
> those only exist in the Mythbuntu repo). You'll see from this commit
> that it's literally impossible for mythlogserver to crash anymore
>
> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
> Thanks,
>
> Thomas Mashos
>
>
> On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden> wrote:
>> Bug still exists 16th September.
>>
>> --
>> You received this bug notification because you are a member of Mythbuntu
>> Bug Team, which is subscribed to MythTV.
>> https://bugs.launchpad.net/bugs/1101395
>>
>> Title:
>> mythlogserver crashed with SIGSEGV in QObject::disconnect()
>>
>> Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
>> Triaged
>> Status in MythTV:
>> Unknown
>> Status in “mythtv” package in Ubuntu:
>> Fix Released
>>
>> Bug description:
>> crashed on remote frontend
>>
>> ProblemType: Crash
>> DistroRelease: Ubuntu 12.04
>> Package: mythtv-common 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin: LP-PPA-mythbuntu-0.26]
>> ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
>> Uname: Linux 3.2.0-35-generic x86_64
>> NonfreeKernelModules: nvidia
>> .var.log.mythtv.mythavtest.log:
>>
>> .var.log.mythtv.mythbackend.log:
>>
>> .var.log.mythtv.mythccextractor.log:
>>
>> .var.log.mythtv.mythcommflag.log:
>>
>> .var.log.mythtv.mythfilldatabase.log:
>>
>> .var.log.mythtv.mythjobqueue.log:
>>
>> .var.log.mythtv.mythlcdserver.log:
>>
>> .var.log.mythtv.mythmediaserver.log:
>>
>> .var.log.mythtv.mythmetadatalookup.log:
>>
>> .var.log.mythtv.mythpreviewgen.log:
>>
>> .var.log.mythtv.mythshutdown.log:
>>
>> .var.log.mythtv.mythtranscode.log:
>>
>> .var.log.mythtv.mythtv.setup.log:
>>
>> .var.log.mythtv.mythutil.log:
>>
>> .var.log.mythtv.mythwelcome.log:
>>
>> ApportVersion: 2.0.1-0ubuntu17.1
>> Architecture: amd64
>> CrashDB: mythbuntu
>> Date: Fri Jan 18 15:13:07 2013
>> Disassembly: => 0x0: Cannot access memory at address 0x0
>> DistributionChannelDescriptor:
>> # This is a distribution channel descriptor
>> # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
>> canonical-oem-somerville-precise-amd64-20120703-2
>> ExecutablePath: /usr/bin/mythlogserver
>> InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
>> Installed_mythtv_dbg: 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
>> MarkForUpload: True
>> MythTVDirectoryPermissions:
>> total 4
>> drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
>> ProcCmdline: /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7
>> ProcEnviron:
>> TERM=xterm
>> PATH=(custom, no user)
>> LANG=en_US.UTF-8
>> SHELL=/bin/bash
>> SegvAnalysis:
>> Segfault happened at: 0x0: Cannot access memory at address 0x0
>> PC (0x00000000) not located in a known VMA region (needed executable region)!
>> Stack memory exhaust...

Read more...

kmitche (kmitche) wrote :
Download full text (7.7 KiB)

Thomas,
I am running the mythbuntu repo. Mythlogserver appears to be active as a result. Dropping the repo would fix this issue, correct? Thanks for following up with this.
Kent
On Sep 15, 2013, at 4:02 PM, Thomas Mashos <email address hidden> wrote:

> Are you running packages that are after September 7th? (currently,
> those only exist in the Mythbuntu repo). You'll see from this commit
> that it's literally impossible for mythlogserver to crash anymore
>
> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
> Thanks,
>
> Thomas Mashos
>
>
> On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden> wrote:
>> Bug still exists 16th September.
>>
>> --
>> You received this bug notification because you are a member of Mythbuntu
>> Bug Team, which is subscribed to MythTV.
>> https://bugs.launchpad.net/bugs/1101395
>>
>> Title:
>> mythlogserver crashed with SIGSEGV in QObject::disconnect()
>>
>> Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
>> Triaged
>> Status in MythTV:
>> Unknown
>> Status in “mythtv” package in Ubuntu:
>> Fix Released
>>
>> Bug description:
>> crashed on remote frontend
>>
>> ProblemType: Crash
>> DistroRelease: Ubuntu 12.04
>> Package: mythtv-common 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin: LP-PPA-mythbuntu-0.26]
>> ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
>> Uname: Linux 3.2.0-35-generic x86_64
>> NonfreeKernelModules: nvidia
>> .var.log.mythtv.mythavtest.log:
>>
>> .var.log.mythtv.mythbackend.log:
>>
>> .var.log.mythtv.mythccextractor.log:
>>
>> .var.log.mythtv.mythcommflag.log:
>>
>> .var.log.mythtv.mythfilldatabase.log:
>>
>> .var.log.mythtv.mythjobqueue.log:
>>
>> .var.log.mythtv.mythlcdserver.log:
>>
>> .var.log.mythtv.mythmediaserver.log:
>>
>> .var.log.mythtv.mythmetadatalookup.log:
>>
>> .var.log.mythtv.mythpreviewgen.log:
>>
>> .var.log.mythtv.mythshutdown.log:
>>
>> .var.log.mythtv.mythtranscode.log:
>>
>> .var.log.mythtv.mythtv.setup.log:
>>
>> .var.log.mythtv.mythutil.log:
>>
>> .var.log.mythtv.mythwelcome.log:
>>
>> ApportVersion: 2.0.1-0ubuntu17.1
>> Architecture: amd64
>> CrashDB: mythbuntu
>> Date: Fri Jan 18 15:13:07 2013
>> Disassembly: => 0x0: Cannot access memory at address 0x0
>> DistributionChannelDescriptor:
>> # This is a distribution channel descriptor
>> # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
>> canonical-oem-somerville-precise-amd64-20120703-2
>> ExecutablePath: /usr/bin/mythlogserver
>> InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
>> Installed_mythtv_dbg: 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
>> MarkForUpload: True
>> MythTVDirectoryPermissions:
>> total 4
>> drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
>> ProcCmdline: /usr/bin/mythlogserver --daemon --verbose general --loglevel info --syslog local7
>> ProcEnviron:
>> TERM=xterm
>> PATH=(custom, no user)
>> LANG=en_US.UTF-8
>> SHELL=/bin/bash
>> SegvAnalysis:
>> Segfault happened at: 0x0: Cannot access memory at address 0x0
>> PC (0x00000000) not located in a known VMA...

Read more...

Thomas Mashos (tgm4883) wrote :
Download full text (11.7 KiB)

Let me know. What I'm getting at is that with current packages it
should be impossible for mythlogserver to crash because we aren't
installing mythlogserver because we've disabled mythlogserver from
compiling.
Thanks,

Thomas Mashos

On Sun, Sep 15, 2013 at 4:16 PM, nik [tm] <email address hidden> wrote:
> Hi Thomas,
>
> I'm pretty sure it completely up to date, but will check when home
> tonight an confirm.
>
> Regards
> Nick Sharp
>
>
> On 16/09/2013, at 8:32, Thomas Mashos <email address hidden>
> wrote:
>
>> Are you running packages that are after September 7th? (currently,
>> those only exist in the Mythbuntu repo). You'll see from this commit
>> that it's literally impossible for mythlogserver to crash anymore
>>
>> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
>> Thanks,
>>
>> Thomas Mashos
>>
>>
>> On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden> wrote:
>>> Bug still exists 16th September.
>>>
>>> --
>>> You received this bug notification because you are a member of Mythbuntu
>>> Bug Team, which is subscribed to MythTV.
>>> https://bugs.launchpad.net/bugs/1101395
>>>
>>> Title:
>>> mythlogserver crashed with SIGSEGV in QObject::disconnect()
>>>
>>> Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
>>> Triaged
>>> Status in MythTV:
>>> Unknown
>>> Status in “mythtv” package in Ubuntu:
>>> Fix Released
>>>
>>> Bug description:
>>> crashed on remote frontend
>>>
>>> ProblemType: Crash
>>> DistroRelease: Ubuntu 12.04
>>> Package: mythtv-common 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin: LP-PPA-mythbuntu-0.26]
>>> ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
>>> Uname: Linux 3.2.0-35-generic x86_64
>>> NonfreeKernelModules: nvidia
>>> .var.log.mythtv.mythavtest.log:
>>>
>>> .var.log.mythtv.mythbackend.log:
>>>
>>> .var.log.mythtv.mythccextractor.log:
>>>
>>> .var.log.mythtv.mythcommflag.log:
>>>
>>> .var.log.mythtv.mythfilldatabase.log:
>>>
>>> .var.log.mythtv.mythjobqueue.log:
>>>
>>> .var.log.mythtv.mythlcdserver.log:
>>>
>>> .var.log.mythtv.mythmediaserver.log:
>>>
>>> .var.log.mythtv.mythmetadatalookup.log:
>>>
>>> .var.log.mythtv.mythpreviewgen.log:
>>>
>>> .var.log.mythtv.mythshutdown.log:
>>>
>>> .var.log.mythtv.mythtranscode.log:
>>>
>>> .var.log.mythtv.mythtv.setup.log:
>>>
>>> .var.log.mythtv.mythutil.log:
>>>
>>> .var.log.mythtv.mythwelcome.log:
>>>
>>> ApportVersion: 2.0.1-0ubuntu17.1
>>> Architecture: amd64
>>> CrashDB: mythbuntu
>>> Date: Fri Jan 18 15:13:07 2013
>>> Disassembly: => 0x0: Cannot access memory at address 0x0
>>> DistributionChannelDescriptor:
>>> # This is a distribution channel descriptor
>>> # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
>>> canonical-oem-somerville-precise-amd64-20120703-2
>>> ExecutablePath: /usr/bin/mythlogserver
>>> InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
>>> Installed_mythtv_dbg: 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
>>> MarkForUpload: True
>>> MythTVDirectoryPermissions:
>>> total 4
>>> drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
>>> ProcC...

Thomas Mashos (tgm4883) wrote :
Download full text (11.7 KiB)

No, dropping the repo would not fix the issue. Can you post what the
output of this is

"dpkg -l | grep -i myth"
Thanks,

Thomas Mashos

On Sun, Sep 15, 2013 at 4:24 PM, kmitche <email address hidden> wrote:
> Thomas,
> I am running the mythbuntu repo. Mythlogserver appears to be active as a result. Dropping the repo would fix this issue, correct? Thanks for following up with this.
> Kent
> On Sep 15, 2013, at 4:02 PM, Thomas Mashos <email address hidden> wrote:
>
>> Are you running packages that are after September 7th? (currently,
>> those only exist in the Mythbuntu repo). You'll see from this commit
>> that it's literally impossible for mythlogserver to crash anymore
>>
>> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
>> Thanks,
>>
>> Thomas Mashos
>>
>>
>> On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden> wrote:
>>> Bug still exists 16th September.
>>>
>>> --
>>> You received this bug notification because you are a member of Mythbuntu
>>> Bug Team, which is subscribed to MythTV.
>>> https://bugs.launchpad.net/bugs/1101395
>>>
>>> Title:
>>> mythlogserver crashed with SIGSEGV in QObject::disconnect()
>>>
>>> Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
>>> Triaged
>>> Status in MythTV:
>>> Unknown
>>> Status in “mythtv” package in Ubuntu:
>>> Fix Released
>>>
>>> Bug description:
>>> crashed on remote frontend
>>>
>>> ProblemType: Crash
>>> DistroRelease: Ubuntu 12.04
>>> Package: mythtv-common 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin: LP-PPA-mythbuntu-0.26]
>>> ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
>>> Uname: Linux 3.2.0-35-generic x86_64
>>> NonfreeKernelModules: nvidia
>>> .var.log.mythtv.mythavtest.log:
>>>
>>> .var.log.mythtv.mythbackend.log:
>>>
>>> .var.log.mythtv.mythccextractor.log:
>>>
>>> .var.log.mythtv.mythcommflag.log:
>>>
>>> .var.log.mythtv.mythfilldatabase.log:
>>>
>>> .var.log.mythtv.mythjobqueue.log:
>>>
>>> .var.log.mythtv.mythlcdserver.log:
>>>
>>> .var.log.mythtv.mythmediaserver.log:
>>>
>>> .var.log.mythtv.mythmetadatalookup.log:
>>>
>>> .var.log.mythtv.mythpreviewgen.log:
>>>
>>> .var.log.mythtv.mythshutdown.log:
>>>
>>> .var.log.mythtv.mythtranscode.log:
>>>
>>> .var.log.mythtv.mythtv.setup.log:
>>>
>>> .var.log.mythtv.mythutil.log:
>>>
>>> .var.log.mythtv.mythwelcome.log:
>>>
>>> ApportVersion: 2.0.1-0ubuntu17.1
>>> Architecture: amd64
>>> CrashDB: mythbuntu
>>> Date: Fri Jan 18 15:13:07 2013
>>> Disassembly: => 0x0: Cannot access memory at address 0x0
>>> DistributionChannelDescriptor:
>>> # This is a distribution channel descriptor
>>> # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
>>> canonical-oem-somerville-precise-amd64-20120703-2
>>> ExecutablePath: /usr/bin/mythlogserver
>>> InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
>>> Installed_mythtv_dbg: 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
>>> MarkForUpload: True
>>> MythTVDirectoryPermissions:
>>> total 4
>>> drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
>>> ProcCmdline: /usr/bin/mythlogserver --daemon --ver...

Mario Limonciello (superm1) wrote :
Download full text (12.8 KiB)

also make sure you are running a 0.27 based build not earlier.
On Sep 15, 2013 6:41 PM, "Thomas Mashos" <email address hidden> wrote:

> No, dropping the repo would not fix the issue. Can you post what the
> output of this is
>
> "dpkg -l | grep -i myth"
> Thanks,
>
> Thomas Mashos
>
>
> On Sun, Sep 15, 2013 at 4:24 PM, kmitche <email address hidden>
> wrote:
> > Thomas,
> > I am running the mythbuntu repo. Mythlogserver appears to be active as a
> result. Dropping the repo would fix this issue, correct? Thanks for
> following up with this.
> > Kent
> > On Sep 15, 2013, at 4:02 PM, Thomas Mashos <email address hidden>
> wrote:
> >
> >> Are you running packages that are after September 7th? (currently,
> >> those only exist in the Mythbuntu repo). You'll see from this commit
> >> that it's literally impossible for mythlogserver to crash anymore
> >>
> >>
> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
> >> Thanks,
> >>
> >> Thomas Mashos
> >>
> >>
> >> On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden>
> wrote:
> >>> Bug still exists 16th September.
> >>>
> >>> --
> >>> You received this bug notification because you are a member of
> Mythbuntu
> >>> Bug Team, which is subscribed to MythTV.
> >>> https://bugs.launchpad.net/bugs/1101395
> >>>
> >>> Title:
> >>> mythlogserver crashed with SIGSEGV in QObject::disconnect()
> >>>
> >>> Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
> >>> Triaged
> >>> Status in MythTV:
> >>> Unknown
> >>> Status in “mythtv” package in Ubuntu:
> >>> Fix Released
> >>>
> >>> Bug description:
> >>> crashed on remote frontend
> >>>
> >>> ProblemType: Crash
> >>> DistroRelease: Ubuntu 12.04
> >>> Package: mythtv-common
> 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin:
> LP-PPA-mythbuntu-0.26]
> >>> ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
> >>> Uname: Linux 3.2.0-35-generic x86_64
> >>> NonfreeKernelModules: nvidia
> >>> .var.log.mythtv.mythavtest.log:
> >>>
> >>> .var.log.mythtv.mythbackend.log:
> >>>
> >>> .var.log.mythtv.mythccextractor.log:
> >>>
> >>> .var.log.mythtv.mythcommflag.log:
> >>>
> >>> .var.log.mythtv.mythfilldatabase.log:
> >>>
> >>> .var.log.mythtv.mythjobqueue.log:
> >>>
> >>> .var.log.mythtv.mythlcdserver.log:
> >>>
> >>> .var.log.mythtv.mythmediaserver.log:
> >>>
> >>> .var.log.mythtv.mythmetadatalookup.log:
> >>>
> >>> .var.log.mythtv.mythpreviewgen.log:
> >>>
> >>> .var.log.mythtv.mythshutdown.log:
> >>>
> >>> .var.log.mythtv.mythtranscode.log:
> >>>
> >>> .var.log.mythtv.mythtv.setup.log:
> >>>
> >>> .var.log.mythtv.mythutil.log:
> >>>
> >>> .var.log.mythtv.mythwelcome.log:
> >>>
> >>> ApportVersion: 2.0.1-0ubuntu17.1
> >>> Architecture: amd64
> >>> CrashDB: mythbuntu
> >>> Date: Fri Jan 18 15:13:07 2013
> >>> Disassembly: => 0x0: Cannot access memory at address 0x0
> >>> DistributionChannelDescriptor:
> >>> # This is a distribution channel descriptor
> >>> # For more information see
> http://wiki.ubuntu.com/DistributionChannelDescriptor
> >>> canonical-oem-somerville-precise-amd64-20120703-2
> >>> ExecutablePath: /usr/bin/mythlogserver
> >>> Installa...

doylecentral (doyle) wrote :
Download full text (4.8 KiB)

I upgraded on 9/13/13 from whatever repo came with mythbuntu.

On Sun, Sep 15, 2013 at 7:02 PM, Thomas Mashos
<email address hidden>wrote:

> Are you running packages that are after September 7th? (currently,
> those only exist in the Mythbuntu repo). You'll see from this commit
> that it's literally impossible for mythlogserver to crash anymore
>
>
> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
> Thanks,
>
> Thomas Mashos
>
>
> On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden>
> wrote:
> > Bug still exists 16th September.
> >
> > --
> > You received this bug notification because you are a member of Mythbuntu
> > Bug Team, which is subscribed to MythTV.
> > https://bugs.launchpad.net/bugs/1101395
> >
> > Title:
> > mythlogserver crashed with SIGSEGV in QObject::disconnect()
> >
> > Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
> > Triaged
> > Status in MythTV:
> > Unknown
> > Status in “mythtv” package in Ubuntu:
> > Fix Released
> >
> > Bug description:
> > crashed on remote frontend
> >
> > ProblemType: Crash
> > DistroRelease: Ubuntu 12.04
> > Package: mythtv-common
> 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin:
> LP-PPA-mythbuntu-0.26]
> > ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
> > Uname: Linux 3.2.0-35-generic x86_64
> > NonfreeKernelModules: nvidia
> > .var.log.mythtv.mythavtest.log:
> >
> > .var.log.mythtv.mythbackend.log:
> >
> > .var.log.mythtv.mythccextractor.log:
> >
> > .var.log.mythtv.mythcommflag.log:
> >
> > .var.log.mythtv.mythfilldatabase.log:
> >
> > .var.log.mythtv.mythjobqueue.log:
> >
> > .var.log.mythtv.mythlcdserver.log:
> >
> > .var.log.mythtv.mythmediaserver.log:
> >
> > .var.log.mythtv.mythmetadatalookup.log:
> >
> > .var.log.mythtv.mythpreviewgen.log:
> >
> > .var.log.mythtv.mythshutdown.log:
> >
> > .var.log.mythtv.mythtranscode.log:
> >
> > .var.log.mythtv.mythtv.setup.log:
> >
> > .var.log.mythtv.mythutil.log:
> >
> > .var.log.mythtv.mythwelcome.log:
> >
> > ApportVersion: 2.0.1-0ubuntu17.1
> > Architecture: amd64
> > CrashDB: mythbuntu
> > Date: Fri Jan 18 15:13:07 2013
> > Disassembly: => 0x0: Cannot access memory at address 0x0
> > DistributionChannelDescriptor:
> > # This is a distribution channel descriptor
> > # For more information see
> http://wiki.ubuntu.com/DistributionChannelDescriptor
> > canonical-oem-somerville-precise-amd64-20120703-2
> > ExecutablePath: /usr/bin/mythlogserver
> > InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary
> 20120703-15:08
> > Installed_mythtv_dbg:
> 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
> > MarkForUpload: True
> > MythTVDirectoryPermissions:
> > total 4
> > drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
> > ProcCmdline: /usr/bin/mythlogserver --daemon --verbose general
> --loglevel info --syslog local7
> > ProcEnviron:
> > TERM=xterm
> > PATH=(custom, no user)
> > LANG=en_US.UTF-8
> > SHELL=/bin/bash
> > SegvAnalysis:
> > Segfault happened at: 0x0: Cannot access memory at address 0x0
> > PC (0x00000000) not located in...

Read more...

Thomas Mashos (tgm4883) wrote :
Download full text (8.7 KiB)

0.26 or 0.27?
Thanks,

Thomas Mashos

On Sun, Sep 15, 2013 at 5:32 PM, doylecentral
<email address hidden> wrote:
> I upgraded on 9/13/13 from whatever repo came with mythbuntu.
>
>
> On Sun, Sep 15, 2013 at 7:02 PM, Thomas Mashos
> <email address hidden>wrote:
>
>> Are you running packages that are after September 7th? (currently,
>> those only exist in the Mythbuntu repo). You'll see from this commit
>> that it's literally impossible for mythlogserver to crash anymore
>>
>>
>> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
>> Thanks,
>>
>> Thomas Mashos
>>
>>
>> On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden>
>> wrote:
>> > Bug still exists 16th September.
>> >
>> > --
>> > You received this bug notification because you are a member of Mythbuntu
>> > Bug Team, which is subscribed to MythTV.
>> > https://bugs.launchpad.net/bugs/1101395
>> >
>> > Title:
>> > mythlogserver crashed with SIGSEGV in QObject::disconnect()
>> >
>> > Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
>> > Triaged
>> > Status in MythTV:
>> > Unknown
>> > Status in “mythtv” package in Ubuntu:
>> > Fix Released
>> >
>> > Bug description:
>> > crashed on remote frontend
>> >
>> > ProblemType: Crash
>> > DistroRelease: Ubuntu 12.04
>> > Package: mythtv-common
>> 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin:
>> LP-PPA-mythbuntu-0.26]
>> > ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
>> > Uname: Linux 3.2.0-35-generic x86_64
>> > NonfreeKernelModules: nvidia
>> > .var.log.mythtv.mythavtest.log:
>> >
>> > .var.log.mythtv.mythbackend.log:
>> >
>> > .var.log.mythtv.mythccextractor.log:
>> >
>> > .var.log.mythtv.mythcommflag.log:
>> >
>> > .var.log.mythtv.mythfilldatabase.log:
>> >
>> > .var.log.mythtv.mythjobqueue.log:
>> >
>> > .var.log.mythtv.mythlcdserver.log:
>> >
>> > .var.log.mythtv.mythmediaserver.log:
>> >
>> > .var.log.mythtv.mythmetadatalookup.log:
>> >
>> > .var.log.mythtv.mythpreviewgen.log:
>> >
>> > .var.log.mythtv.mythshutdown.log:
>> >
>> > .var.log.mythtv.mythtranscode.log:
>> >
>> > .var.log.mythtv.mythtv.setup.log:
>> >
>> > .var.log.mythtv.mythutil.log:
>> >
>> > .var.log.mythtv.mythwelcome.log:
>> >
>> > ApportVersion: 2.0.1-0ubuntu17.1
>> > Architecture: amd64
>> > CrashDB: mythbuntu
>> > Date: Fri Jan 18 15:13:07 2013
>> > Disassembly: => 0x0: Cannot access memory at address 0x0
>> > DistributionChannelDescriptor:
>> > # This is a distribution channel descriptor
>> > # For more information see
>> http://wiki.ubuntu.com/DistributionChannelDescriptor
>> > canonical-oem-somerville-precise-amd64-20120703-2
>> > ExecutablePath: /usr/bin/mythlogserver
>> > InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary
>> 20120703-15:08
>> > Installed_mythtv_dbg:
>> 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2
>> > MarkForUpload: True
>> > MythTVDirectoryPermissions:
>> > total 4
>> > drwxr-xr-x 2 root root 4096 Nov 24 18:26 videos
>> > ProcCmdline: /usr/bin/mythlogserver --daemon --verbose general
>> --loglevel info --syslog local7
>> > ProcEnviron:
>...

Read more...

doylecentral (doyle) wrote :
Download full text (10.5 KiB)

I'm running .26 see below. I thought .27 was not out yet? I'm also running
on a hypervisor xcp with xen monitoring tools installed. I have my system
snapshots so if you want me to try something just let me know.

dc@mythbackend:~$ sudo apt-cache policy mythtv
mythtv:
  Installed: 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1
  Candidate: 2:0.26.1+fixes.20130914.bd7198b-0ubuntu0mythbuntu1
  Version table:
     2:0.26.1+fixes.20130914.bd7198b-0ubuntu0mythbuntu1 0
        500 http://ppa.launchpad.net/mythbuntu/0.26/ubuntu/ precise/main
amd64 Packages
 *** 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 0
        100 /var/lib/dpkg/status
     2:0.25.2+fixes.20120802.46cab93-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/multiverse
amd64 Packages
     2:0.25.0+fixes.20120410.1f5962a-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/multiverse amd64
Packages
dc@mythbackend:~$

On Sun, Sep 15, 2013 at 8:44 PM, Thomas Mashos
<email address hidden>wrote:

> 0.26 or 0.27?
> Thanks,
>
> Thomas Mashos
>
>
> On Sun, Sep 15, 2013 at 5:32 PM, doylecentral
> <email address hidden> wrote:
> > I upgraded on 9/13/13 from whatever repo came with mythbuntu.
> >
> >
> > On Sun, Sep 15, 2013 at 7:02 PM, Thomas Mashos
> > <email address hidden>wrote:
> >
> >> Are you running packages that are after September 7th? (currently,
> >> those only exist in the Mythbuntu repo). You'll see from this commit
> >> that it's literally impossible for mythlogserver to crash anymore
> >>
> >>
> >>
> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
> >> Thanks,
> >>
> >> Thomas Mashos
> >>
> >>
> >> On Sun, Sep 15, 2013 at 3:46 PM, Peter D. <email address hidden>
> >> wrote:
> >> > Bug still exists 16th September.
> >> >
> >> > --
> >> > You received this bug notification because you are a member of
> Mythbuntu
> >> > Bug Team, which is subscribed to MythTV.
> >> > https://bugs.launchpad.net/bugs/1101395
> >> >
> >> > Title:
> >> > mythlogserver crashed with SIGSEGV in QObject::disconnect()
> >> >
> >> > Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
> >> > Triaged
> >> > Status in MythTV:
> >> > Unknown
> >> > Status in “mythtv” package in Ubuntu:
> >> > Fix Released
> >> >
> >> > Bug description:
> >> > crashed on remote frontend
> >> >
> >> > ProblemType: Crash
> >> > DistroRelease: Ubuntu 12.04
> >> > Package: mythtv-common
> >> 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin:
> >> LP-PPA-mythbuntu-0.26]
> >> > ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
> >> > Uname: Linux 3.2.0-35-generic x86_64
> >> > NonfreeKernelModules: nvidia
> >> > .var.log.mythtv.mythavtest.log:
> >> >
> >> > .var.log.mythtv.mythbackend.log:
> >> >
> >> > .var.log.mythtv.mythccextractor.log:
> >> >
> >> > .var.log.mythtv.mythcommflag.log:
> >> >
> >> > .var.log.mythtv.mythfilldatabase.log:
> >> >
> >> > .var.log.mythtv.mythjobqueue.log:
> >> >
> >> > .var.log.mythtv.mythlcdserver.log:
> >> >
> >> > .var.log.mythtv.mythmediaserver.log:
> >> >
> >> > .var.log.mythtv.mythmetadatalookup.log:
> >> >
> >> > .var.log.my...

doylecentral (doyle) wrote :
Download full text (15.5 KiB)

Sorry didn't see your mail.

c@mythbackend:~$ dpkg -l | grep -i myth
rc libmyth-0.25-0
2:0.25.2+fixes.20120802.46cab93-0ubuntu1 Common library code for
MythTV and add-on modules (runtime)
ii libmyth-0.26-0
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Common library code for
MythTV and add-on modules (runtime)
ii libmyth-python
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 A python library to
access some MytTV features
ii libmythtv-perl
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 A PERL library to access
some MythTV features
ii mythbuntu-bare-client
2.2 Mythbuntu Bare Client
ii mythbuntu-common
0.67 Mythbuntu application
support functions
ii mythbuntu-control-centre
0.63-0ubuntu2 Mythbuntu Configuration
Application
ii mythbuntu-default-settings
1.08 default settings for
Mythbuntu
ii mythbuntu-desktop
0.77 The Mythbuntu standalone
system
ii mythbuntu-lightdm-theme
1.01 Mythbuntu LightDM setup
ii mythbuntu-log-grabber
0.10-0ubuntu1 Mythbuntu diagnostic
utility
ii mythgallery
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Image gallery/slideshow
add-on module for MythTV
ii mythmusic
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Music add-on module for
MythTV
ii mythtv
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
application (client and server)
ii mythtv-backend
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
application (server)
ii mythtv-backend-master
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Metapackage to setup and
configure a "Master Backend" profile of MythTV.
ii mythtv-common
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
application (common data)
ii mythtv-database
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
application (database)
ii mythtv-frontend
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
application (client)
ii mythtv-theme-mythbuntu
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 The mythbuntu MythTV
Theme
ii mythtv-transcode-utils
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Utilities used for
transcoding MythTV tasks
ii mythweb
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Web interface add-on
module for MytTV
ii php-mythtv
2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 PHP Bindings for MythTV

On Sun, Sep 15, 2013 at 7:41 PM, Thomas Mashos
<email address hidden>wrote:

> No, dropping the repo would not fix the issue. Can you post what the
> output of this is
>
> "dpkg -l | grep -i myth"
> Thanks,
>
> Thomas Mashos
>
>
> On Sun, Sep 15, 2013 at 4:24 PM, kmitche <email address hidden>
> wrote:
> > Thomas,
> > I am running the mythbuntu repo. Mythlogserver appears to be active as a
> result. Dropping the repo would fix this issue, correct? Thanks for
> following up with this.
> > Kent
> > ...

Thomas Mashos (tgm4883) wrote :
Download full text (20.1 KiB)

This is only fixed in 0.27

Thanks,
Thomas Mashos
On Sep 15, 2013 6:35 PM, "doylecentral" <email address hidden> wrote:

> Sorry didn't see your mail.
>
> c@mythbackend:~$ dpkg -l | grep -i myth
> rc libmyth-0.25-0
> 2:0.25.2+fixes.20120802.46cab93-0ubuntu1 Common library code for
> MythTV and add-on modules (runtime)
> ii libmyth-0.26-0
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Common library code for
> MythTV and add-on modules (runtime)
> ii libmyth-python
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 A python library to
> access some MytTV features
> ii libmythtv-perl
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 A PERL library to access
> some MythTV features
> ii mythbuntu-bare-client
> 2.2 Mythbuntu Bare Client
> ii mythbuntu-common
> 0.67 Mythbuntu application
> support functions
> ii mythbuntu-control-centre
> 0.63-0ubuntu2 Mythbuntu Configuration
> Application
> ii mythbuntu-default-settings
> 1.08 default settings for
> Mythbuntu
> ii mythbuntu-desktop
> 0.77 The Mythbuntu standalone
> system
> ii mythbuntu-lightdm-theme
> 1.01 Mythbuntu LightDM setup
> ii mythbuntu-log-grabber
> 0.10-0ubuntu1 Mythbuntu diagnostic
> utility
> ii mythgallery
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Image gallery/slideshow
> add-on module for MythTV
> ii mythmusic
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Music add-on module for
> MythTV
> ii mythtv
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
> application (client and server)
> ii mythtv-backend
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
> application (server)
> ii mythtv-backend-master
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Metapackage to setup and
> configure a "Master Backend" profile of MythTV.
> ii mythtv-common
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
> application (common data)
> ii mythtv-database
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
> application (database)
> ii mythtv-frontend
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Personal video recorder
> application (client)
> ii mythtv-theme-mythbuntu
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 The mythbuntu MythTV
> Theme
> ii mythtv-transcode-utils
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Utilities used for
> transcoding MythTV tasks
> ii mythweb
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 Web interface add-on
> module for MytTV
> ii php-mythtv
> 2:0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1 PHP Bindings for MythTV
>
>
> On Sun, Sep 15, 2013 at 7:41 PM, Thomas Mashos
> <email address hidden>wrote:
>
> > No, dropping the repo would not fix the issue. Can you post what the
> > output of this is
> >
> > "dpkg -l | grep -i myth"
> > Thanks,
> >
> > Thomas Mashos
...

Peter D. (0123peter) wrote :
Download full text (4.8 KiB)

Hi,

I've forgotten whether this is a top post list or a bottom post list.
Sorry.

Somebody posted that the fix is only in 0.27, I was running either
mythtv-backend_2%3a0.26.1+fixes.20130906.dbdd455-0ubuntu0mythbuntu1_amd64.deb
or
mythtv-backend_2%3a0.26.1+fixes.20130914.bd7198b-0ubuntu0mythbuntu1_amd64.deb
when the error popped up.

I'm surprised that that information was not captured automatically,
there was a very large data transfer.

bP

On Sun, 15 Sep 2013 23:02:14 -0000
Thomas Mashos <email address hidden> wrote:

> Are you running packages that are after September 7th? (currently,
> those only exist in the Mythbuntu repo). You'll see from this commit
> that it's literally impossible for mythlogserver to crash anymore
>
> https://github.com/MythTV/packaging/commit/b2571edc639c8d99262dfd4ea222ec920d8a2451
> Thanks,
>
> Thomas Mashos
>
>
> On Sun, Sep 15, 2013 at 3:46 PM, Peter D.
> <email address hidden> wrote:
> > Bug still exists 16th September.
> >
> > --
> > You received this bug notification because you are a member of
> > Mythbuntu Bug Team, which is subscribed to MythTV.
> > https://bugs.launchpad.net/bugs/1101395
> >
> > Title:
> > mythlogserver crashed with SIGSEGV in QObject::disconnect()
> >
> > Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
> > Triaged
> > Status in MythTV:
> > Unknown
> > Status in “mythtv” package in Ubuntu:
> > Fix Released
> >
> > Bug description:
> > crashed on remote frontend
> >
> > ProblemType: Crash
> > DistroRelease: Ubuntu 12.04
> > Package: mythtv-common
> > 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 [origin:
> > LP-PPA-mythbuntu-0.26] ProcVersionSignature: Ubuntu
> > 3.2.0-35.55-generic 3.2.34 Uname: Linux 3.2.0-35-generic x86_64
> > NonfreeKernelModules: nvidia .var.log.mythtv.mythavtest.log:
> >
> > .var.log.mythtv.mythbackend.log:
> >
> > .var.log.mythtv.mythccextractor.log:
> >
> > .var.log.mythtv.mythcommflag.log:
> >
> > .var.log.mythtv.mythfilldatabase.log:
> >
> > .var.log.mythtv.mythjobqueue.log:
> >
> > .var.log.mythtv.mythlcdserver.log:
> >
> > .var.log.mythtv.mythmediaserver.log:
> >
> > .var.log.mythtv.mythmetadatalookup.log:
> >
> > .var.log.mythtv.mythpreviewgen.log:
> >
> > .var.log.mythtv.mythshutdown.log:
> >
> > .var.log.mythtv.mythtranscode.log:
> >
> > .var.log.mythtv.mythtv.setup.log:
> >
> > .var.log.mythtv.mythutil.log:
> >
> > .var.log.mythtv.mythwelcome.log:
> >
> > ApportVersion: 2.0.1-0ubuntu17.1
> > Architecture: amd64
> > CrashDB: mythbuntu
> > Date: Fri Jan 18 15:13:07 2013
> > Disassembly: => 0x0: Cannot access memory at address 0x0
> > DistributionChannelDescriptor:
> > # This is a distribution channel descriptor
> > # For more information see
> > http://wiki.ubuntu.com/DistributionChannelDescriptor
> > canonical-oem-somerville-precise-amd64-20120703-2
> > ExecutablePath: /usr/bin/mythlogserver InstallationMedia: Ubuntu
> > 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
> > Installed_mythtv_dbg:
> > 2:0.26.0+fixes.20130118.8f8274a-0ubuntu0mythbuntu2 MarkForUpload:
> > True MythTVDirectoryPermissions: total 4
> > drwxr-xr-x 2 root root 4096 Nov 2...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.