Ubuntu

Newer version of MythTV fixing some major bugs needs an SRU

Reported by Thomas Mashos on 2012-07-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

For each MythTV release, upstream keeps a "fixes" branch where they commit fixes (rather than features) of bugs found in that release. This has quite a few fixes for some major bugs found in the version released with 12.04 and be uploaded as an SRU.

[IMPACT]

 * Minor issues aside, some of the major issues in the 12.04 release are
    * Running mythfilldatabase takes much longer (hours instead of minutes) to run due to MySQL 5.5 using the innodb engine by default. ( https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/997367 )
    * One of the most popular tuner cards failed recording when run in Digital Cable mode ( http://code.mythtv.org/trac/ticket/10712 )

 * Mythbuntu is doing LTS only releases, thus this needs to be fixed in the point release ISOs.

[TESTCASE]

 * Install a MythTV backend, sign up for an account at http://www.schedulesdirect.org/, configure mythtv-backend, run mythfilldatabase --dd-grab-all. This will take a few hours to run and disk IO will be high.

[Regression Potential]

 * The MythTV set of packages are isolated in that nothing is built against them. There should be no regression as the fixes are on MythTV itself.

 * The Mythbuntu team provides a PPA with builds of MythTV where these fixes have been tested on 12.04. We've not heard any negative feedback on these fixes.

Changed in mythtv (Ubuntu):
milestone: none → ubuntu-12.04.1
Changed in mythtv (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Changed in mythtv (Ubuntu):
milestone: ubuntu-12.04.1 → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 2:0.25.2+fixes.20120801.46cab93-0ubuntu1

---------------
mythtv (2:0.25.2+fixes.20120801.46cab93-0ubuntu1) quantal; urgency=low

  * New upstream fixes branch checkout (46cab93)
  * Updated to 0.25.2 point release. (LP: #1029522)
    - Major fixes:
    - Mythfilldatabase takes hours instead of minutes to run (LP: #997367)
    - A popular tuner card doesn't record in digital cable mode (trac 10712)
 -- Mario Limonciello <email address hidden> Wed, 01 Aug 2012 09:04:32 -0500

Changed in mythtv (Ubuntu):
status: New → Fix Released
Dave Walker (davewalker) wrote :

MRE raised here: https://lists.ubuntu.com/archives/technical-board/2012-August/001357.html

However, based on prior art.. As this is a one off, i'm expecting the TB to comment that an MRE isn't required, and this can be handled between the SRU and Release Team.

Mario Limonciello (superm1) wrote :

This MRE was approved today. It should be releasable from the queue:

http://ubottu.com/meetingology/logs/ubuntu-meeting/2012/ubuntu-meeting.2012-08-06-21.00.log.html

Steve Langasek (vorlon) wrote :

The uploaded SRU includes the following new file, which is not covered by the MRE and not explained in the changelog:

--- mythtv-0.25.0+fixes.20120410.1f5962a/debian/30-mythtv-sysctl.conf 1970-01-01 00:00:00.000000000 +0000
+++ mythtv-0.25.2+fixes.20120802.46cab93/debian/30-mythtv-sysctl.conf 2012-08-01 13:59:24.000000000 +0000
@@ -0,0 +1,5 @@
+# Increase the max allowed socket buffer for MythTV.
+# See http://code.mythtv.org/trac/ticket/10414 for more context
+# Doesn't actually increase the default socket buffer so it shouldn't affect
+# any other applications.
+net.core.rmem_max=1048576

Please explain why this is appropriate to include in an SRU (preferably with a reupload that provides a link to an Ubuntu bug in the changelog).

--- mythtv-0.25.0+fixes.20120410.1f5962a/debian/mythtv-database.postinst 2011-12-08 16:10:15.000000000 +0000
+++ mythtv-0.25.2+fixes.20120802.46cab93/debian/mythtv-database.postinst 2012-08-01 13:59:24.000000000 +0000
@@ -112,7 +112,7 @@
     #and mysql binding checks
     if [ -f "${MYSQLCONFIG}" ]; then
         db_get mythtv/public_bind
- if [ $RET = true ]; then
+ if [ -n "$RET" ] && [ $RET = true ]; then
             NEWIP=`ifconfig | grep "inet addr:" | grep --invert-match 127.0.0.1 | sed ' s/inet addr://g; s/^[ \t]*//;s/[ \t]*$//; q;' | awk '{print $1}'`
             sed -i -e 's/^#bind/bind/' ${MYSQLCONFIG}
         else

This would have been more succinctly written

   if [ "$RET" = true ]; then

> + * Update apport hook for python3 (LP: #1013171)

python3 is not used for apport in 12.04, and there's no reason to include such a change in an SRU - this is all risk and no benefit. Please drop this change.

The rest of the changes to debian/ seem fine, and the changes outside of debian/ are of course covered by the MRE. Please reupload with the aforementioned changes. Rejecting from the queue for now.

Changed in mythtv (Ubuntu Precise):
status: New → Triaged

Hello Thomas, or anyone else affected,

Accepted mythtv into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mythtv/2:0.25.2+fixes.20120802.46cab93-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mythtv (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Thomas Mashos (tgm4883) wrote :

I've confirmed that the new package resolves the other bugs. Marking verification-done

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 2:0.25.2+fixes.20120802.46cab93-0ubuntu1

---------------
mythtv (2:0.25.2+fixes.20120802.46cab93-0ubuntu1) precise-proposed; urgency=low

  * New upstream fixes branch checkout (46cab93)
  * Updated to 0.25.2 point release. (LP: #1029522)
  * Major fixes:
    - Mythfilldatabase takes hours instead of minutes to run (LP: #997367)
    - A popular tuner card doesn't record in digital cable mode (trac 10712)
  * fix get-orig-source rule's broken tarball fetch from archive.
  * Enable libcec support (LP: #982272)
  * Add missingok to additional mythtv-backend logs. (LP: #982162)
  * Pull an updated snapshot of Mythbuntu theme, to avoid theme
    downloader telling the user there is an updated theme on first
    boot.
  * Update amejia's email on uploaders field.
  * Drop recommends on adept-notifier.
  * Bump standards version.
  * New upstream checkout (25dd4ce)
 -- Mario Limonciello <email address hidden> Wed, 08 Aug 2012 20:32:13 -0500

Changed in mythtv (Ubuntu Precise):
status: Fix Committed → Fix Released
Stefano Rivera (stefanor) wrote :

Erm, this was copied forward to raring, but isn't installable

http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html#mythtv

I'll do a new upload to raring shortly that should sort that out.

On Wed, Nov 7, 2012 at 8:19 AM, Stefano Rivera <email address hidden>wrote:

> Erm, this was copied forward to raring, but isn't installable
>
> http://people.canonical.com/~ubuntu-archive/proposed-
> migration/update_excuses.html#mythtv
>
> --
> You received this bug notification because you are a member of Mythbuntu
> Bug Team, which is subscribed to mythtv in Ubuntu.
> https://bugs.launchpad.net/bugs/1029522
>
> Title:
> Newer version of MythTV fixing some major bugs needs an SRU
>
> Status in “mythtv” package in Ubuntu:
> Fix Released
> Status in “mythtv” source package in Precise:
> Fix Released
>
> Bug description:
> For each MythTV release, upstream keeps a "fixes" branch where they
> commit fixes (rather than features) of bugs found in that release.
> This has quite a few fixes for some major bugs found in the version
> released with 12.04 and be uploaded as an SRU.
>
> [IMPACT]
>
> * Minor issues aside, some of the major issues in the 12.04 release are
> * Running mythfilldatabase takes much longer (hours instead of
> minutes) to run due to MySQL 5.5 using the innodb engine by default. (
> https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/997367 )
> * One of the most popular tuner cards failed recording when run in
> Digital Cable mode ( http://code.mythtv.org/trac/ticket/10712 )
>
> * Mythbuntu is doing LTS only releases, thus this needs to be fixed
> in the point release ISOs.
>
> [TESTCASE]
>
> * Install a MythTV backend, sign up for an account at
> http://www.schedulesdirect.org/, configure mythtv-backend, run
> mythfilldatabase --dd-grab-all. This will take a few hours to run and
> disk IO will be high.
>
> [Regression Potential]
>
> * The MythTV set of packages are isolated in that nothing is built
> against them. There should be no regression as the fixes are on MythTV
> itself.
>
> * The Mythbuntu team provides a PPA with builds of MythTV where these
> fixes have been tested on 12.04. We've not heard any negative feedback
> on these fixes.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/1029522/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~mythbuntu-bugs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~mythbuntu-bugs
> More help : https://help.launchpad.net/ListHelp
>

--
Mario Limonciello
<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.