Merge mythtv-status from Debian unstable (main)

Bug #243205 reported by Stefan Ebner on 2008-06-26
4
Affects Status Importance Assigned to Milestone
mythtv-status (Debian)
Fix Released
Unknown
mythtv-status (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: mythtv-status

 mythtv-status (0.9.0-5) unstable; urgency=medium

   * Update init.d with feedback from Adeodato Simó.

 -- Andrew Ruthven <email address hidden> Sat, 08 Nov 2008 10:49:01 +1300
mythtv-status (0.9.0-4) unstable; urgency=medium

   * It turns out that release 0.9.1 of mythtv-status snuck into
     the 0.9.0-2 upload, back that out for now.

 -- Andrew Ruthven <email address hidden> Thu, 30 Oct 2008 13:55:01 +1300
mythtv-status (0.9.0-3) unstable; urgency=medium

   * If someone has removed /var/run/motd then tries to install (or
     reinstall) this package, then it fails. We should make sure that
     doesn't happen by making sure that /var/run/motd exists.
   * Provide some sanity checking before updating the MOTD file in
     the init.d script to make sure that mythtv-status didn't die.

 -- Andrew Ruthven <email address hidden> Tue, 28 Oct 2008 15:12:02 +1300
mythtv-status (0.9.0-2) unstable; urgency=low

   * The init.d script shouldn't check the return code anymore, as the
     return code may be 1 if there are any warnings present. This
     has been stopping the MOTD from being updated.

 -- Andrew Ruthven <email address hidden> Mon, 26 Sep 2008 09:16:53 +1200
mythtv-status (0.9.0-1) unstable; urgency=low

   * New upstream release.
   * Add DM-Upload-Allowed field as I'm now a DM.
   * Upstream license has changed to GPL3.

 -- Andrew Ruthven <email address hidden> Fri, 11 Jul 2008 10:14:20 +1200

mythtv-status (0.8.1-3) unstable; urgency=low

   * A number of small changes to the /etc/default/mythtv-status file
     to make it clearer which script uses which settings.
   * Thank you to Tom Metro for the above suggestion.
   * Fix the handling of EMAIL_ARGS in the postinst to honour it being
     unset. Thank you to Tom for reporting the issue.
   * Not uploaded to Debian.

 -- Andrew Ruthven <email address hidden> Sat, 5 Jul 2008 21:15:00 +1200

 mythtv-status (0.8.1-2) unstable; urgency=low

   * Make sure that variables in /etc/default/mythtv-status that might
     have spaces in them are handled correctly in the postinst.

 -- Andrew Ruthven <email address hidden> Mon, 23 Jun 2008 14:27:29 +1200

mythtv-status (0.8.1-1) unstable; urgency=low

   * New upstream release.

 -- Andrew Ruthven <email address hidden> Thu, 19 Jun 2008 12:26:27 +1200

mythtv-status (0.8.0-2) unstable; urgency=low

   * Stop run-parts in the cron.daily script from complaining if mythtv-status
     returns an exit code of 1 (which is common).

 -- Andrew Ruthven <email address hidden> Thu, 19 Jun 2008 11:09:04 +1200

mythtv-status (0.8.0-1) unstable; urgency=low

   * New upstream release.
   * Update Standards-Version to 3.8.0.
   * Change dependency on libmime-perl to libmime-tools-perl.

 -- Andrew Ruthven <email address hidden> Wed, 18 Jun 2008 12:46:48 +1200

mythtv-status (0.7.4-1) unstable; urgency=low

   * New upstream release (not uploaded to Debian).

 -- Andrew Ruthven <email address hidden> Fri, 23 May 2008 09:31:39 +1200

Stefan Ebner (sebner) wrote :
Changed in mythtv-status:
assignee: nobody → sebner
status: New → In Progress
assignee: sebner → nobody
status: In Progress → Confirmed
Dustin Kirkland  (kirkland) wrote :

I, too, merged this package before I found this bug report.

It's basically identical, slightly different verbage in the changelog.

For what it's worth, I have uploaded it here:
 * http://people.ubuntu.com/~kirkland/mythtv-status/

:-Dustin

Mario Limonciello (superm1) wrote :

Can one of you two first try to get debian to accept our delta? Perhaps as a Recommends libmythtv-perl | libmyth-perl or similar. If they say no for some reason or another, we'll keep carrying the delta, otherwise its a good idea to drop it.

Dustin Kirkland  (kirkland) wrote :

Bug filed with Debian, including a patch. See:
 * http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=489830

Linked to this Launchpad bug report.

:-Dustin

Changed in mythtv-status:
status: Unknown → New
Andrea Colangelo (warp10) wrote :

Unsubscribing u-u-s. Please, resubscribe when you are ready to upload the debdiff (if Debian doesn't accept our delta in a reasonable time).

Artur Rona (ari-tczew) on 2009-07-27
tags: added: merge
Artur Rona (ari-tczew) on 2009-08-06
description: updated
tags: added: upgrade
summary: - Merge mythtv-status 0.8.1-2 from Debian(Unstable)
+ Merge mythtv-status 0.9.0-5 from Debian unstable (main)
Artur Rona (ari-tczew) on 2009-09-13
tags: added: patch

The following message has gone unanswered on the upstream ticket for 14 months. Appears they are waiting on Ubuntu for a response:

<<
In my opinion the libmyth-perl package in Ubuntu is misnamed. According
to the Debian Perl Policy [0], it should be named libmythtv-perl.

I've had a bit of a look on the Ubuntu website to see if Ubuntu has a
Perl Policy as Debian does, but I can't find one. Is there one?
>>

Bug #455542 talks about getting version 0.9.2-2 of mythtv-status merged in Debian Sid since mythtv-status now has trouble calculating disk space. On the assumption that #455542 might be solved simply by merging (and so there will still be a delta), we can leave this ticket open hoping that someone can help the resolve the diff.

Changed in mythtv-status (Ubuntu):
importance: Undecided → Low
summary: - Merge mythtv-status 0.9.0-5 from Debian unstable (main)
+ Merge mythtv-status from Debian unstable (main)
Changed in mythtv-status (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.