Clicking the RSS feed at the bottom of the "Recorded" page results in an error page.

Bug #502129 reported by anonymous1 on 2010-01-01
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Fix Released
Low
Unassigned
mythplugins
Fix Released
Unknown
mythplugins (Ubuntu)
Low
Unassigned

Bug Description

Warning at /usr/share/mythtv/mythweb/modules/_shared/tmpl/_errors/unknown_module.php, line 23:
require(modules/_shared/tmpl/rss/header.php) [function.require]: failed to open stream: No such file or directory
Fatal error: require() [function.require]: Failed opening required 'modules/_shared/tmpl/rss/header.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/mythtv/mythweb/modules/_shared/tmpl/_errors/unknown_module.php on line 23

darthanubis (darthanubis) wrote :

Was unable to file bug against 'Mythweb' because ubuntu-bug mythweb errored out.

*** Problem in mythweb

The problem cannot be reported:

This is not a genuine Ubuntu package

Press any key to continue...
No pending crash reports. Try --help for more information.

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.

*** Error: Invalid problem report

Package mythbuntu does not exist

Press any key to continue...
No pending crash reports. Try --help for more information.

Per Superm1, I filed the bug this way. I am using the mythbuntu autobuilds package.

Thomas Mashos (tgm4883) wrote :

Looks like the page it tries to go to is
http://ares/mythweb/rss/mythweb/tv/recorded?recgroup=&title=

It should go to
http://ares/mythweb/rss/tv/recorded?recgroup=&title=

(note my backend's hostname is ares. Note the extra mythweb in the wrong one)

Changed in mythbuntu:
status: New → Confirmed
importance: Undecided → Low
darthanubis (darthanubis) wrote :

Thank you for confirming.

Thomas Mashos (tgm4883) wrote :

Seems to be $_SERVER['REQUEST_URI'] returns mythweb/tv/recorded instead of just tv/recorded

Thomas Mashos (tgm4883) wrote :

Same bug also effects ical in upcoming recordings

Nick Fox (nickj-fox) wrote :

I have posted a diff for fixing it in mythweb upstream

http://svn.mythtv.org/trac/ticket/7948

Changed in mythplugins:
status: Unknown → New
MarcRandolph (mrand) wrote :

Setting to triaged since there is an upstream ticket

Changed in mythplugins (Ubuntu):
importance: Undecided → Low
status: New → Triaged
MarcRandolph (mrand) wrote :

Leaving Mythbuntu task open for now - maybe patch for 10.04 if upstream doesn't fix it?

Changed in mythbuntu:
status: Confirmed → Triaged
Vincent Bentley (vince-vlara) wrote :

I am using Mythbuntu 0.23 on 10.04 and this fault is still evident. Looking at MythTV ticket 7948 I guess it is not going to be fixed until 0.24 is released.

Changed in mythplugins:
status: New → Fix Released
summary: Mythweb RSS feed broken. Clicking the RSS feed at the bottom of the
- "Recorded" page results in an error page
+ "Recorded" page results in an error page.
description: updated
summary: - Mythweb RSS feed broken. Clicking the RSS feed at the bottom of the
- "Recorded" page results in an error page.
+ Clicking the RSS feed at the bottom of the "Recorded" page results in an
+ error page.
description: updated
Thomas Mashos (tgm4883) on 2011-05-05
Changed in mythbuntu:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.