Ubuntu

Some mythplugins packages fail to configure if /var/lib/mythtv NFS mounted

Reported by Mark Warriner on 2008-04-21
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mythexport (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
mythplugins (Ubuntu)
Undecided
Mario Limonciello
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: mythgallery, mythmusic, mythvideo

When /var/lib/mythtv is mounted over NFS, the following MythTV plug-in packages will fail to configure: mythgallery, mythmusic, mythvideo. These packages attempt to change ownership/permissions on subdirectories of /var/lib/mythtv, which is not allowed with a typical server-side NFS configuration. The failures will occur even if the permissions are already set correctly on these directories, and even if completely different directories are configured in the database settings.

Setting up mythgallery (0.21.0-0ubuntu2~gutsy1) ...
chown: changing ownership of `/var/lib/mythtv/pictures': Operation not permitted
dpkg: error processing mythgallery (--configure):
 subprocess post-installation script returned error exit status 1
Setting up mythvideo (0.21.0-0ubuntu2~gutsy1) ...
chown: changing ownership of `/var/lib/mythtv/videos': Operation not permitted
dpkg: error processing mythvideo (--configure):
 subprocess post-installation script returned error exit status 1
Setting up mythmusic (0.21.0-0ubuntu2~gutsy1) ...
chown: changing ownership of `/var/lib/mythtv/music': Operation not permitted
dpkg: error processing mythmusic (--configure):
 subprocess post-installation script returned error exit status 1

This issue is likely to occur for those who use NFS when upgrading from version 0.20 to 0.21 in gutsy-backports or hardy. A possible workaround is to temporarily unmount the NFS, then completely reinstall all three packages. Note that simply retrying the configure after unmounting does not necessarily work, since those directories would not have been created during package install (empty mount point directory eclipsed by NFS mount).

Mark Warriner (warriner) on 2008-04-21
description: updated
laga (laga) wrote :

Here's a debdiff.

This differs from the original approach for this SRU (as discussed with superm1 and slangasek). It was planned to change the code to ignore chmod/chown failures on package updates, but not on fresh installs. However, that doesn't make a lot of sense considering that people might already have the network mounts in place before they install the packages for the first time.

Maybe it'd be a good idea to check permissions and only fix them if necessary, but that'd be too intrusive for an SRU, IMHO.

Luca Falavigna (dktrkranz) wrote :

ACK from motu-sru.

Consider adjusting version to be 0.21.0+fixes16838-0ubuntu2.1, though.

Changed in mythplugins:
status: New → Confirmed
Mario Limonciello (superm1) wrote :

fix committed in intrepid bzr #59

Changed in mythplugins:
assignee: nobody → superm1
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythplugins - 0.21.0+fixes17416-0ubuntu1

---------------
mythplugins (0.21.0+fixes17416-0ubuntu1) intrepid; urgency=low

  [ Mario Limonciello ]
  * New upstream checkout.
    - Fixes mythmovies stability issues (LP: #230240)
  * debian/control:
    - Build depend on 17416 of mythtv-common.
  * Update 11_ofdb_r16988_r16995 for changes that were absorbed into -fixes.

  [ Michael Haas ]
  * Don't fail if {mythgallery, mythvideo, mythmusic} can't chmod/chown their
    directories in /var/lib/. Some people have these directories mounted on NFS
    which will prevent those packages from upgrading/installing successfully.
    (LP: #220087)

 -- Mario Limonciello <email address hidden> Sun, 01 Jun 2008 17:50:28 -0500

Changed in mythplugins:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in mythplugins:
status: Confirmed → Fix Committed
Mario Limonciello (superm1) wrote :

I've verified that the SRU does work correctly on Hardy. See attached test case for details

Steve Langasek (vorlon) wrote :

Copied to hardy-updates, thanks.

Changed in mythplugins:
status: Fix Committed → Fix Released
rhpot1991 (rhpot1991) on 2009-10-05
Changed in mythexport (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythexport - 2.1.2-0ubuntu1

---------------
mythexport (2.1.2-0ubuntu1) karmic; urgency=low

  * Added starting values div to web interface.
  * Fixed commercial removal.
  * Modified daemon to retry MythTV connection before failing.
  * Fixed SQL error that occurs on installation (LP: #443158).
  * Fixed archos ffmpeg line (LP: #393457).
  * Fixed AP avi errors (LP: #393609).
  * Fixed read only export directory issue (LP: #220087).

 -- John Baab <email address hidden> Mon, 05 Oct 2009 01:06:33 -0400

Changed in mythexport (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments