Ubuntu

mythexport podcast name feature does not work

Reported by Malcolm Parsons on 2010-10-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythexport (Ubuntu)
Undecided
rhpot1991

Bug Description

Binary package hint: mythexport

$ apt-cache policy mythexport
mythexport:
  Installed: 2.2.2-0ubuntu1~ppa8
  Candidate: 2.2.2-0ubuntu1~ppa8
  Version table:
 *** 2.2.2-0ubuntu1~ppa8 0
        500 http://ppa.launchpad.net/mythbuntu/testing/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     2.1.5-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/universe Packages

Observed: All exported files have a blank podcast name.
Expected: Exported files have the supplied podcast name.

setupsave.cgi creates userjobs with deleteperiod and podcastname arguments to mythexport_addjob.

e.g.
"mythexport_addjob starttime=%STARTTIME% chanid=%CHANID% config=MP3
deleteperiod=14 podcastname=MP3"

The mythexport_addjob script doesn't have deleteperiod or podcastname arguments.

rhpot1991 (rhpot1991) on 2010-10-19
Changed in mythexport (Ubuntu):
status: New → Confirmed
assignee: nobody → rhpot1991 (rhpot1991)
rhpot1991 (rhpot1991) on 2010-10-28
Changed in mythexport (Ubuntu):
status: Confirmed → Fix Committed
rhpot1991 (rhpot1991) wrote :

I pushed a change to this in the testing ppa as mythexport 2.2.3-0ubuntu1~ppa1

Please test it out and leave some feedback, then I can look into getting it into Maverick as a SRU.

$ apt-cache policy mythexport
mythexport:
  Installed: 2.2.2-0ubuntu1~ppa8
  Candidate: 2.2.3-0ubuntu1~ppa1
  Version table:
     2.2.3-0ubuntu1~ppa1 0
        500 http://ppa.launchpad.net/mythbuntu/testing/ubuntu/ lucid/main Packages
 *** 2.2.2-0ubuntu1~ppa8 0
        100 /var/lib/dpkg/status
     2.1.5-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/universe Packages

$ sudo apt-get install mythexport
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  mythexport: Depends: libavutil-extra-50 but it is not installable
E: Broken packages

rhpot1991 (rhpot1991) wrote :

Guessing you are on lucid and not maverick?

> > 500 http://ppa.launchpad.net/mythbuntu/testing/ubuntu/ lucid/main Packages

> Guessing you are on lucid and not maverick?

Yes.

rhpot1991 (rhpot1991) wrote :

I forgot that a dependency changed for maverick. If you update it should pull mythexport 2.2.3-0ubuntu1~ppa2 which should install fine for lucid.

The podcast name feature works in this version.

I haven't tested the deleteperiod feature.

I've applied this patch to my install to make the "Filter by Podcast Name" box work when not all files have a podcast name:

--- /usr/share/mythtv/mythexport/rss.cgi.orig 2010-11-01 13:51:42.611370959 +0000
+++ /usr/share/mythtv/mythexport/rss.cgi 2010-11-01 13:52:03.023371905 +0000
@@ -28,7 +28,7 @@
 my $script = "<script type=\"text/javascript\" src=\"includes/ajax.js\"></script>";

 # find all podcast names
-my $query = "SELECT distinct(podcastName) FROM mythexport";
+my $query = "SELECT distinct(podcastName) FROM mythexport WHERE podcastName is not NULL";
 my $query_handle = $connect->prepare($query);
 $query_handle->execute() || die "Unable to query mythexport table";

deleteperiod seems to be working too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythexport - 2.2.3-0ubuntu1

---------------
mythexport (2.2.3-0ubuntu1) natty; urgency=low

  [ John Baab ]
  * Added link to file on file page, useful for manual downloads.
  * Fixed an issue where delete period and podcast name were ignored (LP: #663314)
 -- John Baab <email address hidden> Tue, 26 Apr 2011 01:03:24 -0500

Changed in mythexport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers