Mythexport creates files with wrong permissions

Bug #1578387 reported by John Veness on 2016-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythexport (Ubuntu)
Undecided
Unassigned

Bug Description

I upgraded my system from Ubuntu 12.04 to 14.04. Back in 12.04 the files that mythexported created had 666 permissions, owner mythtv, group mythtv. In 14.04 they are still the same owner and group but have permissions 600. This means that I cannot download them through the RSS feed - I get a 403 error.

John Veness (pelago) wrote :

I have been looking into this more, and it looks like a umask issue. By adding debugging output to /usr/bin/mythexport-daemon, I see that the umask is fine until the startDaemon call, at which point it's set to 066. Presumably it is this that is creating the files with the permissions they have.

startDaemon called Proc::Daemon::Init, and looking at documentation for that, apparently it is normal behaviour to set the umask so.

What I don't know is exactly why this has changed between 12.04 and 14.04. I can't see much changes is the mythexport package between the two, but it may have been a change in Perl or Ubuntu.

If desired, I can show a list of all packages (including version numbers) that changed on my system between 12.04 and 14.04. And I have a backup of my 12.04 system I could roll back to if anyone wants to troubleshoot.

John Veness (pelago) wrote :

I have worked around this by adding:

system("chmod 666 \'$self->{_outputFile}$self->{_extension}\'");

after the ffmpeg line in the .pm file in the configs folder. This seems inelegant but does work. Another user on the mythtv-users mailing list confirmed they were affected the same after upgrading 12.04 to 14.04 and provided the fix. Although this works I am still interested as to what changed between the two versions to require this fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers