MythTV setup failed with "Cannot login"

Bug #728371 reported by Jean-Baptiste Lallement on 2011-03-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythbuntu-live-autostart (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: mythtv

ISO Testing: Mythbuntu i386/AMD64 - 20110302

After the installation of a MythTV systemof type Primary Backend w/ Frontend, and a system restart Mythtv setup starts but when clicking "Finish" on database setup step 2/2, the setup fails with "Cannot login"

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: mythtv-backend 2:0.24.0+fixes.20110214.ad3c81f-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
Date: Thu Mar 3 12:15:35 2011
InstallationMedia: Mythbuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
Installed_mythtv_dbg: 0.0
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: mythtv
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
tags: added: iso-testing
Mario Limonciello (superm1) wrote :
Download full text (17.7 KiB)

Thanks for the bug report. It looks like for some reason MySQL failed to start during install, causing it to not be properly configured.

Mar 3 11:04:30 ubuntu ubiquity: Rather than invoking init scripts through /etc/init.d, use the service(8)
Mar 3 11:04:30 ubuntu ubiquity: utility, e.g. service mysql stop
Mar 3 11:04:30 ubuntu ubiquity:
Mar 3 11:04:30 ubuntu ubiquity: Since the script you are attempting to invoke has been converted to an
Mar 3 11:04:30 ubuntu ubiquity: Upstart job, you may also use the stop(8) utility, e.g. stop mysql
Mar 3 11:04:58 ubuntu ubiquity: Rather than invoking init scripts through /etc/init.d, use the service(8)
Mar 3 11:04:58 ubuntu ubiquity: utility, e.g. service mysql start
Mar 3 11:04:58 ubuntu ubiquity:
Mar 3 11:04:58 ubuntu ubiquity: Since the script you are attempting to invoke has been converted to an
Mar 3 11:04:58 ubuntu ubiquity: Upstart job, you may also use the start(8) utility, e.g. start mysql
Mar 3 11:04:59 ubuntu ubiquity: mysql start/running, process 9378
Mar 3 11:04:59 ubuntu /etc/mysql/debian-start[9398]: Upgrading MySQL tables if necessary.
Mar 3 11:04:59 ubuntu kernel: [ 347.323752] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.324870] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.325538] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.326484] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.327078] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.331348] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.332049] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.336594] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.337399] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu kernel: [ 347.337823] non-accessible hardlink creation was attempted by: mysqld (fsuid 102)
Mar 3 11:04:59 ubuntu /etc/mysql/debian-start[9401]: /usr/bin/mysql_upgrade: the '--basedir' option is always ignored
Mar 3 11:04:59 ubuntu /etc/mysql/debian-start[9401]: Looking for 'mysql' as: /usr/bin/mysql
Mar 3 11:04:59 ubuntu /etc/mysql/debian-start[9401]: Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
Mar 3 11:04:59 ubuntu /etc/mysql/debian-start[9401]: Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysqld/mysqld.sock' '--host=localhost' '--socket=/var/run/mysqld/mysqld.sock' '--host=localhost' '--socket=/var/run/mysqld/mysqld.sock'
Mar 3 11:04:59 ubuntu /etc/mysql/debian-start[9401]: Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysqld/mysqld.sock' '--host=localhost' '--socket=/var/run/mysqld/mysqld.sock' '--host=localhost' '--socket=/var/run/mysqld/mysqld.sock'
Mar 3 11:04:59 ubuntu /etc/mysql/debian-start[9401]: mysql...

Mario Limonciello (superm1) wrote :

This is suspected to be caused by apparmour, which might make it a duplicate of https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/727478

Changed in mythtv (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
affects: mythtv (Ubuntu) → mythbuntu-live-autostart (Ubuntu)
Changed in mythbuntu-live-autostart (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
Mario Limonciello (superm1) wrote :

The non accessible hardlink errors go away if you run

  sysctl -w kernel.yama.protected_nonaccess_hardlinks=0

Before the myth-install-type page. Doesn't fix the second set of problems though.

Mario Limonciello (superm1) wrote :

So there's two distinct problems happening here. The first is fixed by the solution in comment #5. This may not be the proper solution, but it's functional for now.

The second is caused by upstart growing support to manage chroot jobs. The chroot job gets invoked in this case with mysqld.sock outside the chroot. This means that dpkg-reconfigure mythtv-database doesn't have access to it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythbuntu-live-autostart - 0.54-0ubuntu1

---------------
mythbuntu-live-autostart (0.54-0ubuntu1) natty; urgency=low

  * Fix spawning mysql in the install time chroot (LP: #728371)
    - The first fix turns off a kernel security feature for hardlinks
      temporarily, preventing a barage of errors as mysql is bootstrapped
    - The second stops the upstart job being managed from the chroot.
    - It's respawned manually in the chroot so processes in the chroot can
      still access it.
 -- Mario Limonciello <email address hidden> Fri, 04 Mar 2011 00:47:39 -0600

Changed in mythbuntu-live-autostart (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers