Ubuntu

mythbuntu-lircrc-generator generates duplicate keys for devinput

Reported by rtrevor on 2011-05-09
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
mythbuntu-lirc-generator (Ubuntu)
Medium
Mario Limonciello

Bug Description

Binary package hint: mythbuntu-lirc-generator

In Natty 11.04 (possibly other versions affected as well), when configuring lirc to use "Linux input layer (/dev/input/eventX)" it updates /etc/lirc/hardware.conf to read the devinput/lircd.conf.devinput file, which contains two remote setups, one normal, and one "legacy 32-bit".

Because there are two remote setups in there, when running mythbuntu-lircrc-generator it parses the file and generates two duplicate sets of controls in the lircrc output files. Every button press on the remote control is then entered twice.

In the short term, can be manually resolved by editing either lircd.conf.devinput or the generated lircrc files to remove duplicates.

Fix could be to have mythbuntu-lircrc-generator check that each key hasn't already been defined when generating the lircrc output files.

Mario Limonciello (superm1) wrote :

Thanks for the bug. I'm guessing we'll have to special case this until the duplicate config is removed from lirc.

Changed in mythbuntu-lirc-generator (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Mario Limonciello (superm1)
Obleak (fraser-arkhostings) wrote :

Same happens with DVico Fusion controllers. This is due to two remotes being configured with the same name

/usr/share/lirc/remotes/dvico$ ls -l
-rw-r--r-- 1 root root 10353 2006-05-06 14:38 lircd.conf.fusionHDTV

/usr/share/lirc/remotes/dvico$ grep name lircd.conf.fusionHDTV
  name DVICO
  name DVICO_MCE <==== this causes mythbuntu-lircrc-generator
  name DVICO_MCE <==== to create duplicate entries
  name DViCO_Utraview

ARULARASU (arularasug) on 2012-02-28
Changed in mythbuntu-lirc-generator (Ubuntu):
status: Confirmed → Fix Released
Mario Limonciello (superm1) wrote :

Please don't close bugs without fixing them.

Changed in mythbuntu-lirc-generator (Ubuntu):
status: Fix Released → Confirmed
frankster (wtfrank) wrote :

this bug occurs for me in 11.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers