lost gnome in gdm session chooser

Bug #426800 reported by ehcpdeveloper on 2009-09-09
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mythbuntu-default-settings (Ubuntu)
High
Mario Limonciello
Karmic
High
Mario Limonciello
xubuntu-default-settings (Ubuntu)
High
Lionel Le Folgoc
Karmic
High
Lionel Le Folgoc

Bug Description

I upgraded to karmic alpha 5,
then, updated all packages,

Now, I cannot see gnome in gdm session chooser, and I cannot use gnome..
xfce/kde is listed in gdm session chooser and they start, but I need gnome..

I did not delete gnome,

arky (arky) on 2009-09-09
affects: ubuntu → gdm (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Could you take a screenshot of the issue?

 This will help us to find and resolve the problem.

Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
ehcpdeveloper (ehcpdeveloper) wrote :

yes, this is always as I describe, reproducible, :) In fact I dont need to reproduce, it is already like that...
steps:
logout,(or turn on computer)
see login screen,
click on user,
on bottom, "select session," there is kde, xfce , but no gnome..

I am not sure that I can take a screenshot, because that is gdm login screen, not gnome or xfce..

Martin Pitt (pitti) wrote :

This is due to various *-default-settings packages diverting gnome.desktop, which is wrong. It needs to be fixed properly, see bug 403291:

mythbuntu-default-settings (0.80-0ubuntu1) karmic; urgency=low

  * Add in a set of workaround that will be used until a better solution
    to (LP: #403291) is developed.
  * preinst, postrm:
    - Add a diversion for /usr/share/xsessions/gnome.desktop so that we
      can make gnome.desktop be a symlink to mythbuntu.desktop since gdm
      now looks for gnome.desktop to pick it's default session.
  * links:
    - Provide gnome.desktop to force the default session.

 -- Mario Limonciello <email address hidden> Fri, 24 Jul 2009 14:19:02 -0500

affects: gdm (Ubuntu) → mythbuntu-default-settings (Ubuntu)
Changed in mythbuntu-default-settings (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Mario Limonciello (superm1)
importance: Low → Critical
status: Incomplete → Triaged
Changed in mythbuntu-default-settings (Ubuntu Karmic):
importance: Critical → High
milestone: none → karmic-alpha-6
Changed in xubuntu-default-settings (Ubuntu Karmic):
assignee: nobody → Lionel Le Folgoc (mrpouit)
importance: Undecided → High
milestone: none → karmic-alpha-6
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythbuntu-default-settings - 0.82-0ubuntu1

---------------
mythbuntu-default-settings (0.82-0ubuntu1) karmic; urgency=low

  * preinst:
    - Drop diversion for gnome.desktop (LP: #403291, #426800)
  * postrm:
    - Drop.
  * postinst:
    - Clean up diversion conditionally as necessary.
  * links:
    - Drop as our default filename will be default.desktop.
  * Rename mythbuntu.desktop to default.desktop.
  * control:
    - Provides/Conflicts for ubuntu-derivative-default-settings

 -- Mario Limonciello <email address hidden> Thu, 10 Sep 2009 09:51:28 -0500

Changed in mythbuntu-default-settings (Ubuntu Karmic):
status: Triaged → Fix Released
Changed in xubuntu-default-settings (Ubuntu Karmic):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 0.61

---------------
xubuntu-default-settings (0.61) karmic; urgency=low

  * debian/control: provides/conflicts with ubuntu-derivative-default-settings.
  * debian/xubuntu-default-settings.preinst: drop our diversion for
    gnome.desktop.
  * debian/xubuntu-default-settings.postinst: clean up our diversion.
  * debian/xubuntu-default-settings.postrm: dropped.
  * Provide default.desktop instead of gnome.desktop (LP: #403291, #426800).

 -- Lionel Le Folgoc <email address hidden> Thu, 10 Sep 2009 20:44:24 +0200

Changed in xubuntu-default-settings (Ubuntu Karmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers