cannot setup mythbuntu backend - Unable to connect to the database

Bug #711772 reported by Jean-Baptiste Lallement on 2011-02-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythbuntu-common (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Mythbuntu desktop i386 20110202.1

TEST CASE:
1. Install mythbuntu
2. Reboot
3. Login
4. Select Application/System/Mythbuntu backend
5. Follow the setup steps

Results:
The setup fails because it can"t connect to and populate the database.

Here is the output on the console:
2011-02-02 11:36:21.572 Using runtime prefix = /usr
2011-02-02 11:36:21.572 Using configuration directory = /home/ubuntu/.mythtv
2011-02-02 11:36:21.572 Empty LocalHostName.
2011-02-02 11:36:21.572 Using localhost value of ubuntu-VirtualBox
2011-02-02 11:36:21.577 New DB connection, total: 1
2011-02-02 11:36:21.580 Unable to connect to database!
2011-02-02 11:36:21.580 Driver error was [1/1045]:
QMYSQL: Unable to connect
Database error was:
Access denied for user 'mythtv'@'localhost' (using password: YES)

mysql log is attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: mythbuntu-desktop 0.63
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Wed Feb 2 11:36:34 2011
InstallationMedia: Mythbuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202.1)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: mythbuntu-meta

Jean-Baptiste Lallement (jibel) wrote :
tags: added: iso-testing
Mario Limonciello (superm1) wrote :

I suspect this is because the whole collection of ubiquity plugins was missing. I've just uploaded a new mythbuntu-common that should fix that. Hopefully this is the same root cause.

Changed in mythbuntu-meta (Ubuntu):
status: New → Fix Committed
affects: mythbuntu-meta (Ubuntu) → mythbuntu-common (Ubuntu)
Mario Limonciello (superm1) wrote :

I confirmed this was fixed in yesterday's builds.

Changed in mythbuntu-common (Ubuntu Natty):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers