Mythbuntu 16.04 LTS upgrade fails due to mythtv-tweaks.cnf for mysql

Bug #1576767 reported by Caysho on 2016-04-29
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Medium
Thomas Mashos
16.04
Undecided
Unassigned
16.10
Undecided
Unassigned
mythbuntu-common (Ubuntu)
Medium
Thomas Mashos

Bug Description

[Impact]
Using the Mythtv tweaks for MySQL in the Mythbuntu-control-centre causes MySQL to fail to start due to a variable that was renamed in MySQL 5.5. (see https://bugs.mysql.com/bug.php?id=68315 ). This is resolved by using the correct renamed variable name inside Mythbuntu-control-centre.

[Test Case]
Enable the "MySQL performance tweaks" inside Mythbuntu-control-centre, then try to restart MySQL.

[Regression Potential]
Low. This is currently causing MySQL to not start when applied, so in the event of a regression it would just continue to not start.

Original Descrition:

Upgrading from Mythbuntu 14.04 LTS / mythtv 0.28 to Mythbuntu 16.04 LTS / mythtv 0.28 and mythbuntu repositories disabled.

In Mythbuntu Control Centre, MySQL
"Enable MySQL performance tweaks" is selected.

Ran in terminal:
sudo update-manager -d

3) What you expected to happen
Not sure if this should be reported against mythbuntu-common or mythbuntu-control-centre but the expectation is that the mysql version be tested as part of the mythbuntu 0.28 install and the corrected mysql setting be included in the file.

4) What happened instead
Near the end of the upgrade, mysql server is started, and the /etc/mysql/conf.d/mythtv-tweaks.cnf file is invoked which contains the line
table_cache=128

According to
https://bugs.mysql.com/bug.php?id=68315
this is now deprecated, and table_open_cache replaces it.

The failure shows up in
/var/log/mysql/error.log
as
[ERROR] unknown variable 'table_cache=128'
[ERROR] Aborting

and mysql shuts down.
It then continues to start up mysql and shutdown again in a continues loop, effectively hanging.
The process must be killed and intervention is required to complete the upgrade.

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
pvruser@pvr:~$ lsb_release -rd
Description: Ubuntu 16.04 LTS
Release: 16.04

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
pvruser@pvr:~$ apt-cache policy mythbuntu-common
mythbuntu-common:
  Installed: 0.78.2
  Candidate: 0.78.2
  Version table:
 *** 0.78.2 500
        500 http://mirror.internode.on.net/pub/ubuntu/ubuntu xenial/universe i386 Packages
        100 /var/lib/dpkg/status

pvruser@pvr:~$ apt-cache policy mythbuntu-control-centre
mythbuntu-control-centre:
  Installed: 0.64.1
  Candidate: 0.64.1
  Version table:
 *** 0.64.1 500
        500 http://mirror.internode.on.net/pub/ubuntu/ubuntu xenial/universe i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: mythbuntu-common 0.78.2
ProcVersionSignature: Ubuntu 3.13.0-85.129-generic 3.13.11-ckt36
Uname: Linux 3.13.0-85-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.20.1-0ubuntu2
Architecture: i386
CurrentDesktop: XFCE
Date: Fri Apr 29 23:19:12 2016
InstallationDate: Installed on 2011-10-15 (1658 days ago)
InstallationMedia: Mythbuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427.1)
PackageArchitecture: all
SourcePackage: mythbuntu-common
UpgradeStatus: Upgraded to xenial on 2016-04-29 (0 days ago)

Caysho (caysho) wrote :
Caysho (caysho) wrote :

For the upgrade, I guess the easiest way to handle it would be to add an item to the Mythbuntu 16.04 Release Notes about disabling the tweaks.
Post upgrade, the mysql version will need to be checked and a fixed mysql tweaks file be included.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mythbuntu-common (Ubuntu):
status: New → Confirmed
Changed in mythbuntu-common (Ubuntu):
importance: Undecided → Medium
axelsvag (darinsson) wrote :

Now I read this bug and it affect me badly so please look into this since uncheck this does not seems to help a completely new install and never checks this was for me the only possible way out of the dilemma.

Thomas Mashos (tgm4883) on 2016-08-11
Changed in mythbuntu-common (Ubuntu):
assignee: nobody → Thomas Mashos (tgm4883)
Thomas Mashos (tgm4883) on 2016-08-11
Changed in mythbuntu-common (Ubuntu):
status: Confirmed → Fix Committed
Thomas Mashos (tgm4883) on 2016-08-11
Changed in mythbuntu:
assignee: nobody → Thomas Mashos (tgm4883)
importance: Undecided → Medium
status: New → Fix Committed
Thomas Mashos (tgm4883) on 2016-08-11
description: updated
Thomas Mashos (tgm4883) on 2016-08-11
description: updated
Mark Hamblin (5-mark-8) wrote :

I to adapted the clean 16.04 build,.. and imported a 0.27 database,... everything went smoothly until I applied the SQL tweaks,.. and the pc rebooted,... SQL then failed to start...
Editing the mythtv-tweaks.cnf file fixed it for me,.. comment out the table_cache=128 line and add table_open_cache=128 entry.
You can confirm this is your error by looking in the /var/log/mysql/error.log,....
tx guys for the simple fix

Changed in mythbuntu:
status: Fix Committed → Fix Released
Changed in mythbuntu-common (Ubuntu):
status: Fix Committed → Fix Released
Jaaxx (jaaxxlinux) wrote :

Not fixed in 16.10. Single line fix moron.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers