data grid not displaying resultset is blank

Bug #1376154 reported by Sylvain Viart on 2014-10-01
250
This bug affects 52 people
Affects Status Importance Assigned to Milestone
mysql-workbench (Debian)
Fix Released
Unknown
mysql-workbench (Ubuntu)
High
Unassigned
Utopic
Undecided
Unassigned

Bug Description

* Impact
data are not displayed

* Test case
after connection to the local mysql database.
Running a query
Nothing is displayed in view data grid

* Regression potential
the change is limited and to match gtk changes, check that the program works as it should, nothing special to watch

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mysql-workbench (Ubuntu):
status: New → Confirmed
Rocko (rockorequin) wrote :

The result grid is always blank in mysql-workbench-community 6.2.3-1ubu1404 as well. There's plenty of room to show the data but nothing is drawn. The bottom window (Action Output, etc) is also blank.

Rocko (rockorequin) wrote :

I get this error when I it from the command line and execute a query, so it might be a unity/compiz/gtk issue.

(mysql-workbench-bin:12296): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeModel) to class (gtkmm__CustomObject_13GridViewModel) after class_init

(mysql-workbench-bin:12296): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeDragDest) to class (gtkmm__CustomObject_13GridViewModel) after class_init

(mysql-workbench-bin:12296): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeDragSource) to class (gtkmm__CustomObject_13GridViewModel) after class_init

(mysql-workbench-bin:12296): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed

(mysql-workbench-bin:12296): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed

Sylvain Viart (sylvain-viart) wrote :

Will you create the ticket on their bug tracker or I'm supposed to do it?

Rocko (rockorequin) wrote :

@Sylvain: Would you be able to report it upstream? This bug means I can't use Ubuntu 14.10 and I so have had to go back to Ubuntu 14.04.

If it helps, Ubuntu 14.04 only reports this when mysql-workbench first runs:

(mysql-workbench-bin:10337): GLib-GObject-WARNING **: Attempt to add property gtkmm__CustomObject_14CustomRendererIN3Gtk16CellRendererTextEN4Glib7ustringES3_E::editable after class was initialised

and this when it (successfully) draws the results window:

(mysql-workbench-bin:10337): Gtk-CRITICAL **: gtk_tree_view_unref_tree_helper: assertion 'node != NULL' failed

Sylvain Viart (sylvain-viart) wrote :

Not sure to understand. I've some similar errors when starting from command line.

It doesn't work either with oracle binary.
I'm runing xfce.

Which upstream so?
Oracle, Gtk, other?

Of course I can post some ticket somewhere else, tell me where.

Rocko (rockorequin) wrote :

Ok, so I found that this has already been reported upstream to mysql, see: http://bugs.mysql.com/bug.php?id=74147

That bug says it's an incompatibility with libglib 2.42. There's a patch at http://bugs.mysql.com/file.php?id=21874&bug_id=74147 that fixes the problem.

If you want to patch and build mysql-workbench yourself, you can get the source from for 6.2.3 from http://dev.mysql.com/downloads/file.php?id=453799. From the directory you downloaded it to, do:

tar xvf mysql-workbench-community-6.2.3-src.tar.gz
cd mysql-workbench-community-6.2.3-src
wget -O patch-glib.diff http://bugs.mysql.com/file.php?id=21874&bug_id=74147
patch -p0 < patch-glib.diff
sudo apt-get build-dep mysql-workbench
sudo apt-get install libgdal-dev
cd build
cmake .. -DBUILD_CONFIG=mysql_release
make
sudo make install

Gabriele Tozzi (gabriele-tozzi) wrote :

This bug also has been reported and fixed on Debian, see:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=763356

Installing packages mysql-workbench_6.2.3+dfsg-6 and mysql-workbench-data_6.2.3+dfsg-6 from Debian Jessie solved the issue for me.

Ubuntu package needs to be updated.

Oliver Marks (oly) wrote :

hit the same issues, thanks for taking the time to write the build instructions rockorequin :)

Luc Bruninx (luc2005) wrote :

I'm sorry, but the patch proposed by Rocko (rockorequin) don't work for me.

Luc Bruninx (luc2005) wrote :

The Gabriele Tozzi solution work for me. Download the 2 deb files from the Debian repository and use dpkg to install it (after removing the Ubuntu packages).

Michael Petch (mpetch) wrote :

This bug manifests itself in a number of different ways. All seem to be related to no data being populated in what should be the ListModel panes. Another way to observe this issue is to run mysql-workbench and open the sakila_full model. Once open double click on one of the tables in the diagram. At the bottom in the middle is a pane that should have a "column" tab. Click on that tab and should see that it is blank. Normally that pane would have a list of all the fields and their attributes and allow you to add/modify/delete any of the columns.

This bug is a regression caused by changes in GLIB >= 2.42.2. It is rather severe in that it affects many aspects of the workbench from querying databases to editing the EER disagrams.

This bug has been identified previously in Debian here:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=763356

The issue is a glib regression with glib >= 2.42.0 . Oracle provided a patch (referenced in this bug report) here:

http://bugs.mysql.com/file.php?id=21874&bug_id=74147

The upstream bug associated with that patch can be found here:

http://bugs.mysql.com/bug.php?id=74147

This bug has been fixed in Vivd Vervet (15.04) as can be found here:

https://launchpad.net/ubuntu/+source/mysql-workbench/6.2.3+dfsg-6

I am attaching a debdiff patch that seems to work well to resolve this issue on Ubuntu Utopic Unicorn (14.10) and is the same patch (libglib2.42.patch) applied to mysql-workbench (6.2.3+dfsg-6) in Vivid Vervet (15.04)

Sebastien Bacher (seb128) wrote :
Changed in mysql-workbench (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

uploaded as a SRU to utopic as well

description: updated
Changed in mysql-workbench (Debian):
status: Unknown → Fix Released
d❤vid (kwill) wrote :

Issue reopened upstream (I assume based on installation from the MySQL deb):

http://bugs.mysql.com/bug.php?id=74147

> [20 Nov 21:14] Ricardo Almeida
> I have just installed MySQL Workbench 6.2.4 release on Ubuntu 14.10
> The issue remains the same. Very disappointing

...

> [21 Nov 21:13] Philip Olson
> Confirmed and reopened.

d❤vid (kwill) wrote :

How can I track SRU status (for Utopic)? Is subscribing to this issue sufficient?

Hello Sylvain, or anyone else affected,

Accepted mysql-workbench into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mysql-workbench/6.1.7+dfsg-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in mysql-workbench (Ubuntu Utopic):
status: New → Fix Committed

This version (6.1.7+dfsg-1ubuntu1) of the package solves the bug for me. Thanks!

tags: added: verification-done
removed: verification-needed
Rocko (rockorequin) wrote :

Thanks, version 6.1.7+dfsg-1ubuntu1 fixes it for me, too.

Out of interest, why are we still on 6.1.7 when upstream is at 6.2.4?

d❤vid (kwill) wrote :

Confirmed for me too (results appear, other basic functions continue working as expected). Thanks! :)

@Rocko afaik once an Ubuntu release is made, packages are not updated, but critical bugfixes (like this one) are backported - you can expect the new version to be included in Ubuntu 15.04

Michael Petch (mpetch) wrote :

Version 6.1.7+dfsg-1ubuntu1on Utopic works for me as well.

Bart Verwilst (verwilst) wrote :

Confirmed to fix this bug for me as well.

Oleg Kalnichevski (olegk) wrote :

Confirming the patch has fixed the issue for me.

coombesy (webeire) wrote :

confirmed fix - Ubuntu 14.10 Mate amd64

after `apt-get remove --purge mysql-workbench*` I installed the following, in this order..

https://launchpad.net/ubuntu/utopic/amd64/mysql-workbench-data/6.1.7+dfsg-1ubuntu1
https://launchpad.net/ubuntu/+source/mysql-workbench/6.1.7+dfsg-1ubuntu1

Fernando Fernandez (ferdez) wrote :

Hey Nuno C, maybe you should try to help instead of complain for "bad" service you most probably didn't pay for. ;-)

Nuno (nunoc-gtt) wrote :

Hey Fernando F, you can bet I dont pay for broken software that isn't fixed by it's devs.

Nuno, please just keep your hate for yourself.

Nuno (nunoc-gtt) wrote :

Its not hate, it's a fact.

Michael Petch (mpetch) wrote :

@Nuno, the binaries are already made. They are available in the utopic-proposed repository. Utopic-proposed is were the code goes to be tested before it is added to the official Utopic release repository.

To learn how to enable the -proposed repository using the GUI or the CLI you can use these instructions:

https://wiki.ubuntu.com/Testing/EnableProposed

Fernando Fernandez (ferdez) wrote :

Tested package from utopic-proposed and confirmed bug is solved.

Thanks.

Nuno (nunoc-gtt) wrote :

Good morning

Yeah I've already done the utopic update but the behavior (no grid on SELECT) stayed equal. This was earlier last week but i tried check for new update now and nothing new is showing for SQLWB.

d❤vid (kwill) wrote :

@Nuno - By "utopic update" do you mean a normal system update, or enabling "utopic-proposed"?

It sounds like you did the former, but if you want the fix **right now**, you need to do the latter. Instructions for this are at https://wiki.ubuntu.com/Testing/EnableProposed ... if they are unclear, you might get help here or at https://askubuntu.com (and maybe someone can improve the instructions?)

Once a number of people have tested on "utopic-proposed" and found that it works, the fix will appear in a normal system update. But, you have to wait for the testing process to be completed before this happens. (No-one wants a bug fix that doesn't work or introduces another bug.)

While bugs are frustrating, I hope you can see why the wait is neccessary and that no-one here is demanding anything of you. My guess is that most of the people commenting on this thread are users like you and I, and the rest are developers and maintainers who are also keen to get the bug fixed. We are all in this together.

Michael Petch (mpetch) wrote :

@Nuno . At a command line what does this command output:

dpkg-query -W -f='${Package} ${Version}\n' 'mysql-workbench*'

Nuno (nunoc-gtt) wrote :

Hi, by doing the command above
dpkg-query -W -f='${Package} ${Version}\n' 'mysql-workbench*'

This is what i get:

mysql-workbench
mysql-workbench-community 6.2.4-1ubu1404
mysql-workbench-data 6.1.7+dfsg-1ubuntu1
mysql-workbench-gpl
mysql-workbench-oss

Also note I am in Xubuntu 14.10.
I am here to help because SQLWB is a great tool for me as a developer, but as a user I feel unsupported as this is a simple fix (rollback some library) and as such should be trivial to release a new build for this instead of me (as user) having to fiddle with utopic upgrades and synaptic and command lines. Maybe a preferences option to check inside SQLWB for untested releases?

Nuno (nunoc-gtt) wrote :

kwill,

I have no problem whatsoever with testing software, by the way i recommend it by the dozen.
The problem is there was not enough testing because obviosly nobody checked to see if SQLWB ran in 14.10. Ok, it happens, it was identified and a fix was provided for 6.2.4 which obviously wasn't tested enough, resulting in the bug being there after the fix.
Guess what? I had 6.2.3 and never warned me of new version, even when I deliberately checked for new versions. I discovered 6.2.4 was launched because went to the website looking for the release date. So, updates are also not working right.
I came to this forum and a fix was provided via the utopic prerelease and guess what? Didnt do jack to fix it.

I work as a developer for a living, and you can be sure that the products I put out there for my paying customers DO HAVE bugs, but I try to ease their pain with the software by not introducing new roadblocks. I would never ever suggest that they download my source code and build tools and compile the fix themselves. Thats my job.

I use and love SQLWB to do my work and right now I'm unable to use it because of this bug, and every effort to fix it was unsucessful, and that's why I vented before.

Dima (dimamytiansky) on 2014-12-03
Changed in mysql-workbench (Ubuntu Utopic):
status: Fix Committed → Fix Released
Changed in mysql-workbench (Ubuntu Utopic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-workbench - 6.1.7+dfsg-1ubuntu1

---------------
mysql-workbench (6.1.7+dfsg-1ubuntu1) utopic; urgency=high

  * New "libglib2.42.patch" with adaptations for compatibility with
    libglib_2.42 (LP: #1376154).
    Thanks, Marcin Szalowicz.
 -- Michael Petch <email address hidden> Sun, 16 Nov 2014 20:55:43 -0700

Changed in mysql-workbench (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mysql-workbench has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

angus73 (angus73) wrote :

Sorry, I am still stuck with this bug in Utopic, even if I have the "utopic-updates" checked in the software source. What am I missing?

Peter Reid (peter-reid) wrote :

As noted by angus73 this bug is still affecting me with the latest version from the 14.04 repositories

Michael Petch (mpetch) wrote :

Peter and Angus you will need to open a new bug and tag it as regression-update. Brian Murray said this in his last post "In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions."

With that being said have you confirmed the latest mysql-workbench is installed? What does the output from this command (open a terminal window) say:

dpkg-query -l mysql-workbench-data mysql-workbench | grep mysql

angus73 (angus73) wrote :

Sorry, my mistake. I was not sure that it was a regression, and indeed I realized (before reading the last post from Michael) that I had this version installed:

mysql-workbench-community 6.1.7-1ubu1204

Uninstalling it and installing "mysql-workbench" package fixed the problem.

So, if I understand correctly, I don't suffer from a regression. Maybe Peter does, but I would suggest him to double check his WB version before filing a new bug. Does it make sense?

Peter Reid (peter-reid) wrote :

Sorry for delayed response but the output of the command was:

ii mysql-workbench 6.0.8+dfsg-2 amd64 MySQL Workbench - a visual database modeling, administration and queuing tool
ii mysql-workbench-data 6.0.8+dfsg-2 all MySQL Workbench -- architecture independent data

Unsure as to whether I am affected by the regression

Michael Petch (mpetch) wrote :

I originally did testing with Ubuntu 14.04 and this wasn't an issue as the version of Glib in Ubunty 14.04 predated the change that created this situation. Your output shows that you are using the latest official Ubuntu 14.04 mysql-workbench. This has me curious if somehow your version of Glib has been upgraded through a non-official source? Could you provide me the output from this command:

dpkg-query -l libglib2.0-0 | grep glib

Peter Reid (peter-reid) wrote :

I'm running on Elementary OS Freya Beta 2, so that may explain a different Glib version if that is the case.

Output of command:

ii libglib2.0-0:amd64 2.42.2-0ubuntu1~14.04~ricotz0 amd64 GLib library of C routines
ii libglib2.0-0:i386 2.42.2-0ubuntu1~14.04~ricotz0 i386 GLib library of C routines

Michael Petch (mpetch) wrote :

Yep that is exactly what is going on 2.42.2-0ubuntu1~14.04~ricotz0 is a much newer version of Glib that causes this problem with mysql-workbench (the problem was introduced as of 2.42). You are going to need to acquire a newer version of mysql-workbench to get around the problem or somehow downgrade Glib.

Fery Wardiyanto (feryardiant) wrote :

Hi ~mpetch,

I'm using mysql-workbench-community 6.3.4 (which is the current latest available) running on Freya, i got it from official apt repo of mysql and still facing this problem. Are you habe another solution?

* apologize to everyone, I think it's wrong place to just ask.

any solution would be apreciated.
Thank you :)

Hi ~feryardiant,

Could yoy fix that problem? I'm also facing this issue in Freya. Anyone could fix that?

Thnaks!

Gocht Guerrero (agocht) wrote :

Hi ~Maximiliano García,

Have you found any fix for this? I am just having this issue in freya, just like you.

I had to recompile the application. The packagers don't seem to care that
it works or not.
Le 22 déc. 2015 15:20, "Gocht Guerrero" <email address hidden> a écrit :

> Hi ~Maximiliano García,
>
> Have you found any fix for this? I am just having this issue in freya,
> just like you.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1365383).
> https://bugs.launchpad.net/bugs/1376154
>
> Title:
> data grid not displaying resultset is blank
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/mysql-workbench/+bug/1376154/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.