Ubuntu

EOL upstream, should be dropped from precise

Reported by Clint Byrum on 2011-11-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-gui-tools (Debian)
Fix Released
Unknown
mysql-gui-tools (Ubuntu)
High
Unassigned

Bug Description

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=584987
http://dev.mysql.com/downloads/gui-tools/5.0.html

This project is no longer supported upstream, and does not link correctly against mysql 5.5 client libraries:

x86_64-linux-gnu-g++ -DHAVE_CONFIG_H -I. -pthread -I/usr/include/gtk-2.0 -I/usr/include/libxml2 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gtk-unix-print-2.0 -I/usr/include/libglade-2.0 -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/giomm-2.4 -I/usr/lib/giomm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib/pangomm-1.4/include -I/usr/include/gdkmm-2.4 -I/usr/lib/gdkmm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/cairomm-1.0 -I/usr/lib/cairomm-1.0/include -I/usr/include/mysql -DBIG_JOINS=1 -fno-strict-aliasing -g -I../../../common/source/linux -I../../../common/library/base-library/include -I../../../common/library/utilities/shared_include -I../../../common/library/utilities/include -I../../library/include -DPREFIX=\"""\" -DDATADIRNAME=\""/usr/share"\" -DCOMMONDIRNAME=\""common"\" -DDOCDIR=\"""\" -D_FORTIFY_SOURCE=2 -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -c -o MACatalogsPanel.o MACatalogsPanel.cc
MACatalogsPanel.cc: In member function 'void MACatalogsPanel::maint_next_page()':
MACatalogsPanel.cc:1520:7: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
MACatalogsPanel.cc:1520:7: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
MACatalogsPanel.cc:1520:7: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
MACatalogsPanel.cc:1520:7: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
MACatalogsPanel.cc:1520:7: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
MACatalogsPanel.cc:1558:7: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
MACatalogsPanel.cc:1558:7: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
MACatalogsPanel.cc:1558:7: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
x86_64-linux-gnu-g++ -DHAVE_CONFIG_H -I. -pthread -I/usr/include/gtk-2.0 -I/usr/include/libxml2 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gtk-unix-print-2.0 -I/usr/include/libglade-2.0 -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/giomm-2.4 -I/usr/lib/giomm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/lib/pangomm-1.4/include -I/usr/include/gdkmm-2.4 -I/usr/lib/gdkmm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/cairomm-1.0 -I/usr/lib/cairomm-1.0/include -I/usr/include/mysql -DBIG_JOINS=1 -fno-strict-aliasing -g -I../../../common/source/linux -I../../../common/library/base-library/include -I../../../common/library/utilities/shared_include -I../../../common/library/utilities/include -I../../library/include -DPREFIX=\"""\" -DDATADIRNAME=\""/usr/share"\" -DCOMMONDIRNAME=\""common"\" -DDOCDIR=\"""\" -D_FORTIFY_SOURCE=2 -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -c -o MADummyPanel.o MADummyPanel.cc
x86_64-linux-gnu-g++ -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Wl,-Bsymbolic-functions -Wl,-z,relro -o mysql-administrator-bin MGUserBrowserList.o MInstanceInfo.o MDataInterface.o MDynamicInterface.o MAdministrator.o MAPanel.o MAPreferences.o MAPreferencesEditor.o util.o main.o MAServerInformationPanel.o MAServiceControlPanel.o MAUserAdministrationPanel.o MAStartupParametersPanel.o MAServerConnectionsPanel.o MAHealthPanel.o MAServerLogsPanel.o MABackupPanel.o MARestorePanel.o MAReplicationStatusPanel.o MACatalogsPanel.o MADummyPanel.o ../../library/source/libadmin.a ../../../common/source/linux/libmacommongui.a ../../../common/library/base-library/source/.libs/libmysqlx.a ../../../common/library/sql-parser/source/.libs/libsqlparser.a ../../../common/library/utilities/source/.libs/libguiutil.a -L/usr/lib/x86_64-linux-gnu -lmysqlclient_r -lpthread -lz -lm -lrt -ldl -pthread -lglade-2.0 -lxml2 -lgtkmm-2.4 -latkmm-1.6 -lgdkmm-2.4 -lgiomm-2.4 -lpangomm-1.4 -lgtk-x11-2.0 -lglibmm-2.4 -lcairomm-1.0 -lsigc-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lutil -L/usr/lib/x86_64-linux-gnu -lpcre
../../library/source/libadmin.a(myx_backup.o): In function `write_row_to_file':
/build/buildd/mysql-gui-tools-5.0r14+openSUSE/administrator/library/source/myx_backup.c:3215: undefined reference to `IS_NUM_FIELD'
collect2: ld returned 1 exit status

Changed in mysql-gui-tools (Ubuntu):
importance: Undecided → High
tags: added: ftbfs precise
Colin Watson (cjwatson) wrote :

2011-11-28 14:40:42 INFO Creating lockfile: /var/lock/launchpad-lp-remove-package.lock
2011-11-28 14:40:51 INFO Removing candidates:
2011-11-28 14:40:51 INFO mysql-gui-tools 5.0r14+openSUSE-2.2ubuntu3 in precise
2011-11-28 14:40:51 INFO Removed-by: Colin Watson
2011-11-28 14:40:51 INFO Comment: requested by clint-fewbar; EOL upstream; fails to link against MySQL 5.5; LP: #896463
2011-11-28 14:40:51 INFO 1 package successfully removed.
Confirm this transaction? [yes, no] yes
2011-11-28 14:40:56 INFO Transaction committed.
2011-11-28 14:40:56 INFO The archive will be updated in the next publishing cycle.

Changed in mysql-gui-tools (Ubuntu):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

Also blacklisted from future syncs.

Changed in mysql-gui-tools (Debian):
status: Unknown → New
Colin Watson (cjwatson) wrote :

Unsubscribed ubuntu-archive, as there's no action for us to take regarding the remaining Debian bug task.

Changed in mysql-gui-tools (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.