mysql_install_db run without --user in postinst

Bug #591875 reported by Klas Lindfors on 2010-06-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.1 (Ubuntu)
Low
Unassigned

Bug Description

release: 9.10
version: 5.1.37-1ubuntu5.4

When doing an upgrade of a mysql-server with binlogs enabled running mysql_install_db without --user=mysql will result in new binlogs created with root as owner thus resulting in failed upgrade and mysqld not starting.

So adding --user=mysql to mysql_install_db in mysql-server postinst should probably be harmless and fix this problem.

Related branches

Mathias Gug (mathiaz) wrote :

Could you outline from which release you tried to upgrade from? And which release to tried to upgrade to?

Changed in mysql-dfsg-5.1 (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
status: New → Incomplete
Klas Lindfors (klali) wrote :

upgrading from 5.1.37-1ubuntu5.1 to 5.1.37-1ubuntu5.4

I believe the bug exists in all versions of the package, but only showing itself when mysql_install_db on an already existing database creates new files (as in my case, with bin-log enabled).

Launchpad Janitor (janitor) wrote :

[Expired for mysql-dfsg-5.1 (Ubuntu) because there has been no activity for 60 days.]

Changed in mysql-dfsg-5.1 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers