[lucid] LOAD DATA INFILE fails in replication, simple patch available in 5.1.43

Bug #576949 reported by Mrten on 2010-05-07
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.1 (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Clint Byrum

Bug Description

LOAD DATA INFILE fails in replication when there are keywords or braces in columnnames. This is a known bug in mysql: http://bugs.mysql.com/bug.php?id=49479, which is fixed in 5.1.43. However, Lucid LTS has 5.1.41.

Would it be possible to include the (very simple) patch mentioned in the mysql bugreport (it's the same as the one committed to mysql, check out the commit here: http://lists.mysql.com/commits/92988) in the package for Lucid?

Stable Release Update Report

IMPACT

This bug's impact should be minimal, as the patch is very small and only affects replication slaves in a positive way by quoting strings properly. This would affect any user who has a schema with columns that conflict with SQL keywords.

DEVELOPMENT FIX

This was fixed in the upstream version contained in the current development release (Maverick)

TEST CASE

1. create a replication master/slave setup
2. create a table with a column name of "SELECT"
3. LOAD DATA INFILE into this table on the master
4. slave will fail while attempting to apply this statement.

REGRESSION POTENTIAL

Given the minimal nature of the patch, regressions are quite unlikely. Built and passed tests on lucid with normal regression test suite.

Here is the PPA build log:
https://launchpad.net/~clint-fewbar/+archive/fixes/+build/1945729

Related branches

Mrten (bugzilla-ii) on 2010-05-07
summary: - LOAD DATA INFILE fails in replication, simple patch in 5.1.43
+ [lucid] LOAD DATA INFILE fails in replication, simple patch available in
+ 5.1.43
Mrten (bugzilla-ii) wrote :
Chuck Short (zulcss) wrote :

Can you add the url from where the mysql bug tracker?

Thanks
chuck

Changed in mysql-dfsg-5.1 (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
tags: added: patch
Chuck Short (zulcss) on 2010-05-25
Changed in mysql-dfsg-5.1 (Ubuntu):
status: Incomplete → In Progress
Chuck Short (zulcss) wrote :

Can you try the version in my ppa:

https://edge.launchpad.net/~zulcss/+archive/server-bug-fixes

thanks
chuck

Mrten (bugzilla-ii) wrote :

Seems to work, thanks!

root@miho:/home/mrten# apt-cache policy mysql-server
mysql-server:
  Installed: 5.1.41-3ubuntu12.2
  Candidate: 5.1.41-3ubuntu12.2
  Version table:
 *** 5.1.41-3ubuntu12.2 0
        500 http://ppa.launchpad.net/zulcss/server-bug-fixes/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Mrten (bugzilla-ii) wrote :

Chuck, any ideas on the timeline for the inclusion of the fix for this bug? There has been a security upgrade since you made the fix available in your ppa, so we're kinda stuck between a rock and a hard place...

Thanks!

Mrten (bugzilla-ii) wrote :

This bug blocks the upgrade of our server farm to Lucid since we're importing databases on a daily basis. Is there a place that I can track progress of this 6-line patch? What is the usual path?

Or can I please please please get an update? If this takes four months, then I'll look for a workaround, but if this could be fixed next week (say), I'll keep restarting the replication manually...

Chuck Short (zulcss) wrote :

This is fixed in maverick. Ill try to get this fixed in lucid. Can you supply a testcase for me?

chuck

Changed in mysql-dfsg-5.1 (Ubuntu):
status: In Progress → Fix Released
Changed in mysql-dfsg-5.1 (Ubuntu Lucid):
status: New → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
description: updated
Changed in mysql-dfsg-5.1 (Ubuntu Lucid):
assignee: Clint Byrum (clint-fewbar) → nobody
status: In Progress → Confirmed
Clint Byrum (clint-fewbar) wrote :

Subscribing ubuntu-sru for the lucid SRU, which I forgot to do back in September.

Changed in mysql-dfsg-5.1 (Ubuntu Lucid):
assignee: nobody → Clint Byrum (clint-fewbar)
Martin Pitt (pitti) wrote :

Please note that as per the SRU policy things go much quicker if you just get them uploaded, so that they are ready for review/accepting. This looks fine, please upload.

Kees Cook (kees) wrote :

This looks good; I'll upload it to -proposed now. Thanks!

Kees Cook (kees) wrote :

This has been uploaded to -proposed. Once it has built, please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Thank you in advance!

Changed in mysql-dfsg-5.1 (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed

Accepted mysql-dfsg-5.1 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Mrten (bugzilla-ii) wrote :

Installed yesterday, tested today and works as it should.

tags: added: verified
removed: verification-needed
tags: added: verification-done
removed: verified
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-dfsg-5.1 - 5.1.41-3ubuntu12.10

---------------
mysql-dfsg-5.1 (5.1.41-3ubuntu12.10) lucid-proposed; urgency=low

  * debian/patches/63_cherrypick-upstream-49479.dpatch: fixes LOAD DATA
    INFILE when used in replication. (LP: #576949)
 -- Clint Byrum <email address hidden> Mon, 22 Nov 2010 06:14:16 -0800

Changed in mysql-dfsg-5.1 (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.