mysqld does not start reliably...

Bug #566736 reported by Fons Rademakers on 2010-04-19
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.1 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: upstart

Hi,

 running the as of today up-to-date version of 10.04 beta2 server

Description: Ubuntu lucid (development branch)
Release: 10.04

I see that fairly regularly, mysqld does not start at reboot. Typing "start mysqld" hangs (no output). The server is bound to the server's IP address and not localhost.

To get it to run I've to do:

su
mysqld
kill -9 <mysqld-pid>
start mysql
start: Job is already running: mysql
stop mysql
mysql stop/waiting
start mysql
mysql start/running, process 3016

Cheers, Fons.

affects: upstart (Ubuntu) → mysql-dfsg-5.1 (Ubuntu)
Mathias Gug (mathiaz) wrote :

Looking at the mysqld upstart job (/etc/init/mysqld.conf) you can see that it "start on (net-device-up". Since mysqld is configured to bind to a specific address it fails to start if the network interface isn't up yet.

I'd suggest to update mysqld upstart job to "start on (net-device-up IFACE=ethX" to start mysqld only when the correct interface is up.

Changed in mysql-dfsg-5.1 (Ubuntu):
status: New → Won't Fix
importance: Undecided → Low

I would love your suggestions for me I modified the /etc/init/networking.conf into:
# networking - configure virtual network devices
#
# This task causes virtual network devices that do not have an associated
# kernel object to be started on boot.

description "configure virtual network devices"

start on (local-filesystems
   and stopped udevtrigger)

task

pre-start exec mkdir -p /var/run/network

exec ifup -a
#modification starts here
post-start script
 initctl emit -n net-device-up
end script
#modification ends here

I'm on a virtual server (proxmox) which is running several Virtual ubuntu 10.04 server that's maybe one the net-device-up was never triggered?

Rolf Leggewie (r0lf) wrote :

unless I misunderstand comment 1, there is still work left to be done and the ticket should not be set to wontfix

Changed in mysql-dfsg-5.1 (Ubuntu):
status: Won't Fix → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers