Try to install mysql-server and get hundreds of blocking 'logger: [-x] [-p log_facility] [-t tag] message' messages.

Bug #516437 reported by ikpetroff on 2010-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.1 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: mysql-server

Release: Ubuntu 8.04 (Hardy)
Package: mysql-server, 5.0.51a-3ubuntu5.4
Expected: usual installation process

Command run: sudo apt-get install mysql-server

What happened instead:
  The installation hangs and hundreds of identical messages appear on the terminal:
  'logger: [-x] [-p log_facility] [-t tag] message'
  Without the command 'killall logger' that must be run quickly and several times, the system finally hangs (drawn by all these new logger processes) and the only solution is a manual reboot or reset.

My OS is up to date.

ProblemType: Package
Architecture: i386
Date: Wed Feb 3 09:12:39 2010
DistroRelease: Ubuntu 8.04
ErrorMessage: subprocess post-installation script returned error exit status 143
Package: mysql-server-5.0 5.0.51a-3ubuntu5.4
PackageArchitecture: i386
SourcePackage: mysql-dfsg-5.0
Title: package mysql-server-5.0 5.0.51a-3ubuntu5.4 failed to install/upgrade: subprocess post-installation script returned error exit status 143
Uname: Linux 2.6.24-26-generic i686

ikpetroff (ivan-petroff-cse) wrote :
ikpetroff (ivan-petroff-cse) wrote :

I finally found waht the problem is:

the script '/usr/bin/logger'. In a brand new Ubuntu 8.04 installation this is actually an ELF executable. But on my old Ubuntu 8.04 (but regularly updated) OS is was a shell script.

I simply inserted on the first line the command 'exit' to avoid the script to run its bugs. It solved the problem.

Finally I copied the executable from another and fresher Ubuntu 8.04 installation.

Yet I don't know why '/usr/bin/logger' hadn't been updated correctly...

On Wed, Feb 03, 2010 at 01:32:58PM -0000, ikpetroff wrote:
> I finally found waht the problem is:
>
> the script '/usr/bin/logger'. In a brand new Ubuntu 8.04 installation
> this is actually an ELF executable. But on my old Ubuntu 8.04 (but
> regularly updated) OS is was a shell script.
>

Are you sure /usr/bin/logger has never been locally modified? As far as I can
tell /usr/bin/logger has always been an ELF executable.

  status incomplete
  importance low

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Changed in mysql-dfsg-5.1 (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
ikpetroff (ivan-petroff-cse) wrote :

If /usr/bin/logger has always been an ELF executable I guess my version had been locally modified as you presume.
Unfortunately I don't know how and why it was modified.
What's sure is that my Ubuntu 8.04 has packages from other unofficial sources.

Mathias Gug (mathiaz) wrote :

Marking Invalid since the logger had been modified locally.

Changed in mysql-dfsg-5.1 (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers