some keys print characters instead of performing their actions: ex: delete key generates ~

Bug #451801 reported by Cameron Braid on 2009-10-15
82
This bug affects 14 people
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.1 (Debian)
Fix Released
Unknown
mysql-dfsg-5.1 (Ubuntu)
Wishlist
Unassigned

Bug Description

Pressing certain keys print characters to the console instead of executing their usual action.

Examples :

DEL prints "~"
CTRL-LEFT prints ";5D"
CTRL-RIGHT prints ";5C"

UP, DOWN, HOME and END work as expected

ProblemType: Bug
Architecture: amd64
Date: Thu Oct 15 11:02:39 2009
DistroRelease: Ubuntu 9.10
MySQLConf.etc.mysql.conf.d.cameron.cnf:
 [mysqld]
 datadir = /media/ssd/mysql
 default-table-type=innodb
 innodb_file_per_table
MySQLConf.etc.mysql.conf.d.mysqld.safe.syslog.cnf:
 [mysqld_safe]
 syslog
MySQLVarLibDirListing: []
NonfreeKernelModules: nvidia
Package: mysql-client-5.1 5.1.37-1ubuntu5
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: mysql-dfsg-5.1
Uname: Linux 2.6.31-14-generic x86_64
mtime.conffile..etc.apparmor.d.usr.sbin.mysqld: 2009-10-08T20:54:01.337428

Cameron Braid (cameron-braid) wrote :

On Thu, Oct 15, 2009 at 01:08:41AM -0000, Cameron Braid wrote:
> Public bug reported:
>
> Pressing certain keys print characters to the console instead of
> executing their usual action.
>

By console, do you mean the mysql client?

 status incomplete
 importance low

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Changed in mysql-dfsg-5.1 (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

Yes, in the mysql client.

This also prevents CTRL-R for using reverse search over command history.

On Fri, Oct 16, 2009 at 03:10:54AM -0000, Cameron Braid wrote:
> Yes, in the mysql client.
>
> This also prevents CTRL-R for using reverse search over command history.
>

This may be related to the readline library that used to provide the
interactive shell features.

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Well, whatever it is, it makes using mysql really difficult, since I make heavy use of CTRL-R, DEL and CTRL-LEFT/RIGHT

This seems to me like a more important issue than 'Low' importance.

Is there any easy way for me to test mysql client with an older version (say from jaunty) of the readline library ?

Would this mean patching and building from source ?

Cam

Chuck Short (zulcss) on 2009-10-27
Changed in mysql-dfsg-5.1 (Ubuntu):
importance: Low → Wishlist
status: Incomplete → Confirmed
Cameron Braid (cameron-braid) wrote :

Does importance=Wishlist mean I have to wait till the next ubuntu release for this to be fixed ?

Chris DiMartino (vwchris) wrote :

Is there a workaround for this behavior? I am having the exact same issue using the bundled mysql client:

chris@zaphod:~$ mysql --version
mysql Ver 14.14 Distrib 5.1.37, for debian-linux-gnu (x86_64) using EditLine wrapper

CTRL-<left arrow> produces ;5D
CTRL-<right arrow> produces ;5C
DEL produces ~
CTRL-R is non functional

Losing these integral shell features makes the application mostly unusable to me. I am going to need to pull a copy of mysql source and compile my own client to have it usable again. This seems to me to elevate this above "wishlist" importance. Is there a configuration file that can be used (ala .inputrc) to map these key combinations back to their appropriate configuration?

Mathias Gug (mathiaz) on 2009-11-03
summary: - some keys print characters instead of performing their actions
+ some keys print characters instead of performing their actions: ex:
+ delete key generates ~

+1 for changing Wishlist to Bug, as this is a regression.
I remember having the exact issue several years ago in slackware with mysql installed by hand, but ubuntu never had this problem.
Maybe low priority for granpa's using ubuntu for web browsing, but very high priority for programmers using mysql in ubuntu.

Changed in mysql-dfsg-5.1 (Debian):
status: Unknown → New
Changed in mysql-dfsg-5.1 (Debian):
status: New → Fix Released
wdoekes (walter+ubuntu) wrote :

For those too impatient to wait for the updates to trickle down to the main repository (like myself), I've created an unofficial mysql-client package dynamically linked against libreadline6:
http://wjd.nu/files/2009/12/mysql-client-5.1_5.1.37-1ubuntu5wjd2_amd64.deb

(See more info here http://wjd.nu/notes/2009#mysql-ubuntu-readline-delete-char-karmic )

Mind you, I'm a beginner when it comes to .deb packaging, so don't blame me when your mysql-client doesn't update when the official updates do come in.

Rory McCann (rorymcc) wrote :

I have this problem, this is because mysql isn't compiled with readline (or linked or something). Ergo it also can't do the nice stuff.

I'm also in favour oif marking this as bug, since it feels like a regression. The mysql command line programme has lost functionality.

@wdoekes You could try creating a PPA (Personal Package Archive)? This will compile the source package, and most importantly, compile it for other architectures. I can't use your deb since it's for amd64

Chuck Short (zulcss) wrote :

This has been fixed for lucid. Thanks for the bug report.

Regards
chuck

Changed in mysql-dfsg-5.1 (Ubuntu):
status: Confirmed → Fix Released
andbelo (andbelo) wrote :

I have the mysql-client version 5.1.37-1ubuntu5 running in Karmic and the problem persists. Is there any chances the fix for Lucid can be applied to Karmic?
Thanks

Ivo Jimenez (ivotron) wrote :

+1 for a backport to karmic

For people that have readline in their DNA, it is really annoying to use mysql-client with editline (less with rlwrap, but still)

Sebastien Dejean (sdejean) wrote :

> Chuck Short wrote on 2010-01-21: #11
> This has been fixed for lucid. Thanks for the bug report.
>
> Regards
> chuck
>
> Changed in mysql-dfsg-5.1 (Ubuntu):
> status: Confirmed → Fix Released

> Ivo Jimenez wrote on 2010-01-29: #13
> +1 for a backport to karmic
>
> For people that have readline in their DNA, it is really annoying to use mysql-client with editline (less with rlwrap, but still)

+1 for a backport to karmic

I really don't like to be the guy who adds the +1 when you already know the issue but I have to agree that this fix really needs to be put into Karmic. As a MySQL DBA who uses Ubuntu on a daily basis, relying on readline support has been part of my routine using MySQL for years.

Austriaco (lanieves) wrote :

For those of you Karmic users who, as I, cannot live without readline and don't want to wait until somebody backports the package to Karmic: What I did was to uninstall mysql-server and mysql-client and install mysql-client-5.0 mysql-server-5.0. The server will fail to downgrade, even after mysql-server-5.1 has been removed, so one has to remove /var/lib/mysql/debian-5.1.flag and run apt-get -f install to finish installation (or better, now that you know and don't have to find out for yourselves, remove the debian-5.1.flag file after removing mysql-server-5.1 and before installing mysql-server-5-0).

Now I have readline and my vi-style editing-mode again.

+1 Fix in Karmic

Sebastien Dejean (sdejean) wrote :

For those of you who either have no plans for a Lucid upgrade or you cannot wait, I have been using the MariaDB/OurDelta binaries from their PPA (read http://ourdelta.org/ubuntu for more info). I have been using it for 2 months now, without issue. It is a viable alternative for those of you who were using the Ubuntu MySQL package for development and not production deployments.

Raphaël Gertz (rapsys) wrote :

Seriously it's realy incredible the poor quality of ubuntu...

It become to be clear that you don't care about your user at all and have no real developper on the distribution !

Even mandriva do better work than you, you are more interested in making money with proprietary launchpad than keep the package working...

What would have cost a backport as update ?

Seriouly canonical sucks, i hope your fail soon !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.