Package mysql-server-5.1 failed to install: tried to ovewrite `/usr/sbin/mysqld', witch is already in package mysql-server-core-5.0

Bug #321185 reported by Roope Kuisma on 2009-01-25
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.1 (Ubuntu)
Undecided
Unassigned

Bug Description

Package mysql-server-5.1 failed to install: tried to ovewrite `/usr/sbin/mysqld', witch is already in package mysql-server-core-5.0

Ubuntu release: Jaunty 9.04 alpha 3

ProblemType: Package
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
ErrorMessage: yritetty ylikirjoittaa `/usr/sbin/mysqld', joka on myös paketissa mysql-server-core-5.0
Package: mysql-server-5.1 None [modified: /var/lib/dpkg/info/mysql-server-5.1.list]
SourcePackage: mysql-dfsg-5.1
Title: package mysql-server-5.1 None [modified: /var/lib/dpkg/info/mysql-server-5.1.list] failed to install/upgrade: yritetty ylikirjoittaa `/usr/sbin/mysqld', joka on myös paketissa mysql-server-core-5.0
Uname: Linux 2.6.28-5-generic i686

Roope Kuisma (meizirkki) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-dfsg-5.1 - 5.1.30-2ubuntu4

---------------
mysql-dfsg-5.1 (5.1.30-2ubuntu4) jaunty; urgency=low

  [ Jonathan Riddell ]
  * Move data files to /usr/share/mysql-5.1 with
    --datadir=/usr/share/mysql-5.1 to make them co-installable with mysql 5.0
  * Update debian/rules for the above change
  * Split out /usr/share/mysql-5.1 into new mysql-server-data-5.1 package.
    These files are needed for embedded use of mysql (e.g. by Amarok).
  * Make mysql-server-5.1 conflict on mysql-server-core-5.0 (LP: #321185)

  [ Harald Sitter ]
  * Update all remaining references of usr/share/mysql/
  * Conflicts for the Kubuntu Intrepid deployment (subject for upgrade testing):
    + libmysqlclient16 replaces & conflicts amarok-libmysqlclient16
    + libmysqlclient16.dev replaces & conflicts amarok-libmysqlclient-dev
    + mysql-data-5.1 replaces & conflicts amarok-mysql-data
  * Link /usr/share/mysql-5.1/aclocal/mysql.m4 to /usr/share/aclocal/

 -- Harald Sitter <email address hidden> Tue, 20 Jan 2009 15:43:46 +0100

Changed in mysql-dfsg-5.1:
status: New → Fix Released
Msegeya (msegeya) wrote :

i'm having similar problem as above!!! i need help please....

oli z (oliver-z) wrote :

same problem here... its not fixed:

Wähle vormals abgewähltes Paket mysql-server-core-5.1.
Entpacke mysql-server-core-5.1 (aus .../mysql-server-core-5.1_5.1.34-1ubuntu1_amd64.deb) ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/mysql-server-core-5.1_5.1.34-1ubuntu1_amd64.deb (--unpack):
 Versuche, »/usr/sbin/mysqld« zu überschreiben, welches auch in Paket mysql-server-core-5.0 ist
dpkg-deb: Unterprozess paste mit Signal (Broken pipe) getötet
Wähle vormals abgewähltes Paket mysql-server-5.1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers