package mysql-server-5.1 5.1.30-2ubuntu1 failed to install/upgrade: 子进程 post-installation script 返回了错误号 1

Bug #316957 reported by ZhengPeng Hou on 2009-01-14
24
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
High
Steve Stalcup
mysql-dfsg-5.1 (Ubuntu)
High
Unassigned

Bug Description

sudo aptitude install mysql-server-5.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following partially installed packages will be configured:
  amarok mysql-server-5.1
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Setting up mysql-server-5.1 (5.1.30-2ubuntu1) ...
 * Stopping MySQL database server mysqld [ OK ]
 * Starting MySQL database server mysqld [fail]
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of amarok:
 amarok depends on mysql-server-5.1 (>= 5.1.30-2ubuntu1); however:
  Package mysql-server-5.1 is not configured yet.
dpkg: error processing amarok (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 mysql-server-5.1
 amarok
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up mysql-server-5.1 (5.1.30-2ubuntu1) ...
 * Stopping MySQL database server mysqld [ OK ]
 * Starting MySQL database server mysqld [fail]
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of amarok:
 amarok depends on mysql-server-5.1 (>= 5.1.30-2ubuntu1); however:
  Package mysql-server-5.1 is not configured yet.
dpkg: error processing amarok (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mysql-server-5.1
 amarok
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: 子进程 post-installation script 返回了错误号 1
Package: mysql-server-5.1 5.1.30-2ubuntu1
SourcePackage: mysql-dfsg-5.1
Title: package mysql-server-5.1 5.1.30-2ubuntu1 failed to install/upgrade: 子进程 post-installation script 返回了错误号 1
Uname: Linux 2.6.28-4-generic i686

Related branches

ZhengPeng Hou (zhengpeng-hou) wrote :
Steve Stalcup (vorian) wrote :

This seems to be a transitional problem at the moment. There are two versions of mysql in the archives at the moment.

Today, both versions were updated to resolve some version issues that were causing build failures.

To resolve this issue, we will need to wait until both versions of mysql have finished building on all platforms. We will then need to rebuild Amarok, so it pulls in libmysqlclient16-dev, instead of libmysqlclient15-dev, which the current version was built with (amarok_2.0.1.1-0ubuntu3)

Thanks very much for your bug report

Changed in mysql-dfsg-5.1:
assignee: nobody → vorian
importance: Undecided → High
status: New → In Progress
Changed in amarok:
assignee: nobody → vorian
importance: Undecided → High
status: New → In Progress
Changed in mysql-dfsg-5.1:
assignee: vorian → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:2.0.1.1-0ubuntu4

---------------
amarok (2:2.0.1.1-0ubuntu4) jaunty; urgency=low

  [ Harald Sitter ]
  * Removed build deps:
    - libvisual-0.4-dev (no support in Amarok 2 + unmaintained upstream)
    - libgtk2.0-dev (we build against libgpod-nogtk to save CD space)
  * Removed deps:
    - ruby (scripting is provided via QtScript)
    - kdebase-workspace-data (not necessary with plasma being in kdelibs)
  * Removed suggests:
    - libvisual-0.4-plugins (no support in Amarok 2 + unmaintained upstream)
  * Removed recommends:
    - kdelibs5-dbg from amarok-dbg (use dep, since it is required with the
      current build system)
  * Add Replaces/Conflicts on amarok-kde4(-dbg) to all packages
  * Drop note about libvisual from Description
  * Add ${misc:Depends} for all packages to make lintian happy
  * Import packaging into Bzr and add Vcs-Browser/Vcs-Bzr fields
  * Add final newline to debian/rules
  * Update debian/watch for stable
  * Include debian/icons and debian/amarok.menu from Debian
  * Sync build-depends with current Debian package to reduce diff

  [ Steve Stalcup ]
  * Debian/control:
    - Drop build dependancy on mysql-server-5.1 (not required for build)
    - Drop build dependancy on libmysqlclient-dev (moved to mysql 5.0)
    - Added build dependancy on libmysqlclient16-dev (provided by mysql 5.1)
    - Bump versions on build-deps
  * Correct paths in amarok.install for .xpm icons
  * Updated KUBUNTU-DEBIAND-DIFFERENCES
  * Closes amarok associated bug (LP: #316957)

 -- Steve Stalcup <email address hidden> Wed, 14 Jan 2009 18:42:40 -0500

Changed in amarok:
status: In Progress → Fix Released
kalyan (kallu-be) wrote :
Download full text (4.0 KiB)

The bug is not yet removed .. amarok still depends on mysql-server-5.1

kalyan@hercules:~$ apt-cache policy amarok
amarok:
  Installed: (none)
  Candidate: 2:2.0.1.1-0ubuntu4
  Version table:
     2:2.0.1.1-0ubuntu4 0
        500 http://archive.ubuntu.com jaunty/universe Packages
     2:1.4.10-0ubuntu3 0
        500 ftp://ftp.iitb.ac.in jaunty/universe Packages

kalyan@hercules:/mnt/Mars/temp/Delhi 6$ apt-cache depends amarok
amarok
  Depends: amarok-common
  Depends: kdebase-runtime
  Depends: kdelibs5
  Depends: libc6
  Depends: libcurl3-gnutls
  Depends: libgcc1
  Depends: libgcrypt11
 |Depends: libgl1-mesa-glx
  Depends: <libgl1>
    libgl1-mesa-glx
    libgl1-mesa-swx11
  Depends: libglib2.0-0
 |Depends: libgpod3-nogtk
  Depends: libgpod3
  Depends: libice6
  Depends: libloudmouth1-0
  Depends: libmtp8
  Depends: libmysqlclient16
  Depends: libphonon4
  Depends: libqt4-dbus
  Depends: libqt4-network
  Depends: libqt4-opengl
  Depends: libqt4-script
  Depends: libqt4-sql
  Depends: libqt4-svg
  Depends: libqt4-test
  Depends: libqt4-webkit
  Depends: libqt4-xml
  Depends: libqtcore4
  Depends: libqtgui4
  Depends: libsm6
  Depends: libstdc++6
  Depends: libstreamanalyzer0
  Depends: libstreams0
  Depends: libtag1c2a
  Depends: libx11-6
  Depends: libxau6
  Depends: libxdmcp6 ...

Read more...

ShaunS (shauns) wrote :

Hi,

I am still getting this bug as of 17/01/2009.

My workaround is to install Amarok. Install fails with MySQL 5.1 start error.

From the my command-line:

shaun@kubuntu:~$ sudo mysqld
mysqld: Table 'mysql.plugin' doesn't exist
090117 22:24:56 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
090117 22:24:57 InnoDB: Started; log sequence number 0 46409
090117 22:24:57 [ERROR] mysqld: unknown option '--skip-bdb'
090117 22:24:57 [ERROR] Aborting

090117 22:24:57 InnoDB: Starting shutdown...
090117 22:24:58 InnoDB: Shutdown completed; log sequence number 0 46409
090117 22:24:58 [Note] mysqld: Shutdown complete

I then edit /etc/mysql/my.cnf and comment out the line:
skip-bdb

I then get the error:

shaun@kubuntu:~$ sudo mysqld
mysqld: Table 'mysql.plugin' doesn't exist
090117 22:26:07 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
090117 22:26:07 InnoDB: Started; log sequence number 0 46409
090117 22:26:07 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist

If I now install a package (any package) and apt fixes the MySQL problem (I dont know how exactly) and all is well.

Hope this helps,
Shaun

I discovered this issue for myself last night, and I'm seeing the same as ShaunS today (1/18).

Thanks for posting the workaround Shaun, it worked on my test system as well.

Clement33 (clement33) wrote :

I had this problem too. I got it fixed by shaun's workaround! It now works well

Sven Roederer (sven-roederer) wrote :

The same worked for me.

In Bug #316849 is the same problem reported.

Tirsey (tirseyuis) wrote :

Thanks shaun as you saved me time and the trouble of looking for the workaround :D Much appriciated and it works great. Thanks again.

root@PIRATE:~# mysqld
mysqld: Can't create/write to file '/tmp/ibvl92PS' (Errcode: 13)
090126 0:23:52 InnoDB: Error: unable to create temporary file; errno: 13
090126 0:23:52 [ERROR] Can't start server : Bind on unix socket: No such file or directory
090126 0:23:52 [ERROR] Do you already have another mysqld server running on socket: /var/run/mysqld/mysqld.sock ?
090126 0:23:52 [ERROR] Aborting

090126 0:23:52 [Note] mysqld: Shutdown complete

root@PIRATE:~#

Any solutions?

Download full text (13.6 KiB)

A little more info on the problem:

root@PIRATE:~# mysqld
mysqld: Can't create/write to file '/tmp/ib6qNR4k' (Errcode: 13)
090126 0:27:34 InnoDB: Error: unable to create temporary file; errno: 13
090126 0:27:34 [ERROR] Can't start server : Bind on unix socket: No such file or directory
090126 0:27:34 [ERROR] Do you already have another mysqld server running on socket: /var/run/mysqld/mysqld.sock ?
090126 0:27:34 [ERROR] Aborting

090126 0:27:34 [Note] mysqld: Shutdown complete

root@PIRATE:~# aptitude install mysql-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
  libdbd-mysql-perl{a} libdbi-perl{a} libnet-daemon-perl{a}
  libplrpc-perl{a} mysql-client-5.0{a} mysql-server mysql-server-5.0{a}
The following packages will be REMOVED:
  amarok-common{u} libloudmouth1-0{u} libmtp8{u} libmysqlclient16{u}
0 packages upgraded, 7 newly installed, 4 to remove and 0 not upgraded.
Need to get 32.4MB/33.4MB of archives. After unpacking 90.2MB will be used.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
Get:1 http://ubuntu.mirror.cambrium.nl jaunty/main mysql-client-5.0 5.1.30really5.0.75-0ubuntu3 [8291kB]
Get:2 http://ubuntu.mirror.cambrium.nl jaunty/main mysql-server-5.0 5.1.30really5.0.75-0ubuntu3 [24.0MB]
Get:3 http://ubuntu.mirror.cambrium.nl jaunty/main mysql-server 5.1.30really5.0.75-0ubuntu3 [56.4kB]
Fetched 32.4MB in 45s (706kB/s)
Preconfiguring packages ...
(Reading database ... 205451 files and directories currently installed.)
Removing amarok-common ...
Removing libloudmouth1-0 ...
Removing libmtp8 ...
Removing libmysqlclient16 ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Processing triggers for hal ...
Regenerating hal fdi cache ...
 * Restarting Hardware abstraction layer hald [ OK ]
Selecting previously deselected package libnet-daemon-perl.
(Reading database ... 205027 files and directories currently installed.)
Unpacking libnet-daemon...

It looks like Amarok is still dependant on mysql-server-5.1 as of Jan 27, 2009.

ShaunS's workaround no longer works with the newere mysql-server-5.1 package (there's no skip-bdb line). :\

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers