mysql-server fails to instal with apparmour errors

Bug #322647 reported by Niklas Höglund on 2009-01-29
2
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to install the kubuntu KDE 4.2, it pulled in mysql which failed in the postinst script.

It says something about not recognising the format of apparmour files.

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: subprocess post-installation script killed by signal (Interrupt)
Package: mysql-server-5.0 5.0.67-0ubuntu6
SourcePackage: mysql-dfsg-5.0
Title: package mysql-server-5.0 5.0.67-0ubuntu6 failed to install/upgrade: subprocess post-installation script killed by signal (Interrupt)
Uname: Linux 2.6.24-21-eeepc i686

Niklas Höglund (nhoglund) wrote :
Niklas Höglund (nhoglund) wrote :

The apparmour bit is probably a red herring. I reran the install and it went through this time, but still complained about the policy files.

The first time it had complained about them and was sitting hung up for a longish while with no CPU or I/O load, at which point I pressed Ctrl-C.

Mathias Gug (mathiaz) wrote :

The relevant messages from the log are:

Setting up mysql-server-5.0 (5.0.67-0ubuntu6) ...

 * Stopping MySQL database server mysqld 
[ OK ]

Reloading AppArmor profiles /sbin/apparmor_parser: Unable to replace "/usr/share/gdm/guest-session/Xsession". Profile version not supported by Apparmor module

 Profile /etc/apparmor.d/gdm-guest-session failed to load

/sbin/apparmor_parser: Unable to replace "/usr/lib/cups/backend/cups-pdf". Profile version not supported by Apparmor module

 Profile /etc/apparmor.d/usr.sbin.cupsd failed to load

/sbin/apparmor_parser: Unable to replace "/usr/sbin/mysqld". Profile version not supported by Apparmor module

 Profile /etc/apparmor.d/usr.sbin.mysqld failed to load

 Skipping profile /etc/apparmor.d/usr.sbin.mysqld-akonadi.dpkg-new

: Warning.

 * Starting MySQL database server mysqld 
[fail]

invoke-rc.d: initscript mysql, action "start" failed.

dpkg: error processing mysql-server-5.0 (--configure):

 subprocess post-installation script killed by signal (Interrupt)

Setting up libhtml-template-perl (2.9-1) ...

The apparmor related messages are probably not responsible for the package failure. It seems that the mysql-server hasn't been able to be started. Could you post the content of /var/log/daemon.log at the time of the upgrade?

Changed in mysql-dfsg-5.0:
status: New → Incomplete

Mathias Gug wrote:
> The apparmor related messages are probably not responsible for the
> package failure. It seems that the mysql-server hasn't been able to be
> started. Could you post the content of /var/log/daemon.log at the time
> of the upgrade?

The original log for that has been rotated into oblivion by now. I tried
uninstalling and reinstalling the server now, but that didn't cause the
problem.

Mathias Gug (mathiaz) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments.

Changed in mysql-dfsg-5.0 (Ubuntu):
status: Incomplete → Invalid

On Fri, Apr 3, 2009 at 7:21 PM, Mathias Gug <email address hidden> wrote:

> We are closing this bug report because it lacks the information we need
> to investigate the problem, as described in the previous comments.

I agree that it's not worth spending more time on unless it happens to
others as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers