package mysql-server-5.0 5.0.67-0ubuntu6 failed to install/upgrade: not enough space available on partition

Bug #319515 reported by Aaron Whitehouse on 2009-01-21
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.0 (Ubuntu)
Low
Unassigned

Bug Description

Something has gone badly wrong on my MythTV box and I am now getting an error of:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
whenever I run mysql. I am trying to reinstall everything to try and fix it.

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: subprocess pre-installation script returned error exit status 1
Package: mysql-server-5.0 5.0.67-0ubuntu6
SourcePackage: mysql-dfsg-5.0
Title: package mysql-server-5.0 5.0.67-0ubuntu6 failed to install/upgrade: subprocess pre-installation script returned error exit status 1
Uname: Linux 2.6.27-9-generic i686

According to the log:

ERROR: There's not enough space in /var/lib/mysql/

What is the output of the following shell command:

 $ LC_ALL=C BLOCKSIZE= df --portability /var/lib/mysql

Thanks,

  status incomplete

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Changed in mysql-dfsg-5.0:
status: New → Incomplete

 We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in mysql-dfsg-5.0 (Ubuntu):
status: Incomplete → Invalid

Sorry, this bug has not been reported by me.
Regards Peter

-----Ursprüngliche Nachricht-----
Von: <email address hidden> [mailto:<email address hidden>] Im Auftrag von Mathias Gug
Gesendet: Donnerstag, 2. April 2009 19:48
An: <email address hidden>
Betreff: [Bug 319515] Re: package mysql-server-5.0 5.0.67-0ubuntu6 failed to install/upgrade: subprocess pre-installation script returned error exit status 1

 We are closing this bug report because it lacks the information we need
to investigate the problem, as described in the previous comments.
Please reopen it if you can give us the missing information, and don't
hesitate to submit bug reports in the future. To reopen the bug report
you can click on the current status, under the Status column, and change
the Status back to "New". Thanks again!

** Changed in: mysql-dfsg-5.0 (Ubuntu)
       Status: Incomplete => Invalid

--
package mysql-server-5.0 5.0.67-0ubuntu6 failed to install/upgrade: subprocess pre-installation script returned error exit status 1
https://bugs.launchpad.net/bugs/319515
You received this bug notification because you are a direct subscriber
of the bug.

Status in “mysql-dfsg-5.0” source package in Ubuntu: Invalid

Bug description:
Something has gone badly wrong on my MythTV box and I am now getting an error of:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
whenever I run mysql. I am trying to reinstall everything to try and fix it.

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: subprocess pre-installation script returned error exit status 1
Package: mysql-server-5.0 5.0.67-0ubuntu6
SourcePackage: mysql-dfsg-5.0
Title: package mysql-server-5.0 5.0.67-0ubuntu6 failed to install/upgrade: subprocess pre-installation script returned error exit status 1
Uname: Linux 2.6.27-9-generic i686

I'm working on Kubuntu 9.04 and got same error after system upgrade. For the space issue, it's not my case here given that

 $ LC_ALL=C BLOCKSIZE= df --portability /var/lib/mysql

returns:

Filesystem 1024-blocks Used Available Capacity Mounted on
/dev/sda3 96124936 14192112 77049868 16% /

Changed in mysql-dfsg-5.0 (Ubuntu):
status: Invalid → New
Mathias Gug (mathiaz) wrote :

@Hanen:

Could you post the apt terminal log file (/var/log/apt/term.log*) related to the failed upgrade?

Changed in mysql-dfsg-5.0 (Ubuntu):
status: New → Incomplete
Hanen Ben Rhouma (hanen105) wrote :
Mathias Gug (mathiaz) wrote :

@Hanen:

According to the terminal log file, you're error is not related to this bug since there isn't any line 'ERROR: There's not enough space in /var/lib/mysql/' in the terminal log. Please open a new bug report if you're able to reproduce your problem.

Changed in mysql-dfsg-5.0 (Ubuntu):
status: Incomplete → Invalid
summary: - package mysql-server-5.0 5.0.67-0ubuntu6 failed to install/upgrade:
- subprocess pre-installation script returned error exit status 1
+ package mysql-server-5.0 5.0.67-0ubuntu6 failed to install/upgrade: not
+ enough space available on partition
Sandeep (sgudibanda) wrote :

Hey Mathias,

I am facing similar issue and here is the ouput for the following command.

$ LC_ALL=C BLOCKSIZE= df --portability /var/lib/mysql

Filesystem 1024-blocks Used Available Capacity Mounted on
- 39220672 37710100 0 100% /

I tried just deleting everything under /var/lib as i am re-installing mysql to solve this issue. But i still get disk full error and i get the same output for the above command. How do I free the space?

Regards,
SG

Changed in mysql-dfsg-5.0 (Ubuntu):
status: Invalid → New
Chuck Short (zulcss) on 2009-12-07
Changed in mysql-dfsg-5.0 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Chuck Short (zulcss) wrote :

Intrepid is no longer supported, can you try to reproduce this on lucid,maverick or karmic.

Thanks
chuck

Changed in mysql-dfsg-5.0 (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers