max_connections fixed to 886

Bug #318915 reported by Fridolin Heyer on 2009-01-19
6
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.0 (Ubuntu)
Medium
Unassigned

Bug Description

On ubuntu 8.04 AMD64 the mysql-server-5.0 pkg
is not accepting a max_connections value higher than 886.

No matter how big your iron is, how much ram you have.

This bug didn't harm most mysql users cause who needs more than 886 simultanous connections.

If i set the variable inside my.cnf to a value higher than 886,
it will be reduced to 886.

Entering mysql it is possibly to set the variable to every value.

mysql> set global max_connections = '10000';

will work but this get lost with your next reboot.

Older version and even the 32bit version,
don't have that bug.

It's crazy that just the 64bit pkg has this bug.

best regards
fridolin

Andreas Olsson (andol) wrote :

I can confirm this. I can replicate the limitation on Hardy amd64 but not on Hardy i386.

Changed in mysql-dfsg-5.0:
status: New → Confirmed
Connor Imes (ckimes) on 2009-01-20
Changed in mysql-dfsg-5.0:
importance: Undecided → Medium
Chuck Short (zulcss) wrote :

Why not set it in the my.cnf?

Regards
chuck

Andreas Olsson (andol) wrote :

Chuck: The report, among other things, says: "If i set the variable inside my.cnf to a value higher than 886, it will be reduced to 886."

Thanks I managed to fix everything

***************************************************************************************************************
Kind regards,
Muita Wangoko

Tel: +254-(0)-724 159 723
     +254-(0)-738 560 599

"Elementary sartorial techniques initially applied
obviate the need for repetitive similar actions to
the square of three"

**************************************************************************************************************

Marilyn Monroe - "It's not true that I had nothing on. I had the radio on."

On Mon, Jan 26, 2009 at 8:10 PM, Andreas Olsson <email address hidden> wrote:

> Chuck: The report, among other things, says: "If i set the variable
> inside my.cnf to a value higher than 886, it will be reduced to 886."
>
> --
> max_connections fixed to 886
> https://bugs.launchpad.net/bugs/318915
> You received this bug notification because you are subscribed to mysql-
> dfsg-5.0 in ubuntu.
>
> Status in "mysql-dfsg-5.0" source package in Ubuntu: Confirmed
>
> Bug description:
> On ubuntu 8.04 AMD64 the mysql-server-5.0 pkg
> is not accepting a max_connections value higher than 886.
>
> No matter how big your iron is, how much ram you have.
>
> This bug didn't harm most mysql users cause who needs more than 886
> simultanous connections.
>
> If i set the variable inside my.cnf to a value higher than 886,
> it will be reduced to 886.
>
> Entering mysql it is possibly to set the variable to every value.
>
> mysql> set global max_connections = '10000';
>
> will work but this get lost with your next reboot.
>
> Older version and even the 32bit version,
> don't have that bug.
>
> It's crazy that just the 64bit pkg has this bug.
>
>
> best regards
> fridolin
>

Mathias Gug (mathiaz) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Jaunty Jackalope. Setting max_connections in /etc/mysql/my.cnf works as expected.

It won't be fixed in previous versions of Ubuntu because the package doesn't fit the requirements for backporting. See https://help.ubuntu.com/community/UbuntuBackports for more information.

Changed in mysql-dfsg-5.0:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers