user table setup fails if hostname is "localhost"

Bug #223836 reported by Daniel Hahler
4
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.0 (Debian)
Fix Released
Unknown
mysql-dfsg-5.0 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Installing mysql-server-5.0 (5.0.51a-3ubuntu5) in Ubuntu Hardy fails, if hostname is "localhost".

The reason for this is a "duplicate key" error in ./scripts/mysql_system_tables_data.sql.

I'm attaching a fix for this.

Revision history for this message
Daniel Hahler (blueyed) wrote :
Revision history for this message
Chuck Short (zulcss) wrote :

Thanks for the patch.

Changed in mysql-dfsg-5.0:
status: New → In Progress
Changed in mysql-dfsg-5.0:
status: Unknown → New
Revision history for this message
Chuck Short (zulcss) wrote :

I have confirmed this for hardy.

The bug has been addressed upstream by http://bugs.mysql.com/bug.php?id=34461. It has not been added to intrepid yet because it has not be merged yet. It is a simple one liner patch, which I have attached to the bug report.

TEST CASE:

To reproduce it, you have to do the following:

1. Set your hostname to localhost.
2. Install the mysql packages from the repository.
3. In your /var/log/syslog you should see the following:
         Installation of my system tables failed!
4. Try logging in with mysql -u root -p
5. You should not be able to connect.

!!! WARNING - You should probably do this in a virtual machine just in case.

The patch does resolve the issue.

Revision history for this message
Chuck Short (zulcss) wrote :

I have confirmed this for hardy.

The bug has been addressed upstream by http://bugs.mysql.com/bug.php?id=34461. It has not been added to intrepid yet because it has not be merged yet. It is a simple one liner patch, which I have attached to the bug report.

TEST CASE:

To reproduce it, you have to do the following:

1. Set your hostname to localhost.
2. Install the mysql packages from the repository.
3. In your /var/log/syslog you should see the following:
         Installation of my system tables failed!
4. Try logging in with mysql -u root -p
5. You should not be able to connect.

!!! WARNING - You should probably do this in a virtual machine just in case.

The patch does resolve the issue. If you have any questions please let me know.

Thanks
chuck

Revision history for this message
Nick Barcet (nijaba) wrote : Re: [Bug 223836] Re: user table setup fails if hostname is "localhost"

Is it the same problem as bug #226851 ?

Revision history for this message
Mathias Gug (mathiaz) wrote : Re: [Bug 223836] Re: user table setup fails if hostname is "localhost"

On Thu, May 08, 2008 at 08:34:26AM -0000, Nick Barcet wrote:
> Is it the same problem as bug #226851 ?

I don't think so.

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in mysql-dfsg-5.0:
status: New → Fix Committed
Steve Langasek (vorlon)
Changed in mysql-dfsg-5.0:
milestone: none → ubuntu-8.04.1
Revision history for this message
Adam Sommer (asommer) wrote :

The package in -proposed worked fine for me.

Revision history for this message
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in mysql-dfsg-5.0:
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Copied hardy-proposed to intrepid.

Changed in mysql-dfsg-5.0:
status: In Progress → Fix Released
Changed in mysql-dfsg-5.0:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.