Cannot upgrade to mysql-server-5.0

Bug #208695 reported by Darren Warner on 2008-03-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.0 (Ubuntu)
Undecided
Unassigned
Hardy
Medium
Steve Langasek
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: mysql-client-5.0

Trying to upgrade MySQL 4.1 to 5.0 (just after a dapper -> hardy LTS upgrade):

Preconfiguring packages ...
(Reading database ... 140431 files and directories currently installed.)
Unpacking mysql-client-5.0 (from .../mysql-client-5.0_5.0.51a-3ubuntu5_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/mysql-client-5.0_5.0.51a-3ubuntu5_amd64.deb (--unpack):
 trying to overwrite `/usr/bin/myisam_ftdump', which is also in package mysql-client-4.1
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking mysql-server-5.0 (from .../mysql-server-5.0_5.0.51a-3ubuntu5_amd64.deb) ...
Stopping MySQL database server: mysqld.
dpkg: error processing /var/cache/apt/archives/mysql-server-5.0_5.0.51a-3ubuntu5_amd64.deb (--unpack):
 trying to overwrite `/usr/bin/comp_err', which is also in package mysql-server-4.1
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-client-5.0_5.0.51a-3ubuntu5_amd64.deb
 /var/cache/apt/archives/mysql-server-5.0_5.0.51a-3ubuntu5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

SRU justification: breaks installation of new packages when particular packages from universe are installed from the previous LTS release

Does not apply to intrepid, for which direct upgrades from dapper are not supported.

TEST CASE:
1) Install mysql-server-4.1 and mysql-client-4.1 from dapper.
2) upgrade to hardy.
3) install the mysql-client and mysql-server packages.
4) observe that the upgrade fails with file conflicts.
5) enable hardy-proposed.
6) try again to install the mysql-client and mysql-server packages.
7) observe that the upgrade completes successfully, with removal of the old mysql-{client,server}-4.1 packages.

Regression potential: minimal, since the only change is to declare conflicts/replaces with packages that already have these file conflicts in practice. However, the impact of this bug is also lower than I originally thought, because it can't be triggered on a dapper->hardy upgrade itself since the mysql-client and mysql-server metapackages are /already/ pointing at 5.0 in dapper, and already have the undeclared file conflicts. Therefore this SRU does not need to be accepted prior to the 8.04.1 point release.

Steve Langasek (vorlon) on 2008-05-14
Changed in mysql-dfsg-5.0:
milestone: none → ubuntu-8.04.1
status: New → Confirmed
Steve Langasek (vorlon) wrote :

marking as 'wontfix' for intrepid, since this problem is specific to upgrades from dapper.

Changed in mysql-dfsg-5.0:
status: New → Won't Fix
Steve Langasek (vorlon) on 2008-06-26
Changed in mysql-dfsg-5.0:
assignee: nobody → vorlon
status: Confirmed → In Progress
Steve Langasek (vorlon) on 2008-06-27
description: updated
Changed in mysql-dfsg-5.0:
importance: Undecided → Medium
milestone: ubuntu-8.04.1 → none
Martin Pitt (pitti) wrote :

rejecting your mysql 5.0.51a-3ubuntu6 upload from hardy-proposed; it seems you patched against 5.0.51a-3ubuntu5 in hardy instaed of 5.0.51a-3ubuntu5.1 in hardy-updates

Changed in mysql-dfsg-5.0:
status: New → Won't Fix

On Thu, Jul 03, 2008 at 04:30:23PM -0000, Martin Pitt wrote:
> rejecting your mysql 5.0.51a-3ubuntu6 upload from hardy-proposed; it
> seems you patched against 5.0.51a-3ubuntu5 in hardy instaed of 5.0.51a-
> 3ubuntu5.1 in hardy-updates

Reuploaded as 3ubuntu5.2.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in mysql-dfsg-5.0:
status: In Progress → Fix Committed
ShadowMax (shadowmax76) wrote :

* Ubuntu Hardy *

- Installed libmysqlclient14_4.1.15-1ubuntu5_i386 and mysql-client-4.1_4.1.15-1ubuntu5_i386 from http://packages.ubuntu.com/dapper.

- Tried to install mysql-client-5.0:

$ sudo aptitude install mysql-client-5.0

...
The following NEW packages will be installed:
  mysql-client-5.0
...
dpkg: error processing /var/cache/apt/archives/mysql-client-5.0_5.0.51a-3ubuntu5.1_i386.deb (--unpack):
 trying to overwrite `/usr/bin/myisam_ftdump', which is also in package mysql-client-4.1
dpkg-deb: subprocess paste killed by signal (Broken pipe)
...

- Installing mysql-client-5.0 from hardy-proposed worked fine:

$ sudo aptitude -t hardy-proposed install mysql-client-5.0

...
The following NEW packages will be installed:
  mysql-client-5.0
The following packages will be REMOVED:
  mysql-client-4.1
The following packages will be upgraded:
  libmysqlclient15off mysql-common
...

Steve Langasek (vorlon) wrote :

This package has been copied to hardy-updates, which now has version -3ubuntu5.4 of the package.

Changed in mysql-dfsg-5.0:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers