mySQL password asks only once

Bug #162167 reported by tropicalfruitz
6
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.0 (Debian)
Fix Released
Unknown
mysql-dfsg-5.0 (Ubuntu)
Wishlist
Unassigned
Hardy
Wishlist
Unassigned

Bug Description

During the installation of Ubuntu Gutsy Server, the password request for mySQL 5.0 only occurs once without verification.

Revision history for this message
Dan Trevino (dantrevino) wrote :

assign to server team for eval.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Unassigned. Server team doesn't work that way. You want to evaluate it feel free, but don't assign things to teams that you aren't in charge of or that don't have a policy that supports it (Kernel team does as an example).

Revision history for this message
jelias (jeffrey-eliasen) wrote :

I just noticed this today when I installed server for the first time. If this can be properly assigned and a mentor provided, I would love to use this as my first step into the ubuntu community.

Mathias Gug (mathiaz)
Changed in mysql-dfsg-5.0:
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
Mathias Gug (mathiaz) wrote :

That would be helpful. You can assign the bug to your self and start working on it.

See https://wiki.ubuntu.com/PackagingGuide/ for more information on packaging. You can also drop by #ubuntu-server or contact me directly so that I can help you get started on the bug.

Revision history for this message
jelias (jeffrey-eliasen) wrote :

slight delay as I get up to speed on the packaging mechanism... should be no more than a couple days to get familiarized

Changed in mysql-dfsg-5.0:
assignee: nobody → jeffrey-eliasen
Revision history for this message
jelias (jeffrey-eliasen) wrote : Re: [Bug 162167] Re: mySQL password asks only once

I think I understand the basic packaging mechanism. As I see it, I'm looking
at the file mysql-dfsg-5.0-5.0.45/debian/mysql-server-5.0.postinst and the
related <...>.template files. I see two things that need to happen:

   1. a new string needs to be added to the template file with text to
   the effect of "re-enter password blah blah", plus whatever localization gets
   wrapped around that (I assume this would be a different bug to get
   localization added?)
   2. the postinst file needs to be modified to be similar to the core OS
   install to ask for a password and verification, compare strings, etc

I have no idea how to make (1) happen; are there are people whose jobs are
to write these strings or do I come up with something on my own? Translation
is definitely outside of my expertise :)

For (2), I would like to basically mimic the code from the base OS
installer, partly to keep it simple and partly for consistency between
components. With this in mind, which package is initially responsible for
setting the system root password? Where can I find a list of the core
packages that get laid down in every debian installation?

Jeff

On Tue, Mar 18, 2008 at 4:18 AM, Mathias Gug <email address hidden> wrote:

> That would be helpful. You can assign the bug to your self and start
> working on it.
>
> See https://wiki.ubuntu.com/PackagingGuide/ for more information on
> packaging. You can also drop by #ubuntu-server or contact me directly so
> that I can help you get started on the bug.
>
> --
> mySQL password asks only once
> https://bugs.launchpad.net/bugs/162167
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "mysql-dfsg-5.0" in Ubuntu: Triaged
>
> Bug description:
> During the installation of Ubuntu Gutsy Server, the password request for
> mySQL 5.0 only occurs once without verification.
>

Revision history for this message
Nick Barcet (nijaba) wrote :

Jelias,

This bug just got highlighted a bit too much and beta is right at the door so I am going to ask nxvl to fix it quickly. We tried to contact you before deciding this but could not find your details on Launchpad.

Please do not feel frustrated about this, there is nothing against you here and there are certainly other bugs where your help will be very appreciated and we'll have the time to mentor you.

Changed in mysql-dfsg-5.0:
assignee: jeffrey-eliasen → nvalcarcel
status: Triaged → Confirmed
Revision history for this message
Nicolas Valcarcel (nvalcarcel) wrote :

Attaching debdiff for revision.

Changed in mysql-dfsg-5.0:
assignee: nvalcarcel → nobody
Revision history for this message
Daniel Holbach (dholbach) wrote :

Mathias: can you take a look at it?

Revision history for this message
Nicolas Valcarcel (nvalcarcel) wrote :

I make a mistake, i forgot to add some changes.

Changed in mysql-dfsg-5.0:
status: Unknown → New
Revision history for this message
Nicolas Valcarcel (nvalcarcel) wrote :
Revision history for this message
Nicolas Valcarcel (nvalcarcel) wrote :

Sorry about last debdiff.

Revision history for this message
Mathias Gug (mathiaz) wrote :

Thanks for you debdiffs.

Your drops the debconf priority to medium, instead of high, resulting in a default install that doesn't prompt for a password during installation.

You've also tried to fix a non-existing issue in your last debdiff: /etc/init.d/mysql stop does the right thing even if mysqld is not running. Thus the comment raised in the debian-devel mail doesn't apply to mysql-dfsg. Please check if the issue applies to the package before fixing it.

Could you also not include all the translations in your debdiff ? These are automatically generated by the clean target and should be removed from the submitted debdiff to help the review. Look at the filterdiff command to help in that regard.

Otherwise the debconf code looks good and works. However adding a new string in the template means that we'll have to notify translators about it.

Revision history for this message
Nicolas Valcarcel (nvalcarcel) wrote :

The last change i add was about the comment on Bug #205985, where they point that this error actually happens, which i have also confirm it some time ago, and the source doesn't look like it was solved, sorry about that. But also that's why i keep the previous patch so you can just drop that change.

About the Template, what are the procedures for that? should i notify the translators? where?

Revision history for this message
Nicolas Valcarcel (nvalcarcel) wrote :

Uploading new debdiff.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-dfsg-5.0 - 5.0.51a-3ubuntu3

---------------
mysql-dfsg-5.0 (5.0.51a-3ubuntu3) hardy; urgency=low

  [ Nicolas Valcárcel ]
  * Confirming password on install if given (LP: #162167)

  [ Jamie Strandboge ]
  * follow ApparmorProfileMigration and force apparmor complain mode on some
    upgrades (LP: #203531)
    - debian/control: Recommends apparmor >= 2.1+1075-0ubuntu6
    - debian/mysql-server-5.0.dirs: add etc/apparmor.d/force-complain
    - debian/mysql-server-5.0.preinst: create symlink for force-complain/
      on pre-feisty upgrades, upgrades where apparmor-profiles profile is
      unchanged (ie non-enforcing) and upgrades where the profile doesn't
      exist
    - debian/mysql-server-5.0.postrm: remove symlink in force-complain/ on
      purge
  * debian/additions/my.cnf: add warning about apparmor (LP: #201799)

 -- Mathias Gug <email address hidden> Tue, 25 Mar 2008 17:05:22 -0400

Changed in mysql-dfsg-5.0:
status: Confirmed → Fix Released
Changed in mysql-dfsg-5.0:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.