Comment 5 for bug 153221

I was also able to update on Gutsy without issue:

Preparing to replace mysql-server-5.0 5.0.45-1ubuntu2 (using .../mysql-server-5.0_5.0.45-1ubuntu3_i386.deb) ...

Setting up mysql-server-5.0 (5.0.45-1ubuntu3) ...
 * Stopping MySQL database server mysqld [ OK ]
 * Starting MySQL database server mysqld [ OK ]
 * Checking for corrupt, not cleanly closed and upgrade needing tables.

Again, I used "sudo apt-get update; sudo apt-get upgrade" and not aptitude so I guess it could be an aptitude issue?