Merge mysql-defaults from Debian unstable for 22.04

Bug #1946875 reported by Bryce Harrington
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-defaults (Ubuntu)
Undecided
Miriam España Acebal

Bug Description

Upstream: (Debian)
Debian: 1.0.7
Ubuntu: 1.0.5ubuntu2

Please also note LP: #1945956 "mysql-8.0: Fails to build against OpenSSL 3.0", which will need addressed for the upcoming OpenSSL transition.

### New Debian Changes ###

mysql-defaults (1.0.7) unstable; urgency=medium

  * Set Ubuntu defaults to the mysql-8.0 family.
  * Do not build default-libmysqld-dev on Ubuntu.
  * Switch to debhelper-compat (= 13).
  * Set Rules-Requires-Root: no.
  * Bump Standards-Version to 4.5.1, no changes needed.

 -- Andreas Beckmann <email address hidden> Mon, 08 Feb 2021 22:46:21 +0100

mysql-defaults (1.0.6) unstable; urgency=medium

  * Change Debian defaults to MariaDB 10.5 as it is now available
    in both Debian unstable and Debian testing

 -- Otto Kekäläinen <email address hidden> Sat, 05 Dec 2020 18:35:44 +0200

mysql-defaults (1.0.5ubuntu1) eoan; urgency=medium

  * Bump MySQL to 8.0.

 -- Robie Basak <email address hidden> Mon, 12 Aug 2019 02:29:20 +0100

mysql-defaults (1.0.5) unstable; urgency=medium

  [ Andreas Beckmann ]
  * Switch Vcs-* URLs to salsa.debian.org.
  * Use dpkg makefile snippets instead of manual changelog parsing.
  * Sync debian/copyright with the current dh-make template.
  * Switch to debhelper compat level 11.
  * Bump Standards-Version to 4.1.4, no changes needed.

  [ Otto Kekäläinen ]
  * Change Debian dependencies to MariaDB 10.3 series now available in unstable

 -- Otto Kekäläinen <email address hidden> Tue, 25 Dec 2018 13:57:14 +0200

mysql-defaults (1.0.4) unstable; urgency=medium

  * Add frozen mode common documentation.
  * Add copyright statement for files in doc/*

 -- Robie Basak <email address hidden> Fri, 12 Jan 2018 09:43:13 +0000

mysql-defaults (1.0.3) unstable; urgency=medium

  [ Andreas Beckmann ]
  * default-mysql-server: Add Breaks against the transitional mysql-server
    package in stretch to reduce future upgrade problems.
  * Use substvars for the defaults and dpkg-vendor to distinguish between
    Debian and Ubuntu at build time.
  * Set Ubuntu defaults to the mysql-5.7 family.
  * Bump Standards-Version to 4.0.0, no changes needed.

  [ Pino Toscano ]
  * Add default-libmysqld-dev package. (Closes: #852102)

 -- Andreas Beckmann <email address hidden> Wed, 28 Jun 2017 13:12:15 +0200

mysql-defaults (1.0.2) unstable; urgency=medium

  [ Andreas Beckmann ]
  * Do not install alternatives pointing to conffiles that were removed by the
    local admin (Closes: #844048)

  [ Otto Kekäläinen ]
  * Update the versioned dependencies from MariaDB 10.0 to 10.1 now when
    MariaDB 10.1 has entered Debian unstable and testing (Closes: #850147)

 -- Otto Kekäläinen <email address hidden> Sun, 15 Jan 2017 21:46:13 +0200

mysql-defaults (1.0.1) unstable; urgency=low

  [ Helmut Grohne ]
  * Switch default-libmysqlclient-dev to Architecture: any. (Closes: #842454)

 -- Otto Kekäläinen <email address hidden> Thu, 10 Nov 2016 22:22:16 +0200

mysql-defaults (1.0.0) unstable; urgency=low

  [ Andreas Beckmann ]
  * fix the branch in the Vcs-Git URL

  [ Otto Kekäläinen ]
  * Upload to unstable

 -- Otto Kekäläinen <email address hidden> Mon, 15 Aug 2016 21:10:41 +0300

mysql-defaults (1.0.0~exp1) experimental; urgency=low

  [ Otto Kekäläinen ]
  * Initial upload to Debian. This package provides a mysql-common package
    that is independent on it's own without the server source packages.
    This source package also generates the default-mysql-* metapackages
    that have been created to meet the requirements set by the release team.
    The package will be first tested in experimental so that any potential
    regressions have minimal impact.
    .
    The mysql-common package replaces the one provided from mysql-5.6/5.7
    source package. In the future mysql-common will be provided only from this

### Old Ubuntu Delta ###

mysql-defaults (1.0.5ubuntu2) eoan; urgency=medium

  * Drop the default-libmysqld-dev binary package. MySQL 8 no longer produces
    a libmysqld-dev package, so it no longer makes sense to ship this.

 -- Robie Basak <email address hidden> Thu, 22 Aug 2019 20:38:41 +0000

mysql-defaults (1.0.5ubuntu1) eoan; urgency=medium

  * Bump MySQL to 8.0.

 -- Robie Basak <email address hidden> Mon, 12 Aug 2019 02:29:20 +0100

Changed in mysql-defaults (Ubuntu):
assignee: nobody → Miriam España Acebal (mirespace)
Bryce Harrington (bryce)
description: updated
Changed in mysql-defaults (Ubuntu):
milestone: none → ubuntu-21.11
Bryce Harrington (bryce)
description: updated
Bryce Harrington (bryce)
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers