mysql-admin should emit more informative error messages

Bug #94746 reported by Kurt J. Bosch on 2007-03-22
2
Affects Status Importance Assigned to Milestone
mysql-admin (Debian)
Fix Released
Unknown
mysql-admin (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: mysql-admin

When I try to use mysql-admin on feisty to run a Backup-Job (Normal Backup - all tables - mythtv database mythconverg) against mysql-server on up to date Dapper, I only get these Errors:

Error during Backup
SQL-Error

The backup does not run.

I tried to move ~/.mysql* away and created a new Job but it didn't help.

Versions are:
Client: Ubuntu Feisty mysql-admin 1.2.5rc-1
Server: Ubuntu Dapper mysql-server 5.0.22-0ubuntu6.06.3

After I installed
mysql-admin_1.1.10-1_i386.deb
mysql-admin-common_1.1.10-1_all.deb
from edgy it worked normal again.

OK - now I did

mysql -u root -p
grant select on mysql.* to mythtv@"192.168.178.%" identified by "mythtv";
flush privileges;
exit

to grant right to read database mysql to user mythtv which I use for doing backups with mysql-admin and now it works with the new version too. (Many thanks to Adam Majer)

I don't know why this change was necessary now. It workes with 1.1.10 without this too. I needed only
grant all on mythconverg.* to mythtv@"192.168.178.%" identified by "mythtv";
to grant rights for database mythconverg itself to user mythtv.

Now I don't know - is this a bug or is this a feature ?

OK - the last line from mysql.log which I got after enabling logging on the server was:

Access denied for user 'mythtv'@'192.168.178.%' to database 'mysql'

So I think at least the error message given by mysql-admin should be 'Access denied for database mysql' or similar, but not only 'SQL-Error' because this is misleading and does not really help.

Canging summary

Changed in mysql-admin:
status: Unknown → Fix Released

i stil got that message sql error on feisty
En Edgy me funciona bien, pero aqui en feisty no se como solucionarlo, me da el error sql cunado quiero hacer backup.

Daniel T Chen (crimsun) on 2008-09-29
Changed in mysql-admin:
importance: Undecided → Wishlist
status: New → Confirmed
JC Hulce (soaringsky) wrote :

We're closing this bug since it is has been some time with no response from the original bug reporter. However, if the issue still exists in the latest development version of Ubuntu and you are the original reporter please feel free to reopen with the requested information. If you are not the original reporter, please don't reopen this one but instead file a new bug and reference this one.

Changed in mysql-admin (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.