mysql-8.0: Fail to build against OpenSSL 3.0

Bug #1945956 reported by Simon Chopin
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-8.0 (Ubuntu)
Fix Released
Undecided
Robie Basak

Bug Description

Hello,

As part of a rebuild against OpenSSL3, this package failed to build on one or
several architectures. You can find the details of the rebuild at

https://people.canonical.com/~schopin/rebuilds/openssl-3.0.0-impish.html

or for the amd64 failed build, directly at

https://launchpad.net/~schopin/+archive/ubuntu/openssl-3.0.0/+build/22099159/+files/buildlog_ubuntu-impish-amd64.mysql-8.0_8.0.26-0ubuntu1.0~ssl3ppa1.1_BUILDING.txt.gz

We're planning to transition to OpenSSL 3.0 for the 22.04 release, and consider
this issue as blocking for this transition.

You can find general migration informations at
https://www.openssl.org/docs/manmaster/man7/migration_guide.html
For your tests, you can build against libssl-dev as found in the PPA
schopin/openssl-3.0.0

I can find a patchset upstream for this issue, but I couldn't see any sign of upstream
review on it:

https://github.com/mysql/mysql-server/pull/320
https://bugs.mysql.com/bug.php?id=102405

Related branches

Bryce Harrington (bryce)
tags: added: server-next
Changed in mysql-8.0 (Ubuntu):
assignee: nobody → Miriam España Acebal (mirespace)
Changed in mysql-8.0 (Ubuntu):
assignee: Miriam España Acebal (mirespace) → nobody
Changed in mysql-8.0 (Ubuntu):
status: New → Triaged
Robie Basak (racb)
Changed in mysql-8.0 (Ubuntu):
assignee: nobody → Robie Basak (racb)
Revision history for this message
Simon Chopin (schopin) wrote :

OK, so I tested out the patches linked above. Turns out they still FTBFS against libssl3, because there is some SSL code buried in some plugins which hasn't been update. ALso, the patched package also FTBFS against libssl1.1 as the test suite fails on main.ssl_deprecated_tls_versions. I'm currently rebuilding the package from scratch to check that it is indeed a regression from the patch, and not something that's been introduced by the 1.1.1l version of OpenSSL.

Revision history for this message
Robie Basak (racb) wrote : Re: [Bug 1945956] Re: mysql-8.0: Fail to build against OpenSSL 3.0

I have already enhanced the patches to add support for the plugins, but feel free to take over if you like?

Revision history for this message
Simon Chopin (schopin) wrote :

Oh I'd rather not take over, thank you :-D

I just wanted to do a quick sanity check of this patch since mysql-8 was
the last package on my list that didn't have any obvious sign of
activity. I'm glad you're on it :)

Robie Basak (racb)
tags: added: ftbfs update-excuse
Robie Basak (racb)
Changed in mysql-8.0 (Ubuntu):
milestone: none → ubuntu-22.04-feature-freeze
Revision history for this message
Robie Basak (racb) wrote :

Fixed in 8.0.28-0ubuntu1 now in jammy-proposed.

Changed in mysql-8.0 (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-8.0 - 8.0.28-0ubuntu3

---------------
mysql-8.0 (8.0.28-0ubuntu3) jammy; urgency=medium

  * d/a/source_mysql-8.0.py: Improve apport hook
    - Update call signature for add_info() (LP: #1922413)
    - Skip non-existing conf dirs (LP: #1958641)
    - If /etc/mysql missing, ask confirmation (LP: #1922412)
    - Fix all lint/flakes warnings
      + python3 -m py_compile source_mysql-8.0.py
      + pyflakes3 source_mysql-8.0.py
      + pylint source_mysql-8.0.py

 -- Bryce Harrington <email address hidden> Wed, 16 Feb 2022 19:07:41 -0800

Changed in mysql-8.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers