package mysql-server-5.7 5.7.25-0ubuntu0.18.04.2 failed to install/upgrade: installed mysql-server-5.7 package post-installation script subprocess returned error exit status 1

Bug #1814630 reported by Success on 2019-02-05

This bug report will be marked for expiration in 17 days if no further activity occurs. (find out why)

16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mysql-5.7 (Ubuntu)
Undecided
Unassigned

Bug Description

I am trying to set up a database via the terminal using mysql,and i get the error above

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: mysql-server-5.7 5.7.25-0ubuntu0.18.04.2
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
Date: Tue Feb 5 08:07:49 2019
ErrorMessage: installed mysql-server-5.7 package post-installation script subprocess returned error exit status 1
InstallationDate: Installed on 2019-02-02 (2 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
Logs.var.log.daemon.log:

MySQLConf.etc.mysql.conf.d.mysql.cnf: [mysql]
MySQLConf.etc.mysql.conf.d.mysqldump.cnf:
 [mysqldump]
 quick
 quote-names
 max_allowed_packet = 16M
MySQLConf.etc.mysql.mysql.conf.d.mysqld_safe_syslog.cnf:
 [mysqld_safe]
 syslog
MySQLVarLibDirListing: ['ib_buffer_pool', 'sys', 'debian-5.7.flag', 'ibtmp1', 'ibdata1', 'ib_logfile0', 'performance_schema', 'mysql', 'ib_logfile1', 'auto.cnf']
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=7613dd27-b8f7-439b-a4d1-2757fd17e5bd ro quiet splash resume=UUID of swap vt.handoff=1
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3ubuntu1
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.3
SourcePackage: mysql-5.7
Title: package mysql-server-5.7 5.7.25-0ubuntu0.18.04.2 failed to install/upgrade: installed mysql-server-5.7 package post-installation script subprocess returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Success (dmoxy) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mysql-5.7 (Ubuntu):
status: New → Confirmed
Karl Stenerud (kstenerud) wrote :

Hi,

You're getting the following error each time you try to launch mysql:

2019-02-05T07:26:56.039478Z 0 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
2019-02-05T07:26:56.039484Z 0 [ERROR] Do you already have another mysqld server running on port: 3306 ?
2019-02-05T07:26:56.039502Z 0 [ERROR] Aborting

Use netstat -lntp to find out what is listening on mysql's port (3306). Do you have a non-ubuntu mysql or mariadb installed?

Changed in mysql-5.7 (Ubuntu):
status: Confirmed → Incomplete

I am using the database provided by LAMP stack

On Wed, Feb 6, 2019 at 12:20 PM Karl Stenerud <email address hidden>
wrote:

> Hi,
>
> You're getting the following error each time you try to launch mysql:
>
> 2019-02-05T07:26:56.039478Z 0 [ERROR] Can't start server: Bind on TCP/IP
> port: Address already in use
> 2019-02-05T07:26:56.039484Z 0 [ERROR] Do you already have another mysqld
> server running on port: 3306 ?
> 2019-02-05T07:26:56.039502Z 0 [ERROR] Aborting
>
> Use netstat -lntp to find out what is listening on mysql's port (3306).
> Do you have a non-ubuntu mysql or mariadb installed?
>
>
> ** Changed in: mysql-5.7 (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1814630
>
> Title:
> package mysql-server-5.7 5.7.25-0ubuntu0.18.04.2 failed to
> install/upgrade: installed mysql-server-5.7 package post-installation
> script subprocess returned error exit status 1
>
> Status in mysql-5.7 package in Ubuntu:
> Incomplete
>
> Bug description:
> I am trying to set up a database via the terminal using mysql,and i
> get the error above
>
> ProblemType: Package
> DistroRelease: Ubuntu 18.04
> Package: mysql-server-5.7 5.7.25-0ubuntu0.18.04.2
> ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
> Uname: Linux 4.15.0-29-generic x86_64
> ApportVersion: 2.20.9-0ubuntu7.2
> Architecture: amd64
> Date: Tue Feb 5 08:07:49 2019
> ErrorMessage: installed mysql-server-5.7 package post-installation
> script subprocess returned error exit status 1
> InstallationDate: Installed on 2019-02-02 (2 days ago)
> InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64
> (20180725)
> Logs.var.log.daemon.log:
>
> MySQLConf.etc.mysql.conf.d.mysql.cnf: [mysql]
> MySQLConf.etc.mysql.conf.d.mysqldump.cnf:
> [mysqldump]
> quick
> quote-names
> max_allowed_packet = 16M
> MySQLConf.etc.mysql.mysql.conf.d.mysqld_safe_syslog.cnf:
> [mysqld_safe]
> syslog
> MySQLVarLibDirListing: ['ib_buffer_pool', 'sys', 'debian-5.7.flag',
> 'ibtmp1', 'ibdata1', 'ib_logfile0', 'performance_schema', 'mysql',
> 'ib_logfile1', 'auto.cnf']
> ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic
> root=UUID=7613dd27-b8f7-439b-a4d1-2757fd17e5bd ro quiet splash resume=UUID
> of swap vt.handoff=1
> Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal,
> 3.6.5-3ubuntu1
> PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal,
> 2.7.15~rc1-1
> RelatedPackageVersions:
> dpkg 1.19.0.5ubuntu2
> apt 1.6.3
> SourcePackage: mysql-5.7
> Title: package mysql-server-5.7 5.7.25-0ubuntu0.18.04.2 failed to
> install/upgrade: installed mysql-server-5.7 package post-installation
> script subprocess returned error exit status 1
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/mysql-5.7/+bug/1814630/+subscriptions
>

ThiagoSerra (thiagoserra) wrote :
Download full text (5.8 KiB)

Same error here on trying to install mysql-server-5.7 and mysql-client-5.7

--------------------------------------------------------------------------------------------

thiago@notedell06:~$ sudo apt install mysql-server-5.7 mysql-client-5.7
[sudo] senha para thiago:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
The following additional packages will be installed:
  libaio1 libevent-core-2.1-6 mysql-client-core-5.7 mysql-common mysql-server-core-5.7
Pacotes sugeridos:
  mailx tinyca
Os NOVOS pacotes a seguir serão instalados:
  libaio1 libevent-core-2.1-6 mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server-5.7
  mysql-server-core-5.7
0 pacotes atualizados, 7 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 0 B/20,4 MB de arquivos.
Depois desta operação, 160 MB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Pré-configurando pacotes ...
A seleccionar pacote anteriormente não seleccionado mysql-common.
(Lendo banco de dados ... 149584 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../0-mysql-common_5.8+1.0.4_all.deb ...
A descompactar mysql-common (5.8+1.0.4) ...
A seleccionar pacote anteriormente não seleccionado libaio1:amd64.
A preparar para desempacotar .../1-libaio1_0.3.110-5_amd64.deb ...
A descompactar libaio1:amd64 (0.3.110-5) ...
A seleccionar pacote anteriormente não seleccionado mysql-client-core-5.7.
A preparar para desempacotar .../2-mysql-client-core-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb ...
A descompactar mysql-client-core-5.7 (5.7.25-0ubuntu0.18.04.2) ...
A seleccionar pacote anteriormente não seleccionado mysql-client-5.7.
A preparar para desempacotar .../3-mysql-client-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb ...
A descompactar mysql-client-5.7 (5.7.25-0ubuntu0.18.04.2) ...
A seleccionar pacote anteriormente não seleccionado mysql-server-core-5.7.
A preparar para desempacotar .../4-mysql-server-core-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb ...
A descompactar mysql-server-core-5.7 (5.7.25-0ubuntu0.18.04.2) ...
A seleccionar pacote anteriormente não seleccionado libevent-core-2.1-6:amd64.
A preparar para desempacotar .../5-libevent-core-2.1-6_2.1.8-stable-4build1_amd64.deb ...
A descompactar libevent-core-2.1-6:amd64 (2.1.8-stable-4build1) ...
A descompactar mysql-common (5.8+1.0.4) ...
A seleccionar pacote anteriormente não seleccionado libaio1:amd64.
A preparar para desempacotar .../1-libaio1_0.3.110-5_amd64.deb ...
A descompactar libaio1:amd64 (0.3.110-5) ...
A seleccionar pacote anteriormente não seleccionado mysql-client-core-5.7.
A preparar para desempacotar .../2-mysql-client-core-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb ...
A descompactar mysql-client-core-5.7 (5.7.25-0ubuntu0.18.04.2) ...
A seleccionar pacote anteriormente não seleccionado mysql-client-5.7.
A preparar para desempacotar .../3-mysql-client-5.7_5.7.25-0ubuntu0.18.04.2_amd64.deb ...
A descompactar mysql-client-5.7 (5.7.25-0ubuntu0.18.04.2) ...
A seleccionar pacote anteriormente não seleccionado mysql-server-core-5.7.
A preparar para desempacotar .../4-mysql-server-core-5.7_5.7.25-0ubuntu0.18.04....

Read more...

Paride Legovini (legovini) wrote :

Thank you for your report, however it looks like a different issue from the one this bug report is about. See

https://bugs.launchpad.net/ubuntu/+source/mysql-5.7/+bug/1784466

for a workaround and a comment.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers