package mysql-server-5.7 5.7.17-0ubuntu0.16.04.2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1684072 reported by Stephen Gibbons on 2017-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-5.7 (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 16.04.2 LTS
Release: 16.04

mysql-server-5.7:
  Installed: 5.7.17-0ubuntu0.16.04.2
  Candidate: 5.7.17-0ubuntu0.16.04.2
  Version table:
 *** 5.7.17-0ubuntu0.16.04.2 500
        500 http://nz.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     5.7.17-0ubuntu0.16.04.1 500
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     5.7.11-0ubuntu6 500
        500 http://nz.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

apt-get hangs and then fails. Affecting three servers - all 16.04.2

Mysql says it's already at that version.
mysql> \s
--------------
mysql Ver 14.14 Distrib 5.7.17, for Linux (x86_64) using EditLine wrapper

Connection id: 148
Current database: mysql
Current user: root@localhost
SSL: Not in use
Current pager: stdout
Using outfile: ''
Using delimiter: ;
Server version: 5.7.17-0ubuntu0.16.04.2 (Ubuntu)
Protocol version: 10
Connection: localhost via TCP/IP
Server characterset: latin1
Db characterset: latin1
Client characterset: utf8
Conn. characterset: utf8
TCP port: 3306
Uptime: 42 min 40 sec

apt update fails with request to perform 'dpkg --configure -a'
apt -f install fails with request to perform 'dpkg --configure -a'
Unable to add other updates.

Why does it try to configure5.7.17-0ubuntu0.16.04.1 ?
After the attempts to upgrade .mylogin.cnf or .my.cnf are not respected/read !
The database server is left down !

Setting up mysql-server-5.7 (5.7.17-0ubuntu0.16.04.2) ...
+ . /usr/share/debconf/confmodule
++ '[' '!' '' ']'
++ PERL_DL_NONLAZY=1
++ export PERL_DL_NONLAZY
++ '[' '' ']'
++ exec /usr/share/debconf/frontend /var/lib/dpkg/info/mysql-server-5.7.postinst configure 5.7.17-0ubuntu0.16.04.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers