package mysql-server-5.7 5.7.15-0ubuntu0.16.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1627224 reported by Fabio on 2016-09-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-5.7 (Ubuntu)
Undecided
Unassigned

Bug Description

"do-release-upgrade" on Ubuntu14.04.5, both mysql-server-5.7 and php7 didn't installed properly, sites that where working before the upgrade, now just show PHP code in browser :-(

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: mysql-server-5.7 5.7.15-0ubuntu0.16.04.1
ProcVersionSignature: Ubuntu 3.13.0-96.143-generic 3.13.11-ckt39
Uname: Linux 3.13.0-96-generic i686
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: i386
Date: Sat Sep 24 03:27:57 2016
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2013-01-23 (1339 days ago)
InstallationMedia: Ubuntu-Server 12.04.1 LTS "Precise Pangolin" - Release i386 (20120817.3)
KernLog:

Logs.var.log.daemon.log:

MySQLConf.etc.mysql.conf.d.mysql.cnf: [mysql]
MySQLConf.etc.mysql.conf.d.mysqld_safe_syslog.cnf:
 [mysqld_safe]
 syslog
MySQLConf.etc.mysql.conf.d.mysqldump.cnf:
 [mysqldump]
 quick
 quote-names
 max_allowed_packet = 16M
MySQLConf.etc.mysql.mysql.conf.d.mysqld_safe_syslog.cnf:
 [mysqld_safe]
 syslog
MySQLVarLibDirListing: ['ib_logfile1', 'mysql_upgrade_info', 'debian-5.5.flag', 'mysql', 'performance_schema', 'ibdata1', 'ib_logfile0']
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-3.13.0-96-generic root=UUID=6014f427-d80c-4889-a3d0-d39f01f3d894 ro
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: mysql-5.7
Title: package mysql-server-5.7 5.7.15-0ubuntu0.16.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to xenial on 2016-09-24 (0 days ago)

Fabio (fabio-battinini) wrote :
tags: removed: need-duplicate-check

From the log:
Renaming removed key_buffer and myisam-recover options (if present)
ERROR: Unable to start MySQL server:
2016-09-24T01:27:57.868365Z 0 [ERROR] unknown variable 'log_slow_queries=/var/log/mysql/mysql-slow.log'
2016-09-24T01:27:57.870624Z 0 [ERROR] Aborting
Please take a look at https://wiki.debian.org/Teams/MySQL/FAQ for tips on fixing common upgrade issues.
Once the problem is resolved, run apt-get --fix-broken install to retry.
dpkg: error processing package mysql-server-5.7 (--configure):
 subprocess installed post-installation script returned error exit status 1

So effectively this is a change in mysql that no more supports the old configuration.
The upgrade path takes care of the most common cases, but some can't be automated.

In your older setup you likely had some log entries that mentioned it being deprecated (as it was in 5.5), but now it stopped being supported at all.

Please adapt configuration for this (and maybe more) and you should be fine again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers