mysql-server-5.7.postinst fails with "mysql_upgrade: Got error: 1862: Your password has expired. To log in you must change it using a client that supports expired passwords. while connecting to the MySQL server"

Bug #1605490 reported by Roland on 2016-07-22
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
mysql-5.7 (Ubuntu)
High
devansh srivastava

Bug Description

E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: mysql-server-5.7 5.7.13-0ubuntu0.16.04.2
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
Date: Fri Jul 22 08:29:13 2016
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2015-10-25 (270 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
Logs.var.log.daemon.log:

MySQLConf.etc.mysql.conf.d.mysql.cnf: [mysql]
MySQLConf.etc.mysql.conf.d.mysqldump.cnf:
 [mysqldump]
 quick
 quote-names
 max_allowed_packet = 16M
MySQLConf.etc.mysql.mysql.conf.d.mysqld_safe_syslog.cnf:
 [mysqld_safe]
 syslog
MySQLVarLibDirListing: ['sys', 'performance_schema', 'ib_logfile1', 'debian-5.7.flag', 'mysql', 'auto.cnf', 'ib_buffer_pool', 'ib_logfile0', 'ibdata1']
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-31-generic root=UUID=ca9aeb16-be52-4448-84e9-8d0101dfc7da ro quiet splash nomdmonddf nomdmonisw vt.handoff=7
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: mysql-5.7
Title: package mysql-server-5.7 5.7.13-0ubuntu0.16.04.2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to xenial on 2016-04-24 (88 days ago)
modified.conffile..etc.apparmor.d.usr.sbin.mysqld: [modified]
modified.conffile..etc.mysql.mysql.conf.d.mysqld.cnf: [modified]
mtime.conffile..etc.apparmor.d.usr.sbin.mysqld: 2016-05-30T09:27:13.689723
mtime.conffile..etc.mysql.mysql.conf.d.mysqld.cnf: 2016-04-28T07:56:35.671164

Roland (roland-schaffer) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mysql-5.7 (Ubuntu):
status: New → Confirmed
Hristian (hristian-carabulea) wrote :

I am not sure if this a correct alternate way out of the never-ending-bug. This is all I found when I googled the problem. I just did not want to have an unclosed update on my 16.04.01 32-bit machine. I followed these steps and had a full mysql reinstall.

sudo rm -rf /etc/mysql /var/lib/mysql
sudo apt-get purge mysql*
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get dist-upgrade
sudo apt-get install mysql-server

Now when I type, "mysql -V" I get: mysql Ver 14.14 Distrib 5.7.13, for Linux (i686) using EditLine wrapper.

And when I do an update and upgrade is all OK now. Before I used to get constantly an error messagse of failed updates or something like that.

Changed in mysql-5.7 (Ubuntu):
importance: Undecided → High
Robie Basak (racb) on 2016-08-02
summary: - package mysql-server-5.7 5.7.13-0ubuntu0.16.04.2 failed to
- install/upgrade: subprocess installed post-installation script returned
- error exit status 1
+ mysql-server-5.7.postinst fails with "mysql_upgrade: Got error: 1862:
+ Your password has expired. To log in you must change it using a client
+ that supports expired passwords. while connecting to the MySQL server"
Changed in mysql-5.7 (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → devansh srivastava (devanshdreams)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers