MySQL missing libpluginmecab.so

Bug #1576563 reported by Zach Leigh on 2016-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-5.7 (Ubuntu)
Medium
Lars Tangvald

Bug Description

Using Kubuntu 16.04.
MySQL documentation states that MySQL versions greater than 5.7.6 should include libpluginmecab.so by default but it is not included in the Ubuntu package and is not in the repos.

Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

This was intentional because mecab is in universe in Ubuntu, but the rules in Ubuntu around build dependencies in universe have changed recently. Since in MySQL mecab support is a plugin, we could ship a package with this plugin in universe and only that will depend on libmecab.

Changed in mysql-5.7 (Ubuntu):
milestone: none → ubuntu-16.06
assignee: nobody → Lars Tangvald (lars-tangvald)
status: New → Triaged
importance: Undecided → Medium
Robie Basak (racb) on 2016-08-05
Changed in mysql-5.7 (Ubuntu):
milestone: ubuntu-16.06 → none
hajimuz (hajimuz) wrote :

So the ubuntu package of this plugin is still missing?

hajimuz (hajimuz) wrote :

Here is a simple workaround for those might reach here in the future:

1. Add apt repo from Oracle as follow. (or download the config deb from https://repo.mysql.com/)

deb http://repo.mysql.com/apt/ubuntu/ xenial mysql-apt-config
deb http://repo.mysql.com/apt/ubuntu/ xenial mysql-5.7
deb http://repo.mysql.com/apt/ubuntu/ xenial mysql-tools

2. Install MySQL server with `apt-get install mysql-server`.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers