missing mysql-testsuite metapackage

Bug #959683 reported by Steve Beattie on 2012-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-5.5 (Ubuntu)
High
Clint Byrum
Precise
High
Clint Byrum

Bug Description

Attempting to run the mysql testsuite fails, with a message claiming that the InnoDB engine is unknown/unsupported.

Steps to reproduce:

setup:
1) apt-get install mysql-testsuite mysql-server
2) sudo mkdir /var/lib/mysql/testsuite/
3) sudo chown $USER.$USER /var/lib/mysql/testsuite/
4) mkdir /var/lib/mysql/testsuite/{var,tmp}
5) cd /usr/lib/mysql-testsuite

running the testsuite
6) ./mysql-test-run.pl --force --vardir=/var/tmp/mysql/testsuite/var/ --tmpdir=/var/tmp/mysql/testsuite/tmp --comment=normal --timer --skip-ndbcluster --report-features

This fails with output like:

======
120319 13:27:18 [ERROR] An old style --language value with language specific part detected: /usr/share/mysql/english/
120319 13:27:18 [ERROR] Use --lc-messages-dir without language specific part instead.
120319 13:27:18 [Note] Plugin 'FEDERATED' is disabled.
MySQL Version 5.5.20

##############################################################################
# normal
##############################################################################
Checking supported features...
 - skipping ndbcluster
 - SSL connections supported
Collecting tests...
 - adding combinations for binlog
 - adding combinations for rpl
vardir: /var/tmp/mysql/testsuite/var/
Removing old var directory...
Creating var directory '/var/tmp/mysql/testsuite/var/'...
Installing system database...
mysql-test-run: *** ERROR: Error executing mysqld --bootstrap
Could not install system database from /var/tmp/mysql/testsuite/var//tmp/bootstrap.sql
see /var/tmp/mysql/testsuite/var//log/bootstrap.log for errors
======

The contents of /var/tmp/mysql/testsuite/var//log/bootstrap.log are as follows:

======
/usr/sbin/mysqld --no-defaults --bootstrap --basedir=/usr --datadir=/var/tmp/mysql/testsuite/var//install.db --loose-skip-innodb --loose-skip-falcon --loose-skip-ndbcluster --tmpdir=/var/tmp/mysql/testsuite/var//tmp/ --core-file --language=/usr/share/mysql/english --character-sets-dir=/usr/share/mysql/charsets
120319 13:27:25 [ERROR] An old style --language value with language specific part detected: /usr/share/mysql/english/
120319 13:27:25 [ERROR] Use --lc-messages-dir without language specific part instead.
120319 13:27:25 [Note] Plugin 'FEDERATED' is disabled.
120319 13:27:25 [Note] Plugin 'InnoDB' is disabled.
120319 13:27:25 [Warning] /usr/sbin/mysqld: unknown option '--loose-skip-falcon'
120319 13:27:25 [Warning] /usr/sbin/mysqld: unknown option '--loose-skip-ndbcluster'
120319 13:27:25 [ERROR] Unknown/unsupported storage engine: InnoDB
120319 13:27:25 [ERROR] Aborting

120319 13:27:25 [Note] /usr/sbin/mysqld: Shutdown complete
======

It seems that the mysql-testsuite is trying to enable the InnoDB engine and failing; according to upstream documentation, the InnoDB engine is the default engine in mysql-5.5, so perhaps the testsuite has not been updated to take this into account?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: mysql-server-5.5 5.5.20-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-17.26~aamount-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Mon Mar 19 13:19:20 2012
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120103)
Logs.var.log.daemon.log:

MySQLConf.etc.mysql.conf.d.mysqld.safe.syslog.cnf:
 [mysqld_safe]
 syslog
MySQLVarLibDirListing: False
ProcEnviron:
 TERM=screen
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: mysql-5.5
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Steve Beattie (sbeattie) wrote :
Steve Beattie (sbeattie) wrote :

Oh, the command run above ('./mysql-test-run.pl --force --vardir=/var/tmp/mysql/testsuite/var/ --tmpdir=/var/tmp/mysql/testsuite/tmp --comment=normal --timer --skip-ndbcluster --report-features') is based on the commands generated for the 'make test-bt' target; see mysql-test/CMakeLists.txt for details.

Steve Beattie (sbeattie) on 2012-03-19
Changed in mysql-5.5 (Ubuntu):
assignee: nobody → Clint Byrum (clint-fewbar)
Changed in mysql-5.5 (Ubuntu):
importance: Undecided → High
status: New → In Progress
Clint Byrum (clint-fewbar) wrote :

Hi Steve, thanks for the report. It looks like I forgot to add a metapackage for 'mysql-testsuite' so this was actually runing the 5.1.58 test suite.

I've committed a fix for this to the main bzr repository, it should be uploaded in the next few days. For now, to work around it, use 'mysql-testsuite-5.5'.

Changed in mysql-5.5 (Ubuntu):
status: In Progress → Fix Committed
Changed in mysql-5.5 (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-2
summary: - mysql testsuite fails to run; needs updating for InnoDB as default
- engine?
+ missing mysql-testsuite metapackage
tags: added: rls-mgr-p-tracking
Martin Pitt (pitti) on 2012-03-26
Changed in mysql-5.5 (Ubuntu Precise):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
milestone: ubuntu-12.04 → ubuntu-12.04-beta-2
Changed in mysql-5.5 (Ubuntu Precise):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-5.5 - 5.5.22-0ubuntu1

---------------
mysql-5.5 (5.5.22-0ubuntu1) precise; urgency=low

  * New upstream release (LP: #965523)
  * d/mysql-server-5.5.mysql.upstart: Add respawn limit and code
    to exit ping loop if mysqld needs to be respawned. (LP: #711635)
  * New upstream bugfix release.
  * Refreshed patches
  * d/control: Build-Dep on dh-apparmor (LP: #948481)
  * d/p/fix-mysqldump-test.patch: Fixes unreliable test introduced in
    new upstream version. http://bugs.mysql.com/bug.php?id=64401
  * d/control: Re-add empty meta-package for mysql-testsuite so users
    will get the 5.5 version on upgrade and when installing
    mysql-testsuite. (LP: #959683)
 -- Clint Byrum <email address hidden> Thu, 29 Mar 2012 17:31:30 -0700

Changed in mysql-5.5 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.