mysql-5.5 test suite no longer works because of timestamps in the past

Bug #1419262 reported by Steve Langasek on 2015-02-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-5.5 (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned
mysql-5.6 (Ubuntu)
Undecided
Unassigned
Trusty
High
dann frazier

Bug Description

Since February 2, the mysql-5.5 testsuite has been failing consistently under autopkgtest. This appears to be caused by a bug in the test suite that uses keys with fixed time stamps, causing problems when those keys' expiration date is in the past.

The output in the adt log is:

CURRENT_TEST: main.ssl_8k_key
mysqltest: At line 5: command "$MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1" failed

Output from before failure:
ERROR 2026 (HY000): SSL connection error: ASN: after date in the past
exec of '/usr/bin/mysql --defaults-file=/tmp/tmp.wCAnQbZaNW/var/my.cnf --ssl --ssl-key=/usr/lib/mysql-testsuite/std_data/client-key.pem --ssl-cert=/usr/lib/mysql-testsuite/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1' failed, error: 256, status: 1, errno: 0

 - saving '/tmp/tmp.wCAnQbZaNW/var/log/main.ssl_8k_key/' to '/tmp/tmp.wCAnQbZaNW/var/log/main.ssl_8k_key/'
[...]
Failing test(s): rpl.rpl_heartbeat_ssl rpl.rpl_ssl rpl.rpl_ssl1 main.ssl_8k_key

The full output of the failing test run can be found at <https://jenkins.qa.ubuntu.com/job/vivid-adt-mysql-5.5/31/ARCH=amd64,label=adt/>.

I have marked this package as non-blocking for autopkgtest due to these failures. It's therefore important that this be fixed soon, since until it is resolved we are not going to be catching any other possible regressions introduced by changes in mysql-5.5's dependencies.

Steve Langasek (vorlon) on 2015-02-07
Changed in mysql-5.5 (Ubuntu):
importance: Undecided → High
Norvald H. Ryeng (nryeng) wrote :

This bug has been fixed in MySQL 5.5.42.

Robie Basak (racb) on 2015-02-16
tags: added: mysql-5.6-transition
Robie Basak (racb) wrote :

Fixed in mysql-5.6, but no plans to fix mysql-5.5 as it will be removed shortly. Removal is bug 1417328, but waiting on my upload of percona-xtradb-cluster-5.6 which I am planning to do today.

Changed in mysql-5.6 (Ubuntu):
status: New → Fix Released
Changed in mysql-5.5 (Ubuntu):
status: New → Invalid
status: Invalid → Won't Fix
dann frazier (dannf) on 2015-07-10
Changed in mysql-5.6 (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → dann frazier (dannf)
importance: Undecided → High
Changed in mysql-5.5 (Ubuntu Trusty):
status: New → Invalid

Hello Steve, or anyone else affected,

Accepted mysql-5.6 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mysql-5.6/5.6.19-0ubuntu0.14.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mysql-5.6 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

The SSL tests no longer fail, but the mysql5.6 package is still failing its test suite, now because of the test 'main.ctype_uca'.

The failure can be found at <https://jenkins.qa.ubuntu.com/job/trusty-adt-mysql-5.6/15/ARCH=amd64,label=adt/console>:

main.ctype_uca [ fail ]
        Test ended at 2015-07-17 17:52:51

CURRENT_TEST: main.ctype_uca
mysqltest: At line 554: command "remove_file" failed with error 1. my_errno=13

The result from queries just before the failure was:
< snip >
1 SIMPLE t1 range c c 42 NULL 3 Using where; Using index
SELECT hex(c), hex(weight_string(c)) FROM t1 WHERE c LIKE 'a%' ORDER BY c;
hex(c) hex(weight_string(c))
61 120F
61F0909080 120F30D2
61EFBFBF 120FFBC1FFFF
61F48FBFBF 120FFBE1FFFF
SELECT hex(c), hex(weight_string(c)), c FROM t1 WHERE c LIKE _utf32 0x10400 ORDER BY c, BINARY c;
hex(c) hex(weight_string(c)) c
F0909080 30D2 ����
F09090A8 30D2 ����
SELECT hex(c), hex(weight_string(c)), c FROM t1 WHERE c LIKE _utf32 0x10428 ORDER BY c, BINARY c;
hex(c) hex(weight_string(c)) c
F0909080 30D2 ����
F09090A8 30D2 ����
DROP TABLE t1;
#
# Bug #16204175 : COLLATION NAME MISSING FROM LOG MESSAGES
# ABOUT LDML DEFINITION PROBLEMS
#

More results from queries before failure can be found in /tmp/tmp.cJlnK7IBON/var/log/ctype_uca.log

 - saving '/tmp/tmp.cJlnK7IBON/var/log/main.ctype_uca/' to '/tmp/tmp.cJlnK7IBON/var/log/main.ctype_uca/'

Retrying test main.ctype_uca, attempt(2/3)...

main.ctype_uca [ retry-fail ]
        Test ended at 2015-07-17 17:52:53

CURRENT_TEST: main.ctype_uca
mysqltest: At line 553: command "copy_file" failed with error 1. my_errno=17

The result from queries just before the failure was:
< snip >
1 SIMPLE t1 range c c 42 NULL 3 Using where; Using index
SELECT hex(c), hex(weight_string(c)) FROM t1 WHERE c LIKE 'a%' ORDER BY c;
hex(c) hex(weight_string(c))
61 120F
61F0909080 120F30D2
61EFBFBF 120FFBC1FFFF
61F48FBFBF 120FFBE1FFFF
SELECT hex(c), hex(weight_string(c)), c FROM t1 WHERE c LIKE _utf32 0x10400 ORDER BY c, BINARY c;
hex(c) hex(weight_string(c)) c
F0909080 30D2 ����
F09090A8 30D2 ����
SELECT hex(c), hex(weight_string(c)), c FROM t1 WHERE c LIKE _utf32 0x10428 ORDER BY c, BINARY c;
hex(c) hex(weight_string(c)) c
F0909080 30D2 ����
F09090A8 30D2 ����
DROP TABLE t1;
#
# Bug #16204175 : COLLATION NAME MISSING FROM LOG MESSAGES
# ABOUT LDML DEFINITION PROBLEMS
#

More results from queries before failure can be found in /tmp/tmp.cJlnK7IBON/var/log/ctype_uca.log

 - saving '/tmp/tmp.cJlnK7IBON/var/log/main.ctype_uca/' to '/tmp/tmp.cJlnK7IBON/var/log/main.ctype_uca/'

Test main.ctype_uca has failed 2 times, no more retries!

The problem occurs on both amd64 and i386.

This appears to be a new test is the latest upload of mysql5.6 and should probably just be disabled? Nevertheless, this should be resolved before promoting this package since otherwise the problem of the package failing its test suite has not been addressed...

tags: added: verification-failed
removed: verification-needed
Download full text (3.7 KiB)

On Fri, Jul 17, 2015 at 2:56 PM, Steve Langasek
<email address hidden> wrote:
> The SSL tests no longer fail, but the mysql5.6 package is still failing
> its test suite, now because of the test 'main.ctype_uca'.
>
> The failure can be found at <https://jenkins.qa.ubuntu.com/job/trusty-
> adt-mysql-5.6/15/ARCH=amd64,label=adt/console>:
>
> main.ctype_uca [ fail ]
> Test ended at 2015-07-17 17:52:51
>
> CURRENT_TEST: main.ctype_uca
> mysqltest: At line 554: command "remove_file" failed with error 1. my_errno=13
>
> The result from queries just before the failure was:
> < snip >
> 1 SIMPLE t1 range c c 42 NULL 3 Using where; Using index
> SELECT hex(c), hex(weight_string(c)) FROM t1 WHERE c LIKE 'a%' ORDER BY c;
> hex(c) hex(weight_string(c))
> 61 120F
> 61F0909080 120F30D2
> 61EFBFBF 120FFBC1FFFF
> 61F48FBFBF 120FFBE1FFFF
> SELECT hex(c), hex(weight_string(c)), c FROM t1 WHERE c LIKE _utf32 0x10400 ORDER BY c, BINARY c;
> hex(c) hex(weight_string(c)) c
> F0909080 30D2 ����
> F09090A8 30D2 ����
> SELECT hex(c), hex(weight_string(c)), c FROM t1 WHERE c LIKE _utf32 0x10428 ORDER BY c, BINARY c;
> hex(c) hex(weight_string(c)) c
> F0909080 30D2 ����
> F09090A8 30D2 ����
> DROP TABLE t1;
> #
> # Bug #16204175 : COLLATION NAME MISSING FROM LOG MESSAGES
> # ABOUT LDML DEFINITION PROBLEMS
> #
>
> More results from queries before failure can be found in
> /tmp/tmp.cJlnK7IBON/var/log/ctype_uca.log
>
> - saving '/tmp/tmp.cJlnK7IBON/var/log/main.ctype_uca/' to
> '/tmp/tmp.cJlnK7IBON/var/log/main.ctype_uca/'
>
> Retrying test main.ctype_uca, attempt(2/3)...
>
> main.ctype_uca [ retry-fail ]
> Test ended at 2015-07-17 17:52:53
>
> CURRENT_TEST: main.ctype_uca
> mysqltest: At line 553: command "copy_file" failed with error 1. my_errno=17
>
> The result from queries just before the failure was:
> < snip >
> 1 SIMPLE t1 range c c 42 NULL 3 Using where; Using index
> SELECT hex(c), hex(weight_string(c)) FROM t1 WHERE c LIKE 'a%' ORDER BY c;
> hex(c) hex(weight_string(c))
> 61 120F
> 61F0909080 120F30D2
> 61EFBFBF 120FFBC1FFFF
> 61F48FBFBF 120FFBE1FFFF
> SELECT hex(c), hex(weight_string(c)), c FROM t1 WHERE c LIKE _utf32 0x10400 ORDER BY c, BINARY c;
> hex(c) hex(weight_string(c)) c
> F0909080 30D2 ����
> F09090A8 30D2 ����
> SELECT hex(c), hex(weight_string(c)), c FROM t1 WHERE c LIKE _utf32 0x10428 ORDER BY c, BINARY c;
> hex(c) hex(weight_string(c)) c
> F0909080 30D2 ����
> F09090A8 30D2 ����
> DROP TABLE t1;
> #
> # Bug #16204175 : COLLATION NAME MISSING FROM LOG MESSAGES
> # ABOUT LDML DEFINITION PROBLEMS
> #
>
> More results from queries before failure can be found in
> /tmp/tmp.cJlnK7IBON/var/log/ctype_uca.log
>
> - saving '/tmp/tmp.cJlnK7IBON/var/log/main.ctype_uca/' to
> '/tmp/tmp.cJlnK7IBON/var/log/main.ctype_uca/'
>
> Test main.ctype_uca has failed 2 times, no more retries!
>
> The problem occurs on both amd64 and i386.
>
> This ap...

Read more...

Adam Conrad (adconrad) wrote :

The mysql-5.6 autopkgtests are now passing again.

tags: added: verification-done
removed: verification-failed

This is fixed, 5.5 works fine in autopkgtest history and this partifular issue here was fixed in 5.6. Updating the task states.

Note: there is a follow up issue around rpl.rpl_row_img_sanity rpl.rpl_test_framework main.ctype_uca - but that is another issue

Changed in mysql-5.6 (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers