mysql-5.5 still built using GCC-4.4, should be built with the default GCC

Bug #1162139 reported by Matthias Klose on 2013-03-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-5.5 (Debian)
Fix Released
Unknown
mysql-5.5 (Ubuntu)
Critical
Robie Basak
Raring
High
Unassigned
Saucy
Critical
Robie Basak

Bug Description

mysql-5.5 still built using GCC-4.4, should be built with the default GCC

Matthias Klose (doko) wrote :

last package blocking demotion of GCC-4.4

Changed in mysql-5.5 (Debian):
status: Unknown → Confirmed
Robie Basak (racb) on 2013-04-02
Changed in mysql-5.5 (Ubuntu Raring):
assignee: nobody → Robie Basak (racb)
Robie Basak (racb) wrote :

The underlying difficulty here is that using the current gcc breaks an openssl API related test (des_encrypt).

It seems that the options are:

1. Link with openssl.
2. Disable des_encrypt support.
3. Update the embedded yassl if that can fix the problem.
4. Cherry-pick from upstream yassl if that can fix the problem.
5. Link with GnuTLS instead.
6. Carry on with gcc-4.4.

I'll keep looking into it.

Robie Basak (racb) wrote :

I've concluded that the best thing to do is to disable the i386 assembly optimisations altogether. This was discussed in the Debian bug last year, and gcc-4.4 was used as a workaround. I've asked them to revisit this again.

I am reluctant to suggest anything else, since given the current swing in interest towards MariaDB and Percona, I think it is prudent to keep our delta against Debian and upstream minimal. We could fix the i386 assembly so that upstream could accept it, but I don't think that's a useful use of time. But if anyone else wants to have a go at that, please go ahead.

Changed in mysql-5.5 (Ubuntu Raring):
assignee: Robie Basak (racb) → nobody
Clint Byrum (clint-fewbar) wrote :

Note that this is also now tracked in a second bug in Debian

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=707280

They may be merged at some point. That one is RC, and I'm working on a fix for Debian now.

Matthias Klose (doko) wrote :

again, not yet fixed for saucy ...

Changed in mysql-5.5 (Ubuntu):
importance: High → Critical
milestone: ubuntu-13.04-beta-1 → ubuntu-13.09
Robie Basak (racb) wrote :

<rbasak> SpamapS: any update on bug 1162139/debian 678252 please? You had marked it pending...
<SpamapS> rbasak: we are stalled on MySQL 5.5.33 failing to build due to broken tests
<SpamapS> rbasak: the fix is in the svn repo tho
<rbasak> SpamapS: thanks. I'll try cherry-picking that then I guess.

Changed in mysql-5.5 (Ubuntu Saucy):
assignee: nobody → Robie Basak (racb)
Robie Basak (racb) on 2013-09-18
Changed in mysql-5.5 (Ubuntu Saucy):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-5.5 - 5.5.32-0ubuntu7

---------------
mysql-5.5 (5.5.32-0ubuntu7) saucy; urgency=low

  * d/rules, d/control: remove gcc-4.4 dependency and disable X86 assembly in
    taocrypt (LP: #1162139).
    - Cherry-pick from Debian svn r2231 with thanks to Clint Byrum.
 -- Robie Basak <email address hidden> Wed, 18 Sep 2013 10:02:09 +0000

Changed in mysql-5.5 (Ubuntu Saucy):
status: In Progress → Fix Released
Changed in mysql-5.5 (Debian):
status: Confirmed → Fix Released
Robie Basak (racb) on 2014-03-13
Changed in mysql-5.5 (Ubuntu Raring):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.